• 0
rubicon

raccourci clavier pour capture d'écran - impossible de l'activer

Question

Bonsoir,

 

J'ai acheté un ordi portable avec eOS Loki 64bit installé dessus cet automne.

Je n'arrive pas à faire des imprime-écrans depuis la touche du clavier prévue pour ça. La touche est en "accès direct" sur le clavier et s'appelle "Impécr Syst", pas besoin de cliquer sur Fn (Fonction) ou shift ou Ctrl. Quand je clique sur la touche, rien ne se passe.

En plus du logiciel standard de capture écran, j'ai installé shutter. Tous deux fonctionnent bien (avec la souris).

  • Dans mes paramètres, je vois que la fonction de capture écran est désactivée:

HaShIKKeV6ej.png

 

Je ne sais comment l'activer. Lorsque je sélectionne la ligne "prendre une capture d'écran" comme sur l'image ci-dessus, et que je clique sur la touche "Impécr Syst" de mon clavier, le "désactivé" ne change pas.

  • Quand immédiatement ensuite je clique sur "Alt-Tab" pour changer de fenêtre, Loki affiche ceci:

EXJLiJXXFP9v.png

 

  • Ensuite pour "jouer", je sélectionne le paramètre "copier la capture d'écran", et clique sur la touche "Impécr Syst" de mon clavier, pour voir si elle veut bien s'appliquer ici. Résultat, le raccouci clavier Ctrl.Impr qui était présent est remplacé par un beau "désactivé"

Là je coince. Si quelqu'un pouvait m'aider, je lui serais très reconnaissant.

Merci d'avance,

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

17 réponses à cette question

  • 0

Voici la commande qui te permettra de récupérer la fonctionnalité imprime écran avec la touche "Print Screen"

gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot 'Print'

Nikos

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonsoir,

 

Depuis un terminal, pourrais-tu me donner le résultat de la commande suivante :

gsettings get org.gnome.settings-daemon.plugins.media-keys screenshot

Merci.

 

Nikos

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour Nikos,

 

Merci de ton message. Voici le résultat (avec mon compte admin):

~$ gsettings get org.gnome.settings-daemon.plugins.media-keys screenshot
''
~$

Bonne journée,

Rubicon

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

 

Quand tu parles de ton compte admin, tu parles de root ?

 

Nikos

 

Envoyé de mon HUAWEI NXT-L29 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Root ? Depuis elementary ? Tu as réactivé ce compte ?

 

Ce n'est pas conseillé !

 

Lorsque tu te loggues sur ton bureau, tu utilises quel compte ?

 

Envoyé de mon HUAWEI NXT-L29 en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je n'ai qu'un compte, le root. Je me connecte avec ce compte pour démarrer mon ordinateur.

Lorsque j'ouvre mon terminal, je ne dois pas nécessairement saisir mon mot de passe root, ça dépend uniquement de la commande

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ok, Je vois pour te communiquer la commande pour restaurer ce raccourci clavier dans la soirée

 

Envoyé de mon HUAWEI NXT-L29 en utilisant Tapatalk

rubicon aime ça

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'ai exécuté la commande.

Le résultat est  :

~$ gsettings get org.gnome.settings-daemon.plugins.media-keys screenshot
'Print'

c'est donc différent d'avant, où seulement ceci apparaissait:

''

Néanmoins, cliquer sur la touche "Impécr Syst" est toujours sans conséquence. J'aurais espéré que cela déclenche une copie d'écran, mais non...

Comment être sûr que 'Print' est l'argument correct pour la commande media-keys screenshot ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

 

C'est la touche qui déclenche justement les captures.

 

Les captures d'écrans se trouvent directement dans le dossier ~/Images

 

Tu peux y regarder ?

 

Nikos

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

le dossier ~/Images reste vide.

Dans les paramètres de configurations, il apparait toujours ceci : HaShIKKeV6ej.png

 

:(

 

j'ai l'impression qu'aucune action n'est attribuée à cette touche de mon clavier.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour rubicon,

 

Pourrais-tu essayer cette commande :

gsettings list-recursively  | grep screenshot

et nous donner le résultat ?

 

Nikos




			
		

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour Nikos,

 

Voici:

:~$ gsettings list-recursively  | grep screenshot
org.gnome.totem active-plugins ['skipto', 'autoload-subtitles', 'screensaver', 'movie-properties', 'apple-trailers', 'recent', 'vimeo', 'screenshot', 'save-file', 'media_player_keys']
org.gnome.totem screenshot-save-uri ''
org.gnome.settings-daemon.plugins.media-keys window-screenshot '<Alt>Print'
org.gnome.settings-daemon.plugins.media-keys screenshot-clip ''
org.gnome.settings-daemon.plugins.media-keys window-screenshot-clip '<Ctrl><Alt>Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot-clip '<Ctrl><Shift>Print'
org.gnome.settings-daemon.plugins.media-keys screenshot 'Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot '<Shift>Print'
org.gnome.settings-daemon.plugins.media-keys window-screenshot '<Alt>Print'
org.gnome.settings-daemon.plugins.media-keys screenshot-clip ''
org.gnome.settings-daemon.plugins.media-keys window-screenshot-clip '<Ctrl><Alt>Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot-clip '<Ctrl><Shift>Print'
org.gnome.settings-daemon.plugins.media-keys screenshot 'Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot '<Shift>Print'
net.launchpad.screenshot mouse-pointer false
net.launchpad.screenshot close-on-save false
net.launchpad.screenshot format 'png'
net.launchpad.screenshot delay 1
net.launchpad.screenshot redact false
net.launchpad.screenshot folder-dir '/home/myuser/Images'
:~$ 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

je viens de me rendre compte que la copie d'écran fonctionne enfin, merci pour votre aide!

fonctionne = une copie de l'écran entier est sauvegardée au format png dans mon dossier /images.

c'est déjà un grand progrès.

Ce que je cherche à atteindre, c'est : la pression sur le bouton "print" déclenche un programme d'imprime écran (soit le standard Elementary capture d'écran, soit shutter par exemple), de telle sorte que je sois directement en position de sélectionner la zone à copier (pas de copie de l'écran entier par défaut, pas de fichier enregistré par le clic), et ensuite après avoir sélectionné la zone, le programme me propose d'enregistrer un fichier ou copier la zone dans le presse-papier. Quelle commande dois-je exécuter pour cela ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Hello @rubicon,

Ok, c'est un bon point, voici une solution à ton second problème : il te suffit de paramétrer un raccourci clavier pour cela. Dans mon exemple, j'ai utilisé le raccourci clavier CTRL+SHIFT+F12 cela a pour objectif de lancer l'outil de capture intégré à Elementary en mode sélection, une fois ma sélection faite, l'image est sauvegardée sur disque :

Si tu souhaites avoir plus la main sur le comportement de l'outil de capture voici des informations complémentaires :

[email protected]:~$ screenshot-tool --help

Utilisation :
  screenshot-tool [OPTION...]

Options de l'aide :
  -h, --help                  Affiche les options de l'aide
  --help-all                  Affiche toutes les options de l'aide
  --help-gapplication         Afficher les options GApplication
  --help-gtk                  Affiche les options GTK+

Options de l'application :
  -w, --window                Capturer la fenêtre actuelle
  -r, --area                  Capturer une zone
  -s, --screen                Capturer l'écran en entier
  -d, --delay=Secondes        Prendre une capture avec retardateur
  -p, --grab-pointer          Inclure le pointeur dans la capture d'écran
  -e, --redact                Ajouter un système de texte
  -c, --clipboard             Save screenshot to clipboard
  --display=AFFICHAGE         Affichage X à utiliser

Par contre, je persiste sur un point ;) : sous Elementary/Ubuntu, le compte root n'est pas utilisé (d'ailleurs c'est une bonne pratique de ne pas utiliser root mais d'utiliser l'élévation de privilèges via sudo) il est même désactivé, Donc si tu te connectes via root automatiquement c'est une mauvaise pratique.

Nikos

 

20170711-snap.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant