Aller au contenu
ElementaryOS France
  • 0
ccciollll

pavé numérique par défaut dès le démarrage

Question

Bonjour,

je suis à la fois débutant sur eOS ET sur Linux.

Je suis issu du monde des macs, je n'utilise que ça depuis que j'ai abandonné mon Amiga (ou plutôt depuis que j'ai découvert le mac) en 1993 pour mes études dans le graphisme.
Je suis donc venu à eOS un peu par hasard après avoir lu que ça ressemblait à Mac. Bon, pour l'instant c'est plutôt la déception. Oui, ça ressemble à mac dans la forme (graphisme) mais pas tellement dans le fond (usage). Or c'est plutôt ça, le fond, que je recherchais (après tout, vu mon âge, j'ai vécu le passage de Classic à MacOSX, donc les graphismes qui changent, je suis rôdé).

Mais bon, c'est déjà le 2eme Linux que j'installe (il y a une semaine j'avais tenté LinuxMint) et je me fatigue de tout recommencer une 3eme fois donc je vais essayer de rester un peu plus longtemps sur eOS et voir si je peux réussir à dépasser les gros obstacles de départ pour réussir à en faire l'OS de l'ordinateur familial (car je ne suis pas seul à l'utiliser, il y a aussi ma compagne et nos 3 enfants, nous sommes tous mac-user de longue date, et je suis le plus " barbu " du lot, c'est moi qui configure les machines, pour les autres, si ce n'est pas plug&play-comme-sur-mac je vais en entendre parler et j'aurai des requêtes toutes les 2 minutes).

 

Bon bon bon.

Et donc là, comme un jeune puceau, je viens de découvrir une notion que j'ignorais totalement, la notion de " touche verrouillage numérique ". Eh oui.
Pourtant cette touche semble exister sur les claviers mac (c'est fou les trucs qu'on peut ignorer sous ses yeux pendant 20 ans) mais je n'en avais jamais eu l'usage. Vous remarquerez, sur les claviers macs, il n'y a pas de diode " verr num ". Et pour cause. Le pavé numérique marche toujours, c'est par défaut comme ça (enfin je n'ai jamais connu autre chose).

 

Et donc, après ce long préambule assomant, je pose enfin ma question (il était temps, bon dieu) : comment faire pour que le pavé numérique soit activé par défaut ?
J'ai lu sur le net plusieurs tutos à base de Terminal.
Terminal, ça ne me fait pas peur, j'utilise le terminal régulièrement sur mac, il suffit de copier coller les codes que des gentils barbus ont laissé trainer çà et là sur les forums sans ajouter de caractère de son cru et en général ça marche. Oui mais... Oui mais , MON "en général" À MOI  c'est sur MacOSX, et il n'existe qu'un seul MacOSX. Là, j'ai lu des astuces sur des forums mint, des forums ubuntu, des forums gnome ou je ne sais quoi, si ça se trouve c'est la même chose avec un nom différent... Du coup, je ne suis pas sûr qu'une astuce trouvée sur un forum LinuxMachin ou LinuxBidule pourra fonctionner sur mon ordi et son LinuxElementary. Alors avant de faire une connerie, j'ai tenté une recherche sur ce forum strictement eOS. Mais je n'ai pas trouvé de tuto pour activer le pavé numérique par défaut. Puis§je alors utiliser un tuto trouvé ailleurs ?

Ici par exemple : https://www.forum-francophone-linuxmint.fr/viewtopic.php?t=2849

Ou ici : https://forum.ubuntu-fr.org/viewtopic.php?id=189927

Partager ce message


Lien à poster
Partager sur d’autres sites

3 réponses à cette question

Recommended Posts

  • 0

Hello @ccciollll,

elementary OS fonctionne avec dconf pour la configuration, il est aussi possible soit de le faire depuis un éditeur graphique ou via la ligne de commande. Pour la ligne de commande, voici comment vérifier ce qui est déjà configuré pour ton verrouillage numérique :

gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state
gsettings get org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state

Si pour la première commande, tu as un retour à off (donc ton verrouillage numérique n'est pas activé) et si pour la deuxième commande tu as résultat à false (même en activant le verrouillage numérique de ton clavier, au redémarrage, celui-ci sera automatiquement désactivé).

Pour corriger ce comportement, tu peux saisir les deux commantes suivantes :

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on
gsettings set org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true

Tiens nous au courant.

Nikos

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour, aujourd'hui j'ai on et true, et effectivement, sans que je touche le verr num j'ai le pavé numérique fonctionnel .

Je pense que quand j'ai appuyé sur la touche verr num ça a dû solutionner le problème et mettre mon choix en mémoire.
Comme je ne connaissais pas cette touche, j'en ai fait tout un pataquès en pendant qu'il faudrait aller dans le terminal mais peut-être que les windowsiens et linuxiens trouvent normal d'appuyer sur verr num le premier jour de l'install de leur OS et de plus y penser ensuite.

 

En tout cas merci pour tes lignes de codes, si elles ne serent pas à moi, elles serviront à d'autres. Et en plus elles sont franchement simples à comprendre.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×