Aller au contenu
ElementaryOS France
  • 0
petitenajia

Désactiver le pavé tactile au démarrage

Question

Bonjour, 

Je voudrais désactiver le pave tactile de mon pc portable Asus dès le démarrage. En fait, j'ai fait des recherches pour tomber sur une ligne de commande qui me permet de désactiver le pavé tactile.

J'utilise xinput et je tape dans le terminal 

xinput set-prop 14 "Device Enabled" 0
 

Sachant que 14 chez moi correspond au pavé tactile mais comment faire, quels sont les fichiers à modifier pour que cela se fasse tout seul quand elementary OS démarre ? 

Si quelqu'un sait m'aider, je le remercie d'avance.

Merci,

Najia

Partager ce message


Lien à poster
Partager sur d’autres sites

3 réponses à cette question

Recommended Posts

  • 0

Hello @petitenajia,

elementary (comme Ubuntu) dispose d'un outils de configuration qui te permet justement de faire cette modification. Tout d'abord, on va regarder les options de ton touchpad via cette commande :

gsettings list-recursively org.gnome.desktop.peripherals.touchpad | sort

Tu vas récupérer le résultat suivant (ou équivalent) :

org.gnome.desktop.peripherals.touchpad click-method 'default'
org.gnome.desktop.peripherals.touchpad left-handed 'mouse'
org.gnome.desktop.peripherals.touchpad natural-scroll true
org.gnome.desktop.peripherals.touchpad scroll-method 'two-finger-scrolling'
org.gnome.desktop.peripherals.touchpad send-events 'enabled'
org.gnome.desktop.peripherals.touchpad speed 0.0
org.gnome.desktop.peripherals.touchpad tap-to-click true

La ligne qui nous intéresse est la suivante "org.gnome.desktop.peripherals.touchpad send-events 'enabled'", elle régit le comportement du touchpad au sein d'elementary/Ubuntu. Tu as plusieurs possibilités :

  • enabled : le touchpad est actif, même quand une souris est branchée.
  • disabled : le touchpad est inactif, même quand une souris est branchée.
  • disabled-on-external-mouse : le touchpad est inactif seulement quand une souris est branchée (note : j'ai un comportement aléatoire sur cette option).

Dans ton cas, tu souhaites que le touchpad soit désactivé (donc disabled), pour cela, il te faut utiliser cette commande :

gsettings set org.gnome.desktop.peripherals.touchpad send-events 'disabled'

Si tu souhaites revenir à l'état initiale :

gsettings reset org.gnome.desktop.peripherals.touchpad send-events

Tiens nous au courant si cela fonctionne.

Nikos

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Voilà, je viens de faire comme tu m'as indiqué mais ça ne marche pas.

Dans le doute, j'ai relancé le pc après avoir fait cette ligne de commande mais aucun résultat.

Sinon, je me demandais s'il n'y avait pas un fichier de configuration à modifier en mode root ? 

Merci pour ton aide,

Najia

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×