Aller au contenu
ElementaryOS France
Devil505

[FREYA] Driver INTEL HD

Recommended Posts

A partir d'Ubuntu 14.04, intel fournit un driver pour INTEL HD GRAPHICS, voici la manip pour l'installer avec Freya
 

TUTORIEL RETIRÉ

 

Les drivers officiels ne sont pas complètement compatibles avec Ubuntu Trusty LTS (et donc FREYA)

 

raison: https://01.org/linuxgraphics/node/471

 

 

Long story short, do not use the Graphics Installer with Ubuntu 14.04. As of Ubuntu 14.04.2, folks began to experience difficulties when using the Graphics Installer. We understand the causes of these difficulties-- they are similar to those seen in the last "LTS" release, Ubuntu 12.04. Ubuntu 14.04 is an "LTS" release-- this and future LTS releases will challenge us for similar reasons. I'll spare you the details, as they involve packaging minutiae.

As a preventive measure I am considering obsoleting (disabling) Ubuntu 14.04 altogether for the Graphics Installer-- I will update this post if and when I do. If I do, a change will be made on the "server side" (download.01.org) which will prevent users of Ubuntu 14.04 from running the Graphics Installer. Normally, we obsolete Fedora or Ubuntu versions once they are "two behind" the current release. For example, Fedora 19 became obsolete when Fedora 21 was released. But, in the best interest of users, I may have to obsolete (disable) 14.04 altogether.

The standing recommendation is: do not use the Graphics Installer with Ubuntu 14.04-- first upgrade to Ubuntu 14.10 and then run the Graphics Installer.

Cheers-- I will update this post with any actions I take.

UPDATE 18 March 2015 09:15 UTC-7: I have made the necessary change-- the Graphics Installer will no longer function on Ubuntu 14.04. Due to a variety of network factors, it may take up to 48 hours for this change to take effect. Users of Fedora or Ubuntu 14.10 should not be impacted. No additional software updates will be required.

 

 

The LTS update for 14.04.2 appears to have introduced a parallel set of X packages instead of upgrading the existing Xorg packages: If you look you'll find a set of packages with -lts-utopic apprended to the name.

What's happening is the installer adds its xorg packages: The package manager see this isn't compatible
with the -lts-utopic package and has to remove that package. Unfortunately, there is no information to tell it that the -lts-utopic package is an upgrade to the xorg package, so it removes that package and all packages associated with it.

I don't know why the LTS point release was done this way, but it makes it incompatible with the intel installer:
If the LTS had simply released updated Xorg packages, the installer would have noted the LTS packages were more recent than its own and left them alone.

 

Il faut donc utiliser le driver libre dans les dépôts.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, impossible de télécharger la version 1.0.6 de l'installer d'intel y'a plus de lien téléchargement sur la page. J'ai par contre pu installer la version 1.0.7 mais j'ai encore le message "distribution not supported" malgré la bonne modification du fichier lsb-release.

 

Je sèche là. Une idée?

Partager ce message


Lien à poster
Partager sur d’autres sites

:lol: On m'lavais jamais faite celle-là! Je t'envoie mon rib en mp, fais moi un virement de 900€ ça devrait suffire :lol:

 

Plus sérieusement, c'est dommage. Je pourrai changer de distribution mais j'ai pas envie. Je crois que j'ai adopté eOS :wub: . Même si bon, je pouvais faire fonctionner ce foutu écran tactile et installer ces satanés pilotes...

Partager ce message


Lien à poster
Partager sur d’autres sites

Toujours pas de news quant à l'installation des drivers intel ? Ça fout sacrément la mince ! chez moi le fait de pas les avoir : la vue multitâche ne fonctionne pas, le pointeur freeze régulièrement et l'hdmi n'est pas supporté ...

 

Il n'y a pas de solutions alternative ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Toujours pas de news quant à l'installation des drivers intel ? Ça fout sacrément la mince ! chez moi le fait de pas les avoir : la vue multitâche ne fonctionne pas, le pointeur freeze régulièrement et l'hdmi n'est pas supporté ...

 

Il n'y a pas de solutions alternative ?

Le tuto plus haut ne fonctionne pas ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas pour moi en tout cas: impossible de récupérer l'installateur en version 1.0.6 seulement le 1.0.7.

 

Et même avec la version 1.0.7 j'ai toujours l'alerte "distribution invalid". Mais j'ai vu qu'intel avait arrêté de le support d'ubunutu 14.04 du coup je pense que c'est normal... Et effectivement en modifiant  lsb-release par les info de la 14.10: ça fonctionne.

 

Ceci dit j'ai pas cliqué sur "installer" pque j'ai une install qui fonctionne (enfin) correctement sans les derniers pilotes, du coup je sais pas le résultat!  A tester, mais pas sur mon pc :lol:

 

Si quelqu'un est plus aventurier que moi je suis curieux de savoir le résultat (et sur quel matériel).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, 

 

Je crois bon de dire que les drivers intel sont totalement libres et directement implémentés dans le kernel.

Il n'est donc pas vitale de mettre à jour les drivers intel qui ne sont pas propriétaires comme ceux de nvidia.

 

Il existe juste un petit écart entre les drivers contenus dans freiya et ceux sortis par intel mais rien de choquant.

 

Personnellement , je ne vois pas l’intérêt d'ajouter un ppa pour un gain nul ou presque. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×