Jump to content
ElementaryOS France
Sign in to follow this  
nettlebay

Configurer le CPU en mode "performance" dès le démarrage

Recommended Posts

WARNING ! Deux-trois jour après ces manips, j'ai constaté qu'il était à nouveau sur Économie d'Energie par défaut (dans l'indicator) au démarrage... Cherchez l'erreur... Suite à une mise à jour ?

 

 

Ceci ne concerne que les processeurs INTEL
 
Depuis quelques jours, j'ai constaté que l'Indicator-cpufreq n’indique plus que deux options soit Performances et Économie d'Énergie (probablement suite à une mise à jour). De plus, au démarrage, il se remet par défaut sur Économie d'Énergie. Et par dessus tout, j'ai l'impression qu'il ne fonctionne pas correctement. 
 
J'ai essayé de trouver des solutions et n'ai trouvé que cela: http://askubuntu.com/questions/541143/indicator-cpufreq-doesnt-seem-to-work-on-14-10. Mais malheureusement, cette méthode (pour Ubuntu 14.10, il est vrai) ne fonctionne pas chez moi. C'est en relation avec Intel P-State qui est -si j'ai bien compris- un nouveau gestionnaire de performance du CPU. Je ne vais pas m'attarder la-dessus car je pense qu'on y reviendra plus tard avec un nouveau tuto sur Intel P-State et Thermald. Et de toutes manières, il ne semble pas y avoir de solution pour améliorer indicator-cpufreq. Ce n'est donc pas l'objet de ce tuto.
 
 
Maintenant et avant...
cpufreq.png    IW6Zb.png


 
"With intel_pstate, there are only two cpufreq governors: performance and powersave (there's no "ondemand")" 
 
Avec intel_pstate, il y a seulement 2 cpufreq governors, performance et powersave (économies d'énergie). Il n'y a pas de "ondemand"

 

 

Pour le vérifier:

~$ cpupower frequency-info --governors
analyzing CPU 0:
performance powersave 

 Seuls "performance" et "powersafe" sont donc disponibles.

 

 

Ce n'est pas un bug mais une nouvelle caractéristique. Donc, en principe, il n'y a rien à faire d'autant plus que intel_pstate est en principe plus performant.
 
Voir cette page http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html qui est très intéressante (mais en Anglais)
 
 
On arrive dans le vif du sujet...
 
Pour savoir si intel_pstate est installé et actif:


cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver

résultat: 
intel_pstate

Sous Freya, il est en principe activé par défaut, donc pas besoin de l'activer dans Grub. Si ce n'est pas le cas: https://www.google.fr/search?q=install+intel_pstate
 
 
Nous allons maintenant installer Linux-tools.

sudo apt-get install linux-tools-common linux-tools-generic

Ce qui nous permet de tester intel_pstate avec cpupower


~$ cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 500 MHz - 2.17 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 500 MHz and 2.17 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 2.17 GHz.
  boost state support:
    Supported: yes
    Active: yes

Cela peut varier en fonction de votre matos, évidemment.
 
 
(Pour info seulement) Pour le mettre en mode powersave (économie d'énergie):

sudo cpupower frequency-set -g powersave

NOTE: la manip' ci-dessus est en principe inutile puisqu'il est déjà en powersave par défaut...
 
 
Pour le mettre en Performance (plus intéressant déjà! Mais pas pour un laptop)


sudo cpupower frequency-set -g performance

Il est évidemment possible de faire des lanceurs avec ces commandes.
 
 
Pour que ce paramètre soit automatique au démarrage:
 
Ouvrez /etc/rc.local en root (vous pouvez utiliser Scratch en remplaçant gedit par scratch-text-editor)

sudo gedit /etc/rc.local

Dans rc.local, ajoutez cette ligne en bas juste avant exit 0

sudo cpupower frequency-set -g performance

exit 0 

 Il y a peut-être d'autres solutions moins "bourrines", mais bon, ça fonctionne... C'est le principal.
Note: pour désactiver une commande dans rc.local, il suffit de rajouter devant (à gauche) un dièse "#" et un espace. Exemple: # sudo cpupower frequency-set -g performance
 
Enregistrez et voilà, y'a plus qu'à redémarrer!
 
 
Attention! Sur un laptop (un "portable"!), le mode "performance" n'est pas conseillé au démarrage car il devrait logiquement consommer plus de batterie avec ce paramètre...
 
Je vais aussi probablement faire un tuto en traduisant la page http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html car il y a beaucoup de choses intéressantes comme souvent sur http://www.webupd8.org/ Une vraie caverne d'Ali-Baba pour geeks linuxiens!

 

Page intéressante: http://askubuntu.com/questions/523640/how-i-can-disable-cpu-frequency-scaling-and-set-the-system-to-performance

Edited by nettlebay

Share this post


Link to post
Share on other sites

Interressant, mais est-ce vraiment utile avec les dernier CPU qui gère tout seul la demande de ressource ?

Share this post


Link to post
Share on other sites

Oui, tu as sans doute raison.

 

À ton avis, il vaut mieux enlever carrément ce truc-là et même cpufreq, etc.. ? (avec un CPU récent)

En tous cas, deux-trois jour après mes manips, j'ai constaté qu'il était à nouveau sur Économie d'Energie par défaut (dans l'indicator) au démarrage... C'est dingue, ça!

Quelquefois, il repasse même tout seul sur ce réglage en cours de session (il me semble. Pas sûr...)

Je vais donc ajouter un avertissement à mon tuto. 

 

sur performances:

Intel® Celeron® CPU  N2807  @ 1.58GHz : 2166,00MHz
Intel® Celeron® CPU  N2807  @ 1.58GHz : 2121,00MHz
 
Economie d'énergie:
Intel® Celeron® CPU  N2807  @ 1.58GHz : 606,00MHz
Intel® Celeron® CPU  N2807  @ 1.58GHz : 582,00MHz
 
Résultats collectés avec HardInfo 0.5.1
 

Share this post


Link to post
Share on other sites

Tu as parfaitement raison !

 

Je viens de faire un nouveau test avec Hardinfo en ouvrant un nouvel onglet assez lourd dans Chrome et avec le réglage sur Economie d'Energie. 

(Et il est resté comme ça un moment)...:

 

-Processors-
Intel® Celeron® CPU  N2807  @ 1.58GHz : 2166,00MHz
Intel® Celeron® CPU  N2807  @ 1.58GHz : 2165,00MHz
 
Donc je vire Indicator-cpufreq, il ne sert à rien! J'en profite pour virer cpufreq aussi. On verra bien... (je ferai d'autres tests après redémarrage)

Share this post


Link to post
Share on other sites

Donc après redémarrage, je me suis rendu-compte que ça fonctionne aussi bien voire mieux

 

J'ai supprimé: 

  • cpufrequtils
  • indicator-cpufreq
  • cpufreq ? Il y avait un troisième, mais je ne le retrouve pas dans l'historique de Synaptic. Et cpufreq n'apparaît pas dans Synaptic. Bizarre, bizarre...

Share this post


Link to post
Share on other sites

Au niveau du refroidissement, c'est beaucoup mieux!

 

C'est peut-être lié à l'installation de Thermald, quelques jours avant de désinstaller cpufreq.

 

J'ai attendu quelques jours pour en être sûr...

Pour vous donner une idée: mes CPU sont à 47ºC en ce moment-même. La température est 30ºC dans la pièce (comme dehors... Je suis aux Antilles). J'ai un ventilateur "colonne" dirigé principalement vers mon mini-ordi (un Brix qui tient dans la main. Un "barebone" à 100 € livré sans HD ni RAM). Il est fixé avec un système VESA derrière mon moniteur. Cet ordi a un refroidissement passif (aucun ventilateur). Avant la désinstallation de cpufreq et consors, il était en général à 56º. La gestion de la chaleur est donc meilleure sans CPUfreq.

 

Info: La gestion de mes sondes est imparfaite sous Ubuntu. J'ai constaté en comparant avec le bios environ -18% d'erreur. C'est à dire que lorsqu'il affiche 50º, c'est plutôt 58º qu'il faut lire... Mais bon, cela reste très correct.

Share this post


Link to post
Share on other sites

Voici la partie du manuel concernant le "Vesa bracket". J'ai vraiment la flemme de démonter et en plus, je suis pas sûr que les photos "rendent bien" (noir sur noir, c'est bof-bof...)

Seul petit problème que j'ai eu: les trous de vis de mon LG Flatron ne correspondaient pas exactement à ceux de la plaque-support je n'ai donc pu utiliser que 2 ou 3 vis sur 4. Mais bon, c'est bien fixé et l'ordi ne pesant que quelques centaines de grammes, pas de gros risques... Et même si ça tombe, mon HDD est un SSD. Ça tombera pas loin en plus, grâce aux câbles.

J'ai légèrement bricolé pour écarter un peu le support par rapport au moniteur de manières à créer une "cheminée" pour l'air chaud (le moniteur chauffe plus que l'ordi!). Le Brix a un refroidissement passif (Fanless). Depuis que j'ai supprimé Cpufreq et tutti-quanti et installé Thermald, il chauffe très peu. En ce moment même: 46º indiqué pour le CPU et il fait 31º dans la pièce (je suis aux Antilles) mais j'ai un ventilateur "colonne" tout proche qui est dirigé principalement vers l'ordi. Bon, j'ai constaté que l'indicator indique un peu moins de 20% d'erreur. Si donc, il indique 46º, il doit être en réalité à 54º (j'ai comparé avec le Bios) mais cela reste très correct. Le processeur du Brix peut supporter 70º sans broncher (95º maxi accepté) et j'en suis loin.

Le modèle de mon Brix est toujours vendu: http://www.ldlc.com/fiche/PB00167619.html. Je l'ai payé moins de 100 € hors-taxe en juin 2014 (les produits arrivent ici hors-taxe et comme la douane ne demande jamais rien, c'est tout benef' et ça compense le port). Bien sûr, il m'a fallu rajouter un SSD et 8 Go de RAM (j'ai pas lésiné, la RAM et le SSD Crucial 500 étaient en promo à l'époque). Je m'en suis tiré pour ≃230 € tout compris (y compris le port mais sans les câbles HDMI). J'ai oublié de préciser: c'est un "barebone", donc livré sans RAM, ni SSD, ni OS (mais une carte WIFI est livrée avec).

Voir aussi http://www.gigabyte.fr/products/product-page.aspx?pid=5038#ov (site constructeur)

Manuel en PDF: http://download.gigabyte.eu/FileList/Manual/brix-baytrail_manual_emea.pdf

 

Mais je ne sais pas si ce modèle d'entrée de gamme conviendrait à un super-gamer comme toi. J'ai cependant testé le simulateur de vol Linux Flightgear et c'est pas mal du tout... J'ai été agréablement surpris. De toutes manières, il existe des Brix bien plus puissants (mais pas le même prix!) et peut-être même 1 pour Gamer (à vérifier).

J'ai aussi une Eeebox B-202 Asus qui est montée de cette manière (support Vesa).

 

Cliquer sur l'image pour l'agrandir

 

brix-vesa.jpg

 

Traduc:

  1. Fixer les vis fournies dans le dessous du Brix
  2. Fixer la plaque de montage VESA à l'arrière de l'écran en utilisant les vis fournies
  3. Le Brix peut être maintenant monté en le faisant glisser dans le support

Je viens de vérifier, ils ont des portables "Gamer": http://www.gigabyte.fr/products/list.aspx?s=46&p=400&v=1&ck=5

Edited by nettlebay

Share this post


Link to post
Share on other sites

Ok, c'est un format standard normalement, c'est louche que t'ai pas réussi a mettre les 4 vis

Share this post


Link to post
Share on other sites

Oui, mais il y a peut-être plusieurs standards ?  :)

Ce ne serait pas la première fois!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...