Jump to content
ElementaryOS France
Sign in to follow this  
Nyrhu

[Résolu] De MS Office à LibreOffice

Recommended Posts

Bonjour,

Grand spécialiste du monde Windows, je migre sur eOS donc avec LibreOffice. 

Je souhaiterai adapter l'un de mes fichiers Excel mais j'ai des problèmes avec cette formule 

=MOIS.DECALER(INDIRECT("'" & STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filename";A1))+1;32)-1 & "'" & "!Date" &STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filename";A1))+1;32)-1);1)

 

Elle ne fonctionne pas sous Linux... je vois déjà que la fonction TROUVE est combinée avec le caractère ']' mais sous Linux, ça n'existe pas...

Share this post


Link to post
Share on other sites

Problème réglé :) 

Un peut d'adaptation et ça marche parfaitement, c'était l'occasion d'améliorer la formule également et de simplifier tout mon fichier.

En gros, le noeud du problème est que TROUVE était combiné avec "]" ce qui est correct sous Windows car les fichiers excel sont comme ceci : C:\dossier\[mon fichier.xlsm]Feuil1 et mais sous Linux c'est 'file:///home/nicolas/Téléchargements/mon fichier.xlsm'#$2019 donc il fallait que je cherche "$" :) 

 

Amener à switcher d'un OS à l'autre, j'ai automatiser la formule.

Renvoie $ si sous Linux et ] sous Windows (se base seulement sur l'erreur potentielle). La cellule qui contient cette formule à été nommée OperatingSystem. Ensuite il me suffit de faire référence à OperatingSystem pour déterminer le caractère à trouver :)

=SI(ESTERREUR(TROUVE("$";CELLULE("filename";A1))+1);"]";"$")
=INDIRECT("Solde"&STXT(CELLULE("filename";A1);TROUVE(OperatingSystem;CELLULE("filename";A1))+1;32)-1)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...