Jump to content
ElementaryOS France
  • 0

Update-manager planté


Stroggle
 Share

Question

Bonjour à tous, voilà ce soir l'update-manager me signale une grosse erreur quand il décide de faire les mises-à-jours :

 

Impossible d'évaluer la mise à niveau

Un problème irrémédiable est survenu pendant la préparation de la mise à niveau.

Veuillez signaler ce bogue du paquet « update-manager » en y joignant le message d'erreur suivant :
'E:Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.'

 

Ayant l'habitude de me débrouiller j'ai testé quelques trucs innofensifs à coups d'apt-get. J'ai cherché sur plusieurs forums, mais rien n'y fait, je me tourne donc vers vous ce soir rempli de curiosité et d'ignorance. Et comme je suis gentil ( et un peu bête ) je vous donne mon sources.list

 

# deb cdrom:[elementary OS 0.2 _Luna_ - Stable i386 (20130810)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise universe
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu precise main
# deb-src http://extras.ubuntu.com/ubuntu precise main

 

En espérant pouvoir vite clôre ce problème !

 

PS : en attendant je fais mes MAJ avec apt-get upgrade, mais bon update-manager est bien pratique !

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

T'as essayé de sudo apt-get purge update-manager puis sudo apt-get install update-manager ? Si le problème n'apparait pas avec un apt-get upgrade c'est que le problème doit venir de update-manager et pas de la base de donnée de apt.

Link to comment
Share on other sites

  • 0

Le problème n'apparaît pas du tout avec apt-get upgrade, ce qui est étonnant c'est que la première fois update-manager a fonctionné, c'est ensuite qu'il a planté.

Pour le purge et install je l'ai déjà fait justement...

 

Donc d'après toi je devrais me passer de update-manager? :/

Edited by Stroggle
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...