Jump to content
ElementaryOS France
nettlebay

WIFI: Problèmes de performances

Recommended Posts

WARNING !  Je n'ai pas expérimenté la plupart des solutions présentées ici n'utilisant actuellement aucun appareil wifi sur mon réseau. En principe, ces manip' ne posent aucun danger sauf si vous faites n'importe quoi! Alors... je décline toute responsabilité et bla-bla-bla... OK ?
 
Les problèmes de réseau sont (ou étaient) un souci relativement fréquent après une nouvelle installation d'Ubuntu ou dérivés.
 
Si -en général- tout ça se passe bien et automatiquement avec la liaison filaire (Ethernet), il n'en est pas de même avec le Wifi qui est lent voire ne fonctionne pas du tout.
 
Voici donc une traduction (très!) libre d'un article de http://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/. Je n'ai pas tout traduit, hein! pouf..pouf.. Chaque jour sa peine...
 
Plusieurs solutions sont disponibles. L'une d'entre elles pourra peut-être résoudre votre problème. Qu'on s'entende bien: il ne s'agit pas d'un "step by step" mais bien de solutions indépendantes les unes des autres. Essayez-les unes après les autres et redémarrez votre PC à chaque fois (sauf avis contraire). Si ça ne marche pas, il peut aussi être intéressant d'annuler les modifs.
 
N'hésitez pas à vous référer à l'article d'origine pour plus de précisions: http://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/
 
 
 
Cherchez d'abord quelle est votre carte wifi (attention, le résultat peut prendre quelques dizaines de secondes à s'afficher)
 
 
SOLUTION 1 (carte Atheros seulement)
 
sudo su
echo "options ath9k nohwcrypt=1" >> /etc/modprobe.d/ath9k.conf

Cela va ajouter une ligne à votre fichier de configuration ath9k.conf

 

Redémarrez votre ordi et voyez si ça améliore votre connexion...
 
Annuler la modif: ouvrez en root  /etc/modprobe.d/ath9k.conf et supprimez la ligne ajoutée (options ath9k nohwcrypt=1) . Enregistrez puis redémarrez
 
 
 
SOLUTION 2
 
Désactiver le protocole 802.11n
 
Ce truc consiste à désactiver le protocole 802.11n qui n'est pas encore très utilisé surtout si votre routeur ou box n'est pas de dernière génération.
 
Modification temporaire:
sudo rmmod iwlwif
sudo modprobe iwlwifi 11n_disable=1

Ne redémarrez pas! C'est temporaire seulement. Voyez si cela améliore votre connexion. Si ce n'est pas le cas, redémarrez et ce sera annulé du même coup.

 
Modification permanente (si la précédente a donné de bons résultats)
sudo su
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf

Redémarrez votre ordi

 
IMPORTANT ! pour les versions antérieures à Ubuntu 12.04, mettez iwlagn à la place de iwlwifi.
 
Annuler la modif: ouvrez en root  /etc/modprobe.d/iwlwifi.conf et supprimez la ligne ajoutée (options iwlwifi 11n_disable=1) . Enregistrez puis redémarrez
 
 
SOLUTION 3
 
Réparer le bug de Debian Avahi-Daemon
 
EOS dérivant d'Ubuntu et Ubuntu dérivant de Debian, ce bug a bien pu se propager à eOs...
 
NOTE du traducteur: Je conseille Gedit comme éditeur de texte en partie parce qu'il sauvegarde systématiquement (par défaut) tout fichier modifié. Le fichier est sauvegardé dans le même dossier que l'original sous cette forme (exemple): nsswitch.conf~ (un tilde "~" est ajouté). Pour l'éditeur par défaut d'eOs, remplacez systématiquement "gedit" par "scratch-text-editor" (sans les guillemets bien-sûr!) sourire.gif
sudo apt-get install gedit

Une fois Gedit installé:

sudo gedit /etc/nsswitch.conf
Dans l'éditeur qui s'ouvre, repérez la ligne:
hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

Seulement si vous la trouvez, remplacez-la par 

hosts:          files dns

Enregistrez puis redémarrez. Si ça n'améliore pas votre connexion, rendez-vous à la prochaine solution...

 

Annuler la modif: ouvrez en root  /etc/nsswitch.conf et rétablissez la ligne modifiée (hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4) . Enregistrez puis redémarrez

 
 
 
SOLUTION 4
 
Désactivez le support IPv6
 
C'est une solution parfois très efficace et assez bien connue et je ne m'étendrai pas sur le pourquoi de l'IPv6 sauf qu'il est encore peu utilisé. Orange commence tout juste à se remuer à ce propos..
 
Je n'utiliserai pas ici la méthode de Its Foss ici car j'ai constaté que cela générait une petit erreur (pas bien grave cependant) dans le fichier /etc/sysctl.conf
 
Ma méthode est donc tout simplement d'éditer le fichier:
gksudo gedit /etc/sysctl.conf

et de rajouter en bas:

#
#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
Enregistrez et encore une fois, redémarrez votre PC.
 
Annuler la modif: Si par la suite, vous avez besoin de réactiver l'IPv6, il vous suffira de d'éditer à nouveau /etc/sysctl.conf avec gksudo (ou sudo) puis de mettre un dièse (càd "commenter") devant chaque ligne comme ceci:
#
#disable ipv6
#net.ipv6.conf.all.disable_ipv6 = 1
#net.ipv6.conf.default.disable_ipv6 = 1
#net.ipv6.conf.lo.disable_ipv6 = 1
 
 
SOLUTION 5
 
Laissez tomber Network-Manager et adoptez Wicd...!
 
Les problèmes de connexion sans-fil sont parfois dus au propre gestionnaire de réseau d'Ubuntu: Network-Manager. Je n'en connais pas l'origine, mais j'ai vu pas mal de gens qui s'en plaignaient sur les forums en particulier sur Ubuntu 12.04. Vous pouvez installer Wicd, un suppléant et meilleur gestionnaire de réseau depuis le Software Center (Logithèque) de votre distro ou via Synaptic. Pour plus de détails sur Wicd: http://itsfoss.com/show-security-of-wireless-access-points-ubuntu/
 
Sinon: 
sudo apt-get install wicd

devrait marcher.

 

modifi%25C3%25A9.jpg je conseille personnellement (moi, La Grenouille!), de ensuite au moins désactiver Network-Manager (ou nm-applet?) dans les applications au démarrage ou avec BUM (Boot-up Manager). L'absence de Network-Manager -dans le cas où vous le désinstalleriez- n'empêchera pas, en principe, votre ordi d'être connecté. Ce n'est qu'un gestionnaire...

 

 
 
 
SOLUTION 6
 
Plus de puissance pour votre adaptateur WIFI
 
Ce truc est peut-être obsolète et c'est pourquoi je ne le mentionne qu'à la fin. À l'epoque d'Ubuntu 11.04, le Linux Kernel avait un système de gestionnaire de puissance pour le wifi (Wireless Power Manager). Cela pouvait provoquer des problèmes de performances du wifi. Résultat, parfois c'était rapide, parfois terriblement lent. Mais il est probable que ce problème a été corrigé dans les kernels récents.
 
Juste pour info, donc...
 
Ouvrez un terminal et...
sudo iwconfig

Ça vous donnera le nom de votre réseau wifi. Générallement, c'est wlan0 (zéro).

 
Maintenant, lancez la commande suivante:
sudo iwconfig wlan0 power off

Ça va désactiver le système de gestion de puissance de la carte WIFI et donc lui donner plus de puissance en permanence.

 
Note du traducteur: je ne suis pas sûr que ça soit conservé au redémarrage. À vérifier..
 
 
Pour annuler la modif:
sudo iwconfig wlan0 power on

... ça devrait le faire...

 
Cet article sera peut-être complété et enrichi ultérieurement... Regardez bien la date de modification ci-dessous...
Edited by nettlebay

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...