Jump to content
ElementaryOS France
Sign in to follow this  
Los_tintinos

Blackscreen, reglage de luminosité et carte graphique hybride

Recommended Posts

Bonjour,

 

Si comme moi vous êtes l'heureux possesseur d'un portable équipé d'une carte graphique hybride, vous avez peut être déjà eu des problèmes avec cette foutue configuration. Déjà oubliez les drivers fglrx et autres propriétaires, ils m’empêchent tout simplement de démarrer...

 

Donc dans un premier temps pour être sur de votre coup

 

seb@seb-laptop:/$ lspci -vnnn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] [1002:68e0] (rev ff) (prog-if ff)

 

Il y a bien deux cartes graphiques une Intel et une ATI (HD 5450 pour moi)

 

Si comme dans mon cas vous avez des écrans qui restent désespérément noir au boot, et accessoirement des problèmes avec les réglages de la luminosité,

 

sudo gedit /etc/default/grub

 

puis modifer comme suit la ligne suivante :

 

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

 

Ainsi vous n’aurez plus d’écran noir au boot et normalement vous pourrez modifier les réglages de luminosité avec les boutons ad'hoc.

 

Maintenant la partie carte graphique hybride. Peut être avez vous remarqué qui votre PC soufflait et chauffait comme un fou et que votre autonomie fondait comme un cornetto dans les mains de clara morgane...

 

Dans ce cas c'est avec acpi-call qu'on va lui régler son compte. Le problème c'est que linux alimente les deux cartes graphique même si seul l'intel sert à l'affichage. Pour le moment, la version 12.04 d'Ubuntu, sur laquelle s'appui Luna, ne sait pas switcher entre les cartes, ni même gérer ce truc.

 

Donc avec acpi-call on va simplement éteindre la carte ATI (ou AMD et meme NVidia)

 

Donc voici comment j'ai procédé

 

1°) Installation de git et du dossier acpi-call

sudo apt-get install git
git clone http://github.com/mkottman/acpi_call.git

 

2°) Installation d'acpi_call

cd acpi_call/
make
sudo insmod acpi_call.ko

 

3°) utilisation du script de test

chmod u+x examples/turn_off_gpu.sh
./examples/turn_off_gpu.sh

 

4°) Resultat du script de test, il faut noter le code qui fonctionne ("Work's")

Trying \_SB.PCI0.P0P1.VGA._OFF: failed
Trying \_SB.PCI0.P0P2.VGA._OFF: failed
Trying \_SB_.PCI0.OVGA.ATPX: failed
Trying \_SB_.PCI0.OVGA.XTPX: failed
Trying \_SB.PCI0.P0P3.PEGP._OFF: failed
Trying \_SB.PCI0.P0P2.PEGP._OFF: works!
Trying \_SB.PCI0.P0P1.PEGP._OFF: failed
Trying \_SB.PCI0.MXR0.MXM0._OFF: failed
Trying \_SB.PCI0.PEG1.GFX0._OFF: failed

 

5°) Eteindre sa carte graphique

echo ' \_SB.PCI0.P0P2.PEGP._OFF' > /proc/acpi/call 

 

alors si vous avez de la chance cela fonctionne, ou si comme moi vous avez la shcoumoune (proc/acpi/call : Permission denied et ou acpi_call : module not load) , alors tentez ceci (Remplacer NOMUSER par votre nom de d'utilisateur)

 

 

sudo modprobe acpi_call

sudo chown NOMUSER /proc/acpi/call

echo '\_SB.PCI0.P0P2.PEGP._OFF' > /proc/acpi/call

 

Enfin si cela ne vous renvoi pas d'erreur, c'est bon pour vous.

 

Il suffit de mettre tout dans le rc.local pour automatiser tout ça au démarrage.

 

sudo gedit /etc/rc.local

 

puis y coller ceci avant le exit 0

 

sleep 45
modprobe acpi_call
sleep 3
chown NOMUSER /proc/acpi/call
sleep 3
echo '\_SB.PCI0.P0P2.PEGP._OFF' > /proc/acpi/call

 

Mon autonomie a depuis doublée, mon pc est enfin silencieux,le pc démarre normalement et je ne fini plus mes séances de surf avec les cuisse brûlées au second degrés....

 

Bon courage a vous parce-que j'ai lutté...

Edited by Los_tintinos

Share this post


Link to post
Share on other sites

Merci je garde ça sous la main, ayant que des portables avec carte graphique hybride.

 

Par contre, personnellement (je n'ai pas essayé ta procédure) mais pour ce qui est de

"votre PC soufflait et chauffait comme un fou et que votre autonomie fondait comme un cornetto dans les mains de clara morgane"
j'ai toujours suivis cette procédure:

 

http://doc.ubuntu-fr.org/vga_switcheroo

 

Et j'avoue ne jamais avoir rencontré de problèmes, et que ça a toujours bien fonctionné.

 

Je ne sais pas si tu as déjà essayé cette méthode de ton coté mais si ça peut t'apporter quelque chose j'en suis content! ;)

Share this post


Link to post
Share on other sites

salut,

 

j'ai bien entendu fait le tour de quasiment (je pense) toute les solutions existante avec ces foutues cartes hybrides. (en 3 ans j'ai eclusé quelques tutos...)

VGASwitcheroo est certainement la solution la plus simple. en effet il suffit de le lancer au démarrage et c'est bon.

MAIS, sur mon PC, si je suis obligé de démarrer avec quelques options en plus dans le grub pour ne pas avoir d'écran noir au démarrage. Or ces options rendent vgaswitheroo inopérant, d'où l'utilisation d'acpi-call.

Voila, voilou.

 

Kén@vo

Share this post


Link to post
Share on other sites

J'aimerais bien suivre le Tuto mais ou taper les ligne de commande ? ^^

Dans le menu GRUB j'appui E je tape la première ligne il me dise "unknow command "sudo"

En passant par l'inviter de command en root du mode recovery c'est "gedit" qu'il ne reconnais pas

Bon je tiens a préciser hier ça tourner nickel j'ai voulu installer gsfv (le truc pour connecter mon telephone) et tout a sauter XD

Share this post


Link to post
Share on other sites

Salut,

Dans grub (aprés avoir taper E) il faut juste mettre les commande suivantes :

 

quiet splash acpi_osi=Linux acpi_backlight=vendor

 

puis laisser Eos demarrer.

 

Ensuite tout se fait dans un terminal ou dans une fenêtre Gedit (modification de fichier)

 

si gedit n'est pas installé, il faut le faire en lançant

sudo apt-get install gedit

dans un terminal.

 

Bon courage

Share this post


Link to post
Share on other sites

J'ai tenté les lignes de commande ,toujours écran noir :(

C'est tellement compliqué Linux je trouve :/ , je vais faire a la bourrin formater la partition et réinstall par dessus et j'eviterais d'installer plein de trucs trouver ici et la

J'ai juste peur que GRUB fasse encore des siennes mais bon on verra

Merci de m'avoir accordé de ton temps ^^

Share this post


Link to post
Share on other sites

Salut,

 

C'est pas plus compliqué que windows, c'est juste différent mais surtout moins déployé donc moins développer en terme de drivers.

 

Sinon, fait plutôt une ré-install sans formater d'abord (réflexe windowsien).

Dans l'installateur, il y a une option pour ne pas tout formater qui traine mais aprés où ??

Share this post


Link to post
Share on other sites

J'avoue que c'est pas compliqué quand on sais ce qui ce passe mais la plupart du temps on ne sais pas comme sur ce problème ^^

Pis on ce m'est à chercher de partout la solution jusqu'à trouver un post perdu dans un forum douteux et la bim ça marche (déjà arriver 3-4 fois xD)

Couplé au réflexe Windows on s'y retrouve plus c'est dommage, j'ai toujours eu des problèmes avec Linux mais ça me coupe pas l'envie de toujours retenter l'aventure ^^

Au pire j'essaye d'install par dessus je verrais demain je te tiens au courant ;p

Share this post


Link to post
Share on other sites

Salut,

 

Dans ce cas n'oublie pas qu'elementaryOs reste un beta (version 0.2)

Pour ma part, je suis sous eOS que sur mon laptop. A contrario sur mon Desktop, j'utilise Ubuntu 14.04 Gnome Edition. On y retrouve une expérience utilisateur(Graphique) quasi identique à eOS avec taskbar comme extension. Gnome 3.10 est superbe je trouve. J'ai mis une capture de mon bureau sous gnome dans la partie bureau du forum.

Avec Ubuntu 14.04 tu risque d'avoir moins de problèmes (enfin je pense) qu'eOS

 

Bon courage

Share this post


Link to post
Share on other sites

Merci de ton aide !! :D

Oui je comprend que c'est une BETA je trouve que le travaille fait dessus est magnifique d’où mon acharnement pour l'installation , mais bon marche toujours pas j'ai formaté j'install' -> j'arrive sur GRUB les entrées d'eOS marche mais pas Win 8 -> un coup de Boot Repair et je tombe sur GRUB Bash Like...j'abandonne je vais essayer Ubuntu mais je la trouve pas aussi jolie que eOS apars si tu connais de belle distribution du même style ^^

En attendant j'ai vus que Isis gérera les cartes graphique Hybride ce qui est pas mal , j'espère qu'elle sortira bien vite parce que Win8 je supporte pas :(

Edited by SaKOoU

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...