Jump to content
ElementaryOS France

Search the Community

Showing results for tags 'performances'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Votre communauté
    • Annonces & Informations
    • Idées & améliorations
    • Présentation des membres
    • Sorties d'eOS
  • ElementaryOS
    • Applications tierces
    • Un problème ?
    • Tutoriels
    • Votre desktop
  • Personnalisation
    • Icônes
    • Bootloader
  • Divers
    • Le bar des amis
    • Scripting, Coding, Bash

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. WARNING ! Deux-trois jour après ces manips, j'ai constaté qu'il était à nouveau sur Économie d'Energie par défaut (dans l'indicator) au démarrage... Cherchez l'erreur... Suite à une mise à jour ? Ceci ne concerne que les processeurs INTEL Depuis quelques jours, j'ai constaté que l'Indicator-cpufreq n’indique plus que deux options soit Performances et Économie d'Énergie (probablement suite à une mise à jour). De plus, au démarrage, il se remet par défaut sur Économie d'Énergie. Et par dessus tout, j'ai l'impression qu'il ne fonctionne pas correctement. J'ai essayé de trouver des solutions et n'ai trouvé que cela: http://askubuntu.com/questions/541143/indicator-cpufreq-doesnt-seem-to-work-on-14-10. Mais malheureusement, cette méthode (pour Ubuntu 14.10, il est vrai) ne fonctionne pas chez moi. C'est en relation avec Intel P-State qui est -si j'ai bien compris- un nouveau gestionnaire de performance du CPU. Je ne vais pas m'attarder la-dessus car je pense qu'on y reviendra plus tard avec un nouveau tuto sur Intel P-State et Thermald. Et de toutes manières, il ne semble pas y avoir de solution pour améliorer indicator-cpufreq. Ce n'est donc pas l'objet de ce tuto. Maintenant et avant... "With intel_pstate, there are only two cpufreq governors: performance and powersave (there's no "ondemand")" Avec intel_pstate, il y a seulement 2 cpufreq governors, performance et powersave (économies d'énergie). Il n'y a pas de "ondemand" Pour le vérifier: ~$ cpupower frequency-info --governors analyzing CPU 0: performance powersave Seuls "performance" et "powersafe" sont donc disponibles. Ce n'est pas un bug mais une nouvelle caractéristique. Donc, en principe, il n'y a rien à faire d'autant plus que intel_pstate est en principe plus performant. Voir cette page http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html qui est très intéressante (mais en Anglais) On arrive dans le vif du sujet... Pour savoir si intel_pstate est installé et actif: cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver résultat: intel_pstate Sous Freya, il est en principe activé par défaut, donc pas besoin de l'activer dans Grub. Si ce n'est pas le cas: https://www.google.fr/search?q=install+intel_pstate Nous allons maintenant installer Linux-tools. sudo apt-get install linux-tools-common linux-tools-generic Ce qui nous permet de tester intel_pstate avec cpupower ~$ cpupower frequency-info analyzing CPU 0: driver: intel_pstate CPUs which run at the same hardware frequency: 0 CPUs which need to have their frequency coordinated by software: 0 maximum transition latency: 0.97 ms. hardware limits: 500 MHz - 2.17 GHz available cpufreq governors: performance, powersave current policy: frequency should be within 500 MHz and 2.17 GHz. The governor "performance" may decide which speed to use within this range. current CPU frequency is 2.17 GHz. boost state support: Supported: yes Active: yes Cela peut varier en fonction de votre matos, évidemment. (Pour info seulement) Pour le mettre en mode powersave (économie d'énergie): sudo cpupower frequency-set -g powersave NOTE: la manip' ci-dessus est en principe inutile puisqu'il est déjà en powersave par défaut... Pour le mettre en Performance (plus intéressant déjà! Mais pas pour un laptop) sudo cpupower frequency-set -g performance Il est évidemment possible de faire des lanceurs avec ces commandes. Pour que ce paramètre soit automatique au démarrage: Ouvrez /etc/rc.local en root (vous pouvez utiliser Scratch en remplaçant gedit par scratch-text-editor) sudo gedit /etc/rc.local Dans rc.local, ajoutez cette ligne en bas juste avant exit 0 sudo cpupower frequency-set -g performance exit 0 Il y a peut-être d'autres solutions moins "bourrines", mais bon, ça fonctionne... C'est le principal. Note: pour désactiver une commande dans rc.local, il suffit de rajouter devant (à gauche) un dièse "#" et un espace. Exemple: # sudo cpupower frequency-set -g performance Enregistrez et voilà, y'a plus qu'à redémarrer! Attention! Sur un laptop (un "portable"!), le mode "performance" n'est pas conseillé au démarrage car il devrait logiquement consommer plus de batterie avec ce paramètre... Je vais aussi probablement faire un tuto en traduisant la page http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html car il y a beaucoup de choses intéressantes comme souvent sur http://www.webupd8.org/ Une vraie caverne d'Ali-Baba pour geeks linuxiens! Page intéressante: http://askubuntu.com/questions/523640/how-i-can-disable-cpu-frequency-scaling-and-set-the-system-to-performance
×
×
  • Create New...