Aller au contenu
ElementaryOS France

Rechercher dans la communauté

Affichage des résultats pour les étiquettes 'optimiser'.



Plus d’options de recherche

  • Rechercher par étiquettes

    Saisir les étiquettes en les séparant par une virgule.
  • Rechercher par auteur

Type du contenu


Forums

  • Votre communauté
    • Annonces & Informations
    • Idées & améliorations
    • Présentation des membres
    • Sorties d'eOS
  • ElementaryOS
    • Applications tierces
    • Un problème ?
    • Tutoriels
    • Votre desktop
  • Personnalisation
    • Icônes
    • Bootloader
  • Divers
    • Le bar des amis
    • Scripting, Coding, Bash

Rechercher les résultats dans…

Rechercher les résultats qui…


Date de création

  • Début

    Fin


Dernière mise à jour

  • Début

    Fin


Filtrer par nombre de…

Inscription

  • Début

    Fin


Groupe


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

5 résultats trouvés

  1. "11 things to do after installing elementary OS 0.4 Loki to get a better and smoother experience out of it" Bon, désolé, mais c'est en Anglais... https://itsfoss.com/things-to-do-after-installing-elementary-os-loki/ Et ici via Google Traduction: https://translate.google.com/translate?sl=auto&tl=fr&js=y&prev=_t&hl=fr&ie=UTF-8&u=https%3A%2F%2Fitsfoss.com%2Fthings-to-do-after-installing-elementary-os-loki%2F&edit-text= Pas garanti... Faites gaffe, hein!
  2. On peut quasiment décupler la vitesse des téléchargements par ligne de commande y compris avec Synaptic et Gdebi. Il faut tout simplement installer apt-fast et l'utiliser à la place de apt-get. Apt-fast fonctionne sur le même principe de nombreux autres "gestionnaires de téléchargement" (comme le célèbre FreeDownloadManager sous Windows), c'est à dire qu'il télécharge à partir de plusieurs sources et reconstitue le fichier à la fin. On peut ainsi multiplier la vitesse de téléchargement par 10 et un peu plus. Apt-fast est aidé par Aria2 qui est déjà utilisé sous Ubuntu par d'autres gestionnaires de téléchargement. Pour les distros basées sur Ubuntu 14.04 comme Freya: sudo apt-add-repository ppa:saiarcot895/myppa -y && sudo apt-get update && sudo apt-get -y install apt-fast Répondez aux questions en utilisant les valeurs par défaut. Si vous changez d'avis plus tard, il suffira de taper les commandes suivantes : sudo dpkg-reconfigure apt-fast Note: l’ installateur vous demande de choisir entre les outils de configuration de paquet apt-get et aptitude. En principe, choisissez apt-get qui est installé par défaut sur Ubuntu depuis 10.10. Remplacer automatiquement apt-get par apt-fast En créant un "alias", vous pourrez continuer à utiliser apt-get comme d'habitude, c'est apt-fast qui sera utilisé et surtout les applis basées sur apt-get utiliseront apt-fast à la place. Ouvrez .bashrc avec votre éditeur de texte (ici Gedit): sudo gedit .bashrc Puis ajoutez ces deux lignes en bas du fichier: alias sudo='sudo ' alias apt-get='apt-fast' Enregistrez et fermez le fichier. Redémarrez votre ordi (mais je ne suis pas sûr que ce soit indispensable) Pour utiliser apt-fast en ligne de commande: sudo apt-fast install <programme> et pour le rechargement des paquets: sudo apt-fast update Sources (et plus d'info): https://doc.ubuntu-fr.org/apt-fast http://www.le-libriste.fr/2013/11/ubuntu-accelerer-le-telechargement-de-vos-paquets/
  3. WARNING ! Deux-trois jour après ces manips, j'ai constaté qu'il était à nouveau sur Économie d'Energie par défaut (dans l'indicator) au démarrage... Cherchez l'erreur... Suite à une mise à jour ? Ceci ne concerne que les processeurs INTEL Depuis quelques jours, j'ai constaté que l'Indicator-cpufreq n’indique plus que deux options soit Performances et Économie d'Énergie (probablement suite à une mise à jour). De plus, au démarrage, il se remet par défaut sur Économie d'Énergie. Et par dessus tout, j'ai l'impression qu'il ne fonctionne pas correctement. J'ai essayé de trouver des solutions et n'ai trouvé que cela: http://askubuntu.com/questions/541143/indicator-cpufreq-doesnt-seem-to-work-on-14-10. Mais malheureusement, cette méthode (pour Ubuntu 14.10, il est vrai) ne fonctionne pas chez moi. C'est en relation avec Intel P-State qui est -si j'ai bien compris- un nouveau gestionnaire de performance du CPU. Je ne vais pas m'attarder la-dessus car je pense qu'on y reviendra plus tard avec un nouveau tuto sur Intel P-State et Thermald. Et de toutes manières, il ne semble pas y avoir de solution pour améliorer indicator-cpufreq. Ce n'est donc pas l'objet de ce tuto. Maintenant et avant... "With intel_pstate, there are only two cpufreq governors: performance and powersave (there's no "ondemand")" Avec intel_pstate, il y a seulement 2 cpufreq governors, performance et powersave (économies d'énergie). Il n'y a pas de "ondemand" Pour le vérifier: ~$ cpupower frequency-info --governors analyzing CPU 0: performance powersave Seuls "performance" et "powersafe" sont donc disponibles. Ce n'est pas un bug mais une nouvelle caractéristique. Donc, en principe, il n'y a rien à faire d'autant plus que intel_pstate est en principe plus performant. Voir cette page http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html qui est très intéressante (mais en Anglais) On arrive dans le vif du sujet... Pour savoir si intel_pstate est installé et actif: cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver résultat: intel_pstate Sous Freya, il est en principe activé par défaut, donc pas besoin de l'activer dans Grub. Si ce n'est pas le cas: https://www.google.fr/search?q=install+intel_pstate Nous allons maintenant installer Linux-tools. sudo apt-get install linux-tools-common linux-tools-generic Ce qui nous permet de tester intel_pstate avec cpupower ~$ cpupower frequency-info analyzing CPU 0: driver: intel_pstate CPUs which run at the same hardware frequency: 0 CPUs which need to have their frequency coordinated by software: 0 maximum transition latency: 0.97 ms. hardware limits: 500 MHz - 2.17 GHz available cpufreq governors: performance, powersave current policy: frequency should be within 500 MHz and 2.17 GHz. The governor "performance" may decide which speed to use within this range. current CPU frequency is 2.17 GHz. boost state support: Supported: yes Active: yes Cela peut varier en fonction de votre matos, évidemment. (Pour info seulement) Pour le mettre en mode powersave (économie d'énergie): sudo cpupower frequency-set -g powersave NOTE: la manip' ci-dessus est en principe inutile puisqu'il est déjà en powersave par défaut... Pour le mettre en Performance (plus intéressant déjà! Mais pas pour un laptop) sudo cpupower frequency-set -g performance Il est évidemment possible de faire des lanceurs avec ces commandes. Pour que ce paramètre soit automatique au démarrage: Ouvrez /etc/rc.local en root (vous pouvez utiliser Scratch en remplaçant gedit par scratch-text-editor) sudo gedit /etc/rc.local Dans rc.local, ajoutez cette ligne en bas juste avant exit 0 sudo cpupower frequency-set -g performance exit 0 Il y a peut-être d'autres solutions moins "bourrines", mais bon, ça fonctionne... C'est le principal. Note: pour désactiver une commande dans rc.local, il suffit de rajouter devant (à gauche) un dièse "#" et un espace. Exemple: # sudo cpupower frequency-set -g performance Enregistrez et voilà, y'a plus qu'à redémarrer! Attention! Sur un laptop (un "portable"!), le mode "performance" n'est pas conseillé au démarrage car il devrait logiquement consommer plus de batterie avec ce paramètre... Je vais aussi probablement faire un tuto en traduisant la page http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html car il y a beaucoup de choses intéressantes comme souvent sur http://www.webupd8.org/ Une vraie caverne d'Ali-Baba pour geeks linuxiens! Page intéressante: http://askubuntu.com/questions/523640/how-i-can-disable-cpu-frequency-scaling-and-set-the-system-to-performance
  4. Hou-là ! Dans la nouvelle version de Chrome (Version 42), les favoris (étoile en bout de barre de navigation et le gestionnaire) ont changé... Ah ben oui... c'est plus zoli... (et actuel) mais c'est lourd-lourd, et puis j'aime pas du tout. Et apparemment, je ne suis pas le seul... Je préfère l'ancienne version. Alors, pour revenir au vieux système: Tapez dans votre barre de navigation: chrome://flags/#enhanced-bookmarks-experiment paramétrez sur "Disable". Redémarrez Chrome et tout revient comme à l'origine
  5. Note: je ne suis pas un expert en réseau. Donc, si je dis des c..., n'hésitez pas à le dire! Et d'abord, c'est quoi le MTU ? L'unité de transmission maximale (MTU) d'une interface de réseau est la taille du plus grand bloc de données qui peut être transmis en une seule fois. Tout ce qui est plus grand que le MTU doit être divisé en plus petites unités avant leur transmission. Pour optimiser votre connexion, ce MTU doit être réglé "aux p'tits oignons". Le réglage par défaut du MTU dans Ubuntu est 1500 alors qu'il devrait être généralement 1492 (à mon humble avis...). Pour connaître le MTU de votre Ubuntu (ou eOs): netstat -i Table d'interfaces noyau Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg eth0 1500 0 12894 0 0 0 10911 0 0 0 BMRU lo 65536 0 1279 0 0 0 1279 0 0 0 LRU tun0 1500 0 3302 0 0 0 2793 0 0 0 MOPRU C'est eth0 qui nous intéresse. Généralement, dans Linux, il est réglé sur 1500. La commande ci-dessus ne vous donne pas le MTU idéal mais celui qui est réellement paramétré. On peut le faire comme ça aussi: ~$ ifconfig eth0 | grep -Eo "MTU:[0-9]+" ce qui donne: MTU:1492 Perso, j'ai choisi le plus court chemin c-à-dire aller dans ma Livebox 2 > Assistance > Informations Système > Internet On y voit bien que le MTU (recommandé?) est 1492 Pour changer votre MTU "à la volée" (mais il ne sera pas conservé au redémarrage), pour faire des tests par exemple: sudo ifconfig eth0 mtu 1492 Pour rendre le changement permanent: sudo gedit /etc/dhcp/dhclient.conf Dans le fichier dhclient.conf, recherchez cette ligne: request subnet-mask, broadcast-address, time-offset, ... bla-bla-bla... Juste avant la ligne ci-dessus, ajoutez ces deux lignes: default interface-mtu 1492; supercede interface-mtu 1492; Enregistrez le fichier, puis redémarrez votre machine. Vous pouvez bien entendu vérifier que tout est OK avec netstat -i Et voilà! Notes: il semble que l'indicateur réseau dans Wingpanel (nm-applet) permette ce changement mais il semble aussi que le changement n'est jamais pris en considération. Ce bidouillage est-il vraiment efficace? Le résultat ne vous sautera aux yeux que sur des connexions faibles (modem dial-up). Il est probable qu'en haut-débit, vous ne verrez pas beaucoup de différence sauf s'il était vraiment très mal réglé. Cette bidouille n'est en principe pas dangereuse. Au pire, vous vous retrouverez temporairement sans connexion (peu probable). Dans ce cas, il suffit de reprendre le tuto depuis le début et de revenir à la valeur par défaut de 1500. Mais en règle générale, pas d'acrobaties sans filet! Faites régulièrement des "backups" avec Clonezilla. Ça peut vous sauver la vie! On change seulement le MTU de eth0 (interface ethernet). Il ne faut pas changer celui de "tun0" qui est l'interface réseau virtuelle pour le VPN (si vous en utilisez un) ni de "lo" qui est l'interface locale virtuelle aussi (enfin, je crois. Dites-moi si je fais erreur...)
×
×
  • Créer...