Jump to content
ElementaryOS France
  • 0

Formatage/utilisation disque dur


Question

Bonjour à tous, je reviens vers vous pour un nouveau problème.

 

J'ai récupérer un DD sur mon PC portable qui était du windows, le DD était divisé en 2 parties, une pour windows et l'autre pour mes stockages de doc...

 

J'ai donc branché le DD sur mon PC de bureau sur lequel il y a déjà un DD avec elementary installé dessus, le second DD est bien reconnu et j'ai accès aux 2 parties du DD.

 

J'ai utilisé Gparted afin de formater la partie windows du second DD, une fois le formatage effectuer en ext3 je me retrouve avec mon DD linux, mon DD de stockage et le DD que je viens de formater.

 

Mon problème est que le DD que je viens de formater est inaccessible, j'ai un dossier "lost+found" mais je ne peux rien ajouter sur ce DD.

 

Si quelqu'un à une idée...je suis preneur

 

Merci d'avance

Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0

Tu te retrouve confronté au droit d'utilisateur lié a EXT

 

Pour commencer il faut savoir ce que tu cherche a faire.

Si j'ai bien compris tu as un pc fixe dans lequel tu viens d'ajouter un second disque dur.

tu te retrouve donc avec ceci :

 

---> HDD1 ---> HOME

 

---> HDD2 |---> Stockage

                  |--> EXT3

 

 

Le nouveau disque dur sera-t-il monté en permanance dans le pc ? veux tu qu'il soit ajouter au démarage  ?

 

 

Link to post
Share on other sites
  • 0

Dans ce cas il te faut modifier le fstab dans /etc/

 

je pars aussi du principe que la partition "stockage" est aussi en ntfs (sinon dis nous en quoi il est pour pas faire de bétise)

 

mais avant tout formater l'ext3 en NTFS.
Comme cela tu n'aura plus de problème de droit tu pourra écrire dessu

 

ensuite il te faut regarder les info de chaque partition avec gparted pour récuperer leur UUID

 

créer un dossier dans ton $HOME pour chaque partition  (ex : stockage et ntfs )

 

ouvrir le fichier fstab en root  et ajouter les lignes suivantes  correctement complété

 

 

#disque stockage

UUID= celui du disque stockage          /home/**user**/stockage         ntfs     defaults    0      0

 

#disque ntfs

UUID= celui du disque ntfs                  /home/**user**/ntfs                  ntfs     defaults    0      0

 

 

 

copie nous ton fstab avant de valider

Link to post
Share on other sites
  • 0

Merci steph.

Voici mon fstab

 

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=d18a83ea-6038-467e-b6ff-a3fc05e43f1b /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=b9fb7842-a108-403c-a562-ee1e143cd4a8 none            swap    sw              0       0
Link to post
Share on other sites
  • 0

Bien il faut que tu comprenne le fonctionnement, c'est aussi ça l'interret ;)

 

<file system>  numéro d'identification de la partition, souvent on utilise /dev/sda ..sdb ...   là nous utilisons le UUID,  déjà parce qu'on peut l'avoir facilement, mais aussi car nous ne risquons pas de nous tromper avec lui car chaque UUID est unique

 

<mount point> c'est simplement le dossier sur lequel nous allons faire pointer le disque, dossier que nous ouvrirons pour naviguer dans le disque.

 

<type>   correspond au type de partition, FAT NTFS EXT ...

 

<optionq> comme le nom l'indique ce sont les options que nous donnerons au disque  lecture/écriture.... y'en a plein 

 

<dump> et <pass>  j'ai pas bien compris ça mais il semblerait que ça donne un ordre pour l'ajout des partitions.

 

 

Bien une fois qu'on sait ça on peut déjà regarder ce que l'installation de base t'as donné

 

# / was on /dev/sda1 during installation

UUID=d18a83ea-6038-467e-b6ff-a3fc05e43f1b /               ext4    errors=remount-ro 0       1
 
ce disque correspond a ton system dans lequel tu as ton $HOME     il est en ext4 et directement a la racine " / "
 
# swap was on /dev/sda5 during installation
UUID=b9fb7842-a108-403c-a562-ee1e143cd4a8 none            swap    sw              0       0
 
et celui-ci ta swap comme l'indique le type de partition
 
il reste donc a ajouter les deux lignes donné au dessus  en utilisant l'option defaults pour avoir les trucs de bases lecture/écriture pour tous
 

#disque stockage

UUID= celui du disque stockage          /home/**user**/stockage         ntfs     defaults    0      0

 

#disque ntfs

UUID= celui du disque ntfs                  /home/**user**/ntfs                  ntfs     defaults    0      0

 

Link to post
Share on other sites
  • 0

Merci pour toutes ces explications  ;)

 

Donc maintenant j'ai bien mais deux disques en NTFS, accessible depuis mon compte principal.

En revanche je ne les vois pas sous mes autres comptes...

Une nouvelle explication ? 

 

Cordialement

Link to post
Share on other sites
  • 0

Si ton point de montage se trouve sous /home/user1, c'est normal que user2 ou user3 ne le voient pas car ils n'ont pas les droits d'accés.

Si ca te dérange, prend donc un point de montage sous /media par exemple, faudra le créer avec sudo (comme root) puis donner les droits aux utilisateurs comme dans le tuto suivant (dans automatic mount at boot)

https://help.ubuntu.com/community/InstallingANewHardDrive

Link to post
Share on other sites
  • 0
Si j'ai bien compris, je change les deux lignes que je viens de créer dans le fstab :

 

# UUID=3524D31D68FBEA6C /home/dublan/ntfs                 ntfs      defaults   0   0

# UUID=9A028AF3028AD3A3 /home/dublan/media    ntfs    defaults   0    0

 

en :

 


# UUID=3524D31D68FBEA6C /media                 ntfs      defaults   0   0

# UUID=9A028AF3028AD3A3 /media    ntfs    defaults   0    0

 

C'est ça?

Link to post
Share on other sites
  • 0

Non, tu dois créer les points de montage (des dossiers) sous /media comme tu l'as fait sous /home, en aucun cas prendre /media tout seul Par exemple: /media/part1 et /media/part2

 

Créer le point de montage

sudo mkdir /media/part1

Changer les droits d'accés pour ce point de montage  sudo chgrp plugdev /media/part1  sudo chmod g+w /media/part1  sudo chmod +t /media/part1

Tu fais ca pour la 2éme partition aussi, puis aprés tu peux changer les lignes dans fstab avec les bons point de montage /media/part1 et /media/part2

 

Reboot et ca marche normalement.

Link to post
Share on other sites
  • 0

J'ai compris, j'ai effectué les différentes étapes, j'ai bien accès aux disques sur mon autre session. Par contre je n'ai plus accès aux disques sur le compte principal...

Je verrais ça demain,

Merci pour votre aide à tous les deux.

Bonne soirée

Link to post
Share on other sites
  • 0

J'ai du faire une erreur. 

Dans mon compte principal, je me retrouve bien avec mes 3 périphériques. La manipulation de Steph m'a ajouté 2 dossiers dans /media ou j'avais déjà mes 2 partitions de mon deuxième DD.

 

Par contre dans mes autres comptes dans les périphériques je n'ai que le premier DD (celui où il y a Eos), et dans /media j'ai bien la même chose que dans le compte principal, je peux accéder à mes 2 dossiers créée grâce à Steph mais impossible d'accéder à mes 2 partitions.

Link to post
Share on other sites
  • 0
# /etc/fstab: static file system information.

#

# Use 'blkid' to print the universally unique identifier for a

# device; this may be used with UUID= as a more robust way to name devices

# that works even if disks are added and removed. See fstab(5).

#

# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc            /proc           proc    nodev,noexec,nosuid 0       0

# / was on /dev/sda1 during installation

UUID=d18a83ea-6038-467e-b6ff-a3fc05e43f1b /               ext4    errors=remount-ro 0       1

# swap was on /dev/sda5 during installation

UUID=b9fb7842-a108-403c-a562-ee1e143cd4a8 none            swap    sw              0       0

# UUID=3524D31D68FBEA6C /media/part1                 ntfs      defaults   0   0

# UUID=9A028AF3028AD3A3 /media/part2    ntfs    defaults   0    0

 

 

Si jamais ça peut t'aider

Link to post
Share on other sites
  • 0

Les utilisateurs en question sont bien dans le groupe plugdev?

less /etc/group

derriere le groupe plugdev tu devrais voir les utilisateurs, celui qui fonctionne est 100% dedans, mais si ceux ou ca marche pas sont pas dedans, tu les ajoutes simplement:

sudo usermod -aG plugdev user2

Tu change user2 avec le vrai nom de ton utilisateur que tu veux rajouter bien sur, tu fais cela avec tout ceux en question, puis tu reteste, evt faire un reboot pour que ca fonctionne maintenant.

 

 

 

 

Juste au cas ou ca marche toujours pas après la manip, tu essaye une fois de monter les partitions manuellement dans ces comptes.
Pour connaitre les partitions en question (/dev/sdb1 ou qq du genre surement pour la 1ere partition du 2éme disque)
 

sudo fdisk -l

Pour monter la partition manuellement:

sudo mount /dev/sdb1 /media/part1   

(changer /dev/sdb1 par la bonne partition)
 

Puis regarder sous /media/part1 si ca fontionne.

Si il dit que le disque est déja monté, tu le démonte puis remonte:
 

sudo umount /media/part1

sudo mount /dev/sdb1 /media/part1
Link to post
Share on other sites
  • 0

J'ai ajouté les comptes supplémentaire à plugdev car ils n'y étaient pas.

Je redémarre l'ordi, j'ouvre un des compte utilisateur et la je vois bien les 2 disques en plus. Lorsque je clique dessus pour y accéder il me demande le MDP du compte principal.

Je ne l'ai pas fait, je voulais voir comment c'était sur le compte principal.Sur le compte principal accès normal à ces 2 disques.

Je retourne dans un compte utilisateur, et la il n'y a plus les disques...

Link to post
Share on other sites
  • 0

Merci pour votre aide, pour le moment je bloque.

En fait, les différents disques sont présent uniquement sur le premier compte utilisateur que j'ouvre. Si je passe de l'un à l'autre les disques n'apparaissent pas sur le deuxième.

Je verrais si je trouve une solution

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...