Jump to content
ElementaryOS France
  • 0

Question

Bonjour,

J'ai installé Freya et Steam sur mon SSD.

Comme je n'avais pas assez de place pour tout mes jeux j'ai crée un 2e dossier sur un autre disque mais steam ne le lit pas par défaut( les jeux que j'ai installer sur le 2e disque ne sont pas considérer comme installer) par contre si je vais dans Fichiers et que je monte le 2e disque alors là si je redémarre Steam, les jeux sur le 2e disque sont reconnu.

 

J'aimerai une solution pour que le 2e disque soit monter automatiquement (soit lors du démarrage, soit lors du lancement de Steam).

 

Cordialement et merci d'avance si quelqu'un me trouve une solution .

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

C'est un peu plus compliqué que ça, tout en restant simple

 

Déjà il faut commencer par détailler ce dont FSTAB a besoin

 

Voici la ligne qui correspond a mon disque STEAM

#SSD2
UUID=4B74D20941F44DF8  /home/pioupiou41/steam  ntfs  defaults  0   0

Dont :

 

#SSD2
UUID=4B74D20941F44DF8  : correspond au numéro unique de la partition, une façon simple et efficace d'indiquer au system de quelle partition on parle (se trouve grace a gparted en faisant un clic droit info sur la partition)
 
 /home/pioupiou41/steam  :  dossier que j'ai créer moi même dans mon dossier perso
 
 ntfs : le type de partition que j'ai choisi, simplement car avec celle ci t'as pas besoin de galèrer avec les droits et qu'elle autorise des fichiers de gros volume
 
 defaults : le type d'autorisation defaults autorise tout pour tout le monde, ce qui pour steam est pas mal t'as pas besoin de te demander si tu dois autoriser le programme dessu
 
 0   0   : l'ordre de détection (si j'ai bien compris)
 
 
 
 
 
 
il te faut donc déjà commencer par créer ta partition comme il faut (ça veut dire formater, perso je préfère le ntfs après chacun son truc, mais je saurais t'aider que sur celui ci, attention donc aux datas a ne pas perdre)
 
une fois formater comme il faut, avec gparted tu peux récuperer le UUID, il te reste a créer le dossier steam dans ton home ou ton dossier perso  puis ajouter la ligne comme moi, au reboot suivant ça doit marcher
Link to comment
Share on other sites

  • 0

Ok je viens de lire le fichier

Mon disque dur est diviser en 2 partitions( 1 en fat32 et 1 autre en ext4), je dois monter les 2 partitions ou seulement la partition Linux qui m’intéresse? 

Quand j'ajoute mon disque a FSTAB je dois lui donner la permission pour STEAM (pour que STEAM puisse je lire et le modifier) ?

Link to comment
Share on other sites

  • 0

j'ai fait ce que vous avez dit : Au démarrage j'ai un message d'erreur du type "impossible de monter fstab"

j'appuis sur S et là ça marche parfaitement , le disque n°2 est monter automatiquement au démarrage.

 

Comment je fais pour enlever le message d'erreur ?

Link to comment
Share on other sites

  • 0
# /etc/fstab: static file system information.

#

# Use 'blkid' to print the universally unique identifier for a

# device; this may be used with UUID= as a more robust way to name devices

# that works even if disks are added and removed. See fstab(5).

#

# <file system> <mount point>   <type>  <options>       <dump>  <pass>

# / was on /dev/sda6 during installation

UUID=5da4cbf5-3ae5-4a5a-89ce-5bc262ebbdef /               ext4    errors=remount-ro 0 1

# /home was on /dev/sda5 during installation

UUID=75720c9f-b975-4999-822a-d7a571c88f8e /home           ext4    defaults 0 2

# dossier steam dans SteamDD2

UUID=293E04CB7F834B00 /home/SteamDD2 ntfs defauts 0 0

Link to comment
Share on other sites

  • 0

j'avais fait une erreur de frappe (defauts au lieu de defaults) mais ça change rien j'ai toujours le message d'erreur au démarrage. Bizarrement Gparted ne reconnais plus ma partition SSD (il reconnait le 2e disque) , ça affiche "non alloué" et "Impossible de satisfaire toutes les contraintes sur la partition." 

Par contre le logiciel "Disques" reconnait parfaitement mes partitions. 

Y'a il un moyen de détecter où se trouve l'erreur (avec une ligne de commande) ou bien au moins la ligne où se trouve l'erreur ?

Link to comment
Share on other sites

  • 0

C'est bon j'ai trouvé la solution:

j'ai utilisé la commande mont -fav (qui simule le montage du fichier fstab) pour trouver l'erreur et il m'a indiqué la ligne 1 (# /etc/fstab: static file system information.) , j'ai supprimé cette ligne et je l'ai recrée et je n'ai plus l'erreur au démarrage.

 

Merci beaucoup pioupiou41 pour ton aide!!

j'ai toujours le problème de non reconnaissance avec Gparted  mais je vais pas reformater mon / et mon /home, tant pis c'est pas grave j'ai pas besoin de Gparted. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...