Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
Devil505

Installer le driver proprio NVIDIA

Question

Pour installer le driver NVIDIA

sudo add-apt-repository -y ppa:graphics-drivers/ppa
sudo apt -y update
sudo apt -y install nvidia-settings nvidia-384 software-properties-gtk

Puis rebootez

 

Liste des paquets ici https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

 

vérifiez si une version du paquet nvidia-*** plus à jour est disponible

  • Like 1

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

En théorie oui pour les jeux qui demandent beaucoup de ressources graphiques.

Share this post


Link to post
Share on other sites
  • 0

Pour installer le driver NVIDIA

sudo add-apt-repository -y ppa:graphics-drivers/ppa
sudo apt -y update
sudo apt -y install nvidia-settings nvidia-370

Puis rebootez

 

Liste des paquets ici https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

 

vérifiez si une version du paquet nvidia-*** plus à jour est disponible

 

Merci pour la 1ère ligne de code qui permet à mon système de mettre à jour le driver nvidia!!

Share this post


Link to post
Share on other sites
  • 0

salut,

 

je l'ai installé sur mon ordi sous loki et quand je redémarre l'ordi le pilote graphique plante. Obligé de faire un purge nvidia* pour que ça refonctionne.

 

Le fait que ma GT 540M ai la technologie Optimus doit y être pour quelque chose mais même bumblebee ne règle rien. Je l'ai désinstallé du coup.

 

Une idée ?

Edited by Apache

Share this post


Link to post
Share on other sites
  • 0

salut,

 

je l'ai installé sur mon ordi sous loki et quand je redémarre l'ordi le pilote graphique plante. Obligé de faire un purge nvidia* pour que ça refonctionne.

 

Le fait que ma GT 540M ai la technologie Optimus doit y être pour quelque chose mais même bumblebee ne règle rien. Je l'ai désinstallé du coup.

 

Une idée ?

 

Sur le dépôt il a un parquet nvdiia-prime et bumblebee.

Une piste peut etre ici: http://askubuntu.com/questions/792929/how-to-install-sane-graphics-drivers-for-nvidia-optimus-hardware-on-ubuntu-16-0

Share this post


Link to post
Share on other sites
  • 0

Re,

j'ai suivi le tuto de ton lien mais dès que j'arrive à l'étape de l'installation du pilote nvidia (que se soit le 304, 357, 361 ou 370) j'ai un black screen près le reboot...

j'ai réussi à installer bumblebee mais dès que je passe à l'étape d'installation des pilotes, ça plante.

J'ai essayé aussi http://www.webupd8.org/2016/08/how-to-install-and-configure-bumblebee.html

mais quand j'arrive à l'étape 4, j'ai cette erreur qui s'affiche :

[email protected]<script data-cfhash='f9e31' type="text/javascript">/*  */</script>:~$ gksu gedit /etc/bumblebee/bumblebee.conf
Gtk-Message: Failed to load module "pantheon-filechooser-module"

(gksu:4015): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »

(gksu:4015): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »

du coup la suite ne sers à rien.

 

J'avoue que là je sèche complètement, aucun pilote ne marche à part le "nouveau" qui casse pas des briques quand je veux lancer une appli un peu gourmandes (jeu ou autre).

 

 

Share this post


Link to post
Share on other sites
  • 0
(gksu:4015): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »

Utilises tu un autre thème GTK que celui par défaut (elementary) ?

Share this post


Link to post
Share on other sites
  • 0

Repasse sous le thème elementary et retente la manip, histoire de voir.

 

le 

Gtk-Message: Failed to load module "pantheon-filechooser-module"

est aussi étrange :/

Share this post


Link to post
Share on other sites
  • 0

Avec le thème elementary par défaut j'ai, d'abord sans être root :

apache@Satellite-P770:~$ gksu gedit /etc/bumblebee/bumblebee.conf
Gtk-Message: Failed to load module "pantheon-filechooser-module"

par contre si je me logue en root, aucun message d'erreur n'apparaît mais rien ne se passe...

 

(j'ouvre un nouveau sujet ici pour ne pas trop saturer celui-ci)

Share this post


Link to post
Share on other sites
  • 0

J'ai rajouté au premier post le paquet nécessaire pour passer au driver proprio et j'ai mis à jour la version du driver (375) :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...