Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
francois

incapable de d'amorcer EOS sur usb pour un pavilion dv1540ca de hp

Question

J'ai installer l'iso de EOS sur une clef usb. Celle-ci s'amorce bien sur deux autres ordinateurs et m'a permis d'installer EOS. Par contre, lorsque j'utilise la même clef pour amorce mon vieux laptop un pavilion dv1540ca de hp, la clef usb avec EOS ne s'amorcera pas.

 

Les caractéristiques du dv1540ca respectent les exigeances minimales d'EOS. Je les réfère en hyperliens ici:

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00588967&tmp_task=prodinfoCategory&cc=us&dlc=en&jumpid=reg_r1002_usen_c-001_title_r0001&lc=en&product=1838153

 

Les suggestions seraient appréciées.

 

Merci.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Et avec un autre OS?

 

Sinon c'est le bios qui ne prend peut être pas les clés USB pour des install

Share this post


Link to post
Share on other sites
  • 0

Tu vas rire... J'ai exactement le même ordinateur et exactement le même problème qui m’empêche de tester freya depuis des mois...

 

Et dans la lignée des coïncidences : je viens d'y arriver il y'a juste une heure !!! (tu tombes vraiment bien) Alors c'est un gros hack dégueulasse et pas super pratique/facile mais ça a le mérite de fonctionner http://doc.ubuntu-fr.org/tutoriel/grub2_lancer_des_images_iso

 

@+

Share this post


Link to post
Share on other sites
  • 0

@astianax:

Le bios est ajusté pour la clef usb. J'arrive à booter avec d'autres OS linux. Notamment porteus.

@kido:

J'ai une copie du fichier iso du live cd d'EOS sur ma partition /mnt/sda7. Je vais essayer l'entrée suivante dans le fichier /etc/grub.d/40_custom:

 

menuentry ".. EOS 14.04 Trusty i386" {

insmod loopback

insmod iso9660

set isofile="/mnt/sda1/root/elementaryos-unstable-i386.20140331.iso"

#recherche de la partition dans laquelle se trouve le fichier ISO et montage de celle ci dans "/"

search -sf $isofile

#Montage du fichier ISO dans (loop)/

loopback loop $isofile

echo 'Chargement du noyau Linux ...'

linux (loop)/casper/vmlinuz.efi iso-scan/filename=$isofile boot=casper file=/cdrom/preseed/ubuntu.seed quiet splash --

echo 'Chargement du disque mémoire initial ...'

initrd (loop)/casper/initrd.lz

}

 

Je vous revient pour communiquer le résultat.

Edited by francois

Share this post


Link to post
Share on other sites
  • 0

Oui effectivement chez moi c'était que vmlinuz pas vmlinuz.efi ;)

Share this post


Link to post
Share on other sites
  • 0

@kido:

C'est tout à fait cela. En changeant:

linux (loop)/casper/vmlinuz.efi

pour

linux (loop)/casper/vmlinuz

 

Cela fonctionne.

 

Merci.

 

@astianax et kido:

En observant un peu mieux j'ai réalisé qu'aucune clef ne bootait sur le pavilion dv1540ca de hp. Je me demande si de mettre à jour le bios ne règlerait pas le problème?

Share this post


Link to post
Share on other sites
  • 0

Disons que le problème c'est l'efi et non ton bios, la structure des bios sont plus comme avant, a cause de microsoft qui se lance dans une logique commerciale a la apple.

Ils essaient de verrouiller les machines avec uniquement w8, et donc avant ce qui était un micro logiciel de gestion matériel, séparé de l'os, se retrouve maintenant a 80% géré par l'os. Du coup linux doit changer son approche de boot :)

Share this post


Link to post
Share on other sites
  • 0

@pioupiou:

Le laptop pavilion dv1540ca date des années 2005 à 2008 environ. Je ne crois pas que windows avait déjà commencé à serrer la vis aussi sérieusement à ce moment-là.

Share this post


Link to post
Share on other sites
  • 0

Pas sûr :)

 

Les systèmes basés sur Linux sont capables de gérer l'EFI au démarrage depuis 2000 en utilisant le chargeur d'amorçage Elilo. Il peut être utilisé par les plates-formes IA-64, IA-32 et offre une prise en charge pour le x86-64 depuis juillet 2007. GRUB supporte l'EFI depuis 20062.

Linux prend en charge l'EFI depuis sa version 2.4.203, et peut s'amorcer directement en tant qu'exécutable EFI depuis la version 3.34.

HP-UX utilise l'EFI sur ses systèmes IA-64 depuis 2002.

Share this post


Link to post
Share on other sites
  • 0

beaucoup de pc portable d'HP ne prend pas le live usb (mais prend bien des lecteur dvd externe ^^" .... )

 

j'utilise une astuce qui marche bien avec la virtualisation, j'utilise une partition physique de mon ssd/hdd pour faire une install :P

par contre, l'installation de grub sera obligatoirement sur la partition et non sur l'intégralité du disque ( sinon c'est la vm qui plantera)

 

je ne sais pas si virtualbox le fait maintenant, mais vmware oui.

 

(ps: j'utilise cette technique aussi pour installer de force les kernel qui ne passe pas la partie maj pilote graphique...)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...