Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
grothieum

liste officielle dépots et problème libreoffice

Question

Un problème, s'il en est...

je voudrais savoir s'il existe une liste de dépots types pour eOS svp.

Edited by grothieum

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

je ne comprends pas... depuis que je viens de lancer une mise à jour :

sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libreoffice-base : Dépend: libreoffice-base-core (= 1:4.3.0-0ubuntu1~precise1) mais 1:4.3.0-3ubuntu1~precise1 est installé
                   Dépend: libreoffice-base-drivers (= 1:4.3.0-0ubuntu1~precise1) mais 1:4.3.0-3ubuntu1~precise1 est installé
                   Dépend: libreoffice-core (= 1:4.3.0-0ubuntu1~precise1) mais 1:4.3.0-3ubuntu1~precise1 est installé
libreoffice-core : Casse: libreoffice-base (< 1:4.3.0-3ubuntu1~precise1) mais 1:4.3.0-0ubuntu1~precise1 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Share this post


Link to post
Share on other sites
  • 0

et

apt-get -f install

a déjà été tenté...

 

voilà ce que ça donne :

 

sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés : 
 libreoffice-base
Paquets suggérés :
 libreoffice-gcj libreoffice-report-builder unixodbc
Les paquets suivants seront mis à jour :
 libreoffice-base
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
29 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 170 ko dans les archives.
Après cette opération, 2 841 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O
(Lecture de la base de données... 223694 fichiers et répertoires déjà installés.)
Préparation du remplacement de libreoffice-base 1:4.3.0-0ubuntu1~precise1 (en utilisant .../libreoffice-base_1%3a4.3.0-3ubuntu1~precise1_amd64.deb) ...
Dépaquetage de la mise à jour de libreoffice-base ...
dpkg : erreur de traitement de /var/cache/apt/archives/libreoffice-base_1%3a4.3.0-3ubuntu1~precise1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/lib/libreoffice/share/basic/script.xlc », qui appartient aussi au paquet libreoffice-common 1:4.3.0-3ubuntu1~precise1
dpkg-deb (sous-processus) : le sous-processus données a été tué par le signal (Relais brisé (pipe))
dpkg-deb : erreur : le sous-processus <decompress> a retourné une erreur de sortie d'état 2
dpkg : erreur : --compare-versions prend trois paramètres : <version> <relation> <version>

Utiliser « dpkg --help » pour une obtenir une aide sur l'installation et la désinstallation des paquets [*] ;
Utiliser « dselect » ou « aptitude » pour gérer les paquets de manière
plus conviviale ;
Utiliser « dpkg -Dhelp » pour obtenir une liste des valeurs drapeaux de débogage ;
Utiliser « dpkg --force-help » pour consulter la liste des options de forçage ;
Utiliser « dpkg-deb --help » pour obtenir une aide sur la manipulation des fichiers *.deb ;

Les options marquées d'un [*] affichent beaucoup d'informations - tubez-les à travers « less » ou « more ».
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libreoffice-base_1%3a4.3.0-3ubuntu1~precise1_amd64.deb
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (1)

Edited by grothieum

Share this post


Link to post
Share on other sites
  • 0

libreoffice est dans les dépôt de ubuntu, je te conseil de supp ce dernier et de retenter l'install.

 

dans le cas qu'il manque des dépendances je t'invite a faire cela:

sudo add-apt-repository ppa:libreoffice/ppa -y
sudo apt-get update; sudo apt-get install libreoffice

Share this post


Link to post
Share on other sites
  • 0
Et avec sudo apt-get install -f ?

 

déjà fait, voir un peu plus haut... ne veut rien entendre, le bougre !

Share this post


Link to post
Share on other sites
  • 0

et le

sudo apt-get remove --purge libreoffice

 

beh, il m'insulte tout autant... il veut aussi que je fasse un

sudo apt-get install -f 

 

Il se mord la queue...

 

Quant au ppa, j'ai déjà le bon d'ajouté...

Share this post


Link to post
Share on other sites
  • 0

bonjour,

 

j'ai exactement le même problème et pas plus de solution ....

Share this post


Link to post
Share on other sites
  • 0

dans ce cas, je vous conseil de faire une install propre + ppa libreoffice la prochaine fois pour installé libreoffice.

 

j'avais réglé mon problème comme ça il y a quelque temps...

Share this post


Link to post
Share on other sites
  • 0

mon install était propre, je pense, et j'ai eu d'autres mises à jour depuis, le problème pour moi est tout récent, peut être dernière maj de libreoffice, quoiqu'il en soit, je ne réinstalle pas tout le système, je vais attendre encore un peu et passer sous freya !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...