Jump to content
ElementaryOS France

Eric_M

Membres
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Eric_M

  • Rank
    Débutant
  1. Problème résolu grâce à vos conseils ! Merci beaucoup Nettlebay et TSGeek. Une bonne galère qui se termine sur une réussite et m'aura fait passé du statut de néophyte en linux à celui de débutant expérimenté ! Je récapitule ce que j'ai du faire pour lancer modelio, si cela peut servir à d'autres : Système : eOS 0.3.2 Freya 64 bits sur ordi Dell Inspiron Logiciel à installer : modelio, logiciel libre de modélisation de système. Cf https://fr.wikipedia.org/wiki/Modelio Logiciel non dispo en logithèque, .deb ou PPA Seule source connue : https://www.modelio....ad-modelio.html Le fichier est disponible sous la forme d'une archive au format .tar.gz Mais ce n'est pas un programme à compiler, simplement une archive à extraire après avoir installé les programmes pré-requis sur l'ordinateur. La page de téléchargement indique : Download Modelio from www.modelio.org/download. Extract the package into the directory of your choice. Start Modelio. No installation is required for launching Modelio. Just unzip the downloaded archive and use Modelio! 1) Vérification des pré-requis demandés par la page de téléchargement : A l'aide de Synaptic, vérifier un par un que les paquets et autres logiciels requis sont présents sur la bécanne. Pour ma part la plupart des paquets sont déjà installés sauf : - stdc++6 . Un paquet libstdc++6-4.7 est disponible au téléchargement mais pas installé. Installation du paquet. Paquet libstdc++6-4.7 installé - Java 8 : On peut supposer qu'il s'agit d'installer JDK8 comme indiqué sur un forum. Par ailleurs en prérequis il est demandé Ubuntu 12.04 mais Ubuntu 14.04 convient bien. 2) Installation de JAVA JDK 8 Pour savoir quelle version de Java est installé, je tape : sudo update-alternatives --config java Je lis : Il existe 2 choix pour l'alternative java (qui fournit /usr/bin/java). Sélection Chemin Priorité État ------------------------------------------------------------ * 0 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071 mode automatique 1 /usr/bin/gij-4.8 1048 mode manuel 2 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071 mode manuel ==> Actuellement JAVA 7 est installé. En recherchant java JDK 8 sur google on trouve cette page de téléchargement : http://www.oracle.co...ds-2133151.html qui propose une archive au format tar.gz à télécharger pour JDK 8 pour Linux 64. Il est peut-être possible d'installer JDK 8 mais pour ma part mes tentatives sont infructueuses malgré le strict respect des instructions. Après sollicitation du forum Nettlebay m'indique une adresse signalant le code d'un dépot PPA à intégrer comme source de logiciel pour Java JDK 8. http://www.webupd8.o...tu-via-ppa.html ou http://www.webupd8.o...by-webupd8.html Cette page indique la démarche suivante pour intégrer ce dépot PPA : Our PPA supports Ubuntu 15.04, 14.10, 14.04 and 12.04 as well as Linux Mint 17.1, 17 and 13. Add the PPA and install Oracle Java 8 (the package provides both JDK8 and JRE8) using the following commands: sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer Je tape donc : sudo add-apt-repository ppa:webupd8team/java Puis je tape : sudo apt-get update Il s'affiche des centaines de lignes, dont les dernières sont : Lecture des listes de paquets... Fait W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/main amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_main_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/universe amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_universe_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/multiverse amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/restricted amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/main i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_main_binary-i386_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/universe i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_universe_binary-i386_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/multiverse i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-i386_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/restricted i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-i386_Packages) W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes. Je tape donc : apt-get update Il s'affiche : E: Impossible d'ouvrir le fichier verrou /var/lib/apt/lists/lock - open (13: Permission non accordée) E: Impossible de verrouiller le répertoire /var/lib/apt/lists/ E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée) E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ? Du coup je tape : sudo apt-get update Il s'affiche : des centaines de lignes dont les dernières sont : Lecture des listes de paquets... Fait W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/main amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_main_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/universe amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_universe_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/multiverse amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/restricted amd64 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-amd64_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/main i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_main_binary-i386_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/universe i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_universe_binary-i386_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/multiverse i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-i386_Packages) W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/trusty-security/restricted i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-i386_Packages) W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes. Je ne saisis pas à nouveau sudo apt-get update car je l'ai déjà fait 2 fois. Conformément à ce qu'indique le dépôt, j'installe java en tapant : sudo apt-get install oracle-java8-installer Des centaines de lignes de commande s'affichent ainsi qu'un gros téléchargement. Les dernières lignes qui s'affichent sont : update-alternatives: utilisation de « /usr/lib/jvm/java-8-oracle/bin/rmic » pour fournir « /usr/bin/rmic » (rmic) en mode automatique update-alternatives: utilisation de « /usr/lib/jvm/java-8-oracle/bin/schemagen » pour fournir « /usr/bin/schemagen » (schemagen) en mode automatique update-alternatives: utilisation de « /usr/lib/jvm/java-8-oracle/bin/serialver » pour fournir « /usr/bin/serialver » (serialver) en mode automatique update-alternatives: utilisation de « /usr/lib/jvm/java-8-oracle/bin/wsgen » pour fournir « /usr/bin/wsgen » (wsgen) en mode automatique update-alternatives: utilisation de « /usr/lib/jvm/java-8-oracle/bin/wsimport » pour fournir « /usr/bin/wsimport » (wsimport) en mode automatique update-alternatives: utilisation de « /usr/lib/jvm/java-8-oracle/bin/xjc » pour fournir « /usr/bin/xjc » (xjc) en mode automatique update-binfmts: warning: current package is oracle-java8, but binary format already installed by openjdk-7 Oracle JDK 8 installed update-alternatives: utilisation de « /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libnpjp2.so » pour fournir « /usr/lib/mozilla/plugins/libjavaplugin.so » (mozilla-javaplugin.so) en mode automatique Oracle JRE 8 browser plugin installed Paramétrage de gsfonts-x11 (0.22) ... idee@idee-Inspiron-1570:~$ Java JDK 8 est donc apparement installé ! Le dépôt PPA indique ensuite : Once installed, running "java -version" in a terminal should output something like this: andrei@andrei-desktop:~$ java -version java version "1.8.0_31" Java SE Runtime Environment (build 1.8.0_31-b13) Java HotSpot 64-Bit Server VM (build 25.31-b07, mixed mode) Or, "javac -version": andrei@andrei-desktop:~$ javac -version javac 1.8.0_31 And so on. Je tape donc : java -version Il s'affiche : idee@idee-Inspiron-1570:~$ java -version java version "1.8.0_72" Java SE Runtime Environment (build 1.8.0_72-b15) Java HotSpot 64-Bit Server VM (build 25.72-b15, mixed mode) idee@idee-Inspiron-1570:~$ 3) Installation de modelio : Je télécharge modelio 3.4.1 pour linux 64 à l'aide du lien fournit dans la page https://www.modelio....ad-modelio.html Je l'enregistre dans un dossier A l'aide du gestionnaire d'archive j'extrais le dossier (nommé Modelio 3.4) de l'archive et l'enregistre à la même racine. J'ouvre le dossier. Je double clique sur le fichier m-bin (fichier executable). J'attends quelques secondes et je vois que modelio se lance et fonctionne. Cela marche aussi en double-cliquant sur le fichier "modelio" Modelio est installé et fonctionne !!! Par contre je ne sais pas comment créer un raccourci pour lancer plus facilement modelio depuis Application.
  2. Ce serait pas le même problème que sur ce topic par hasard ? http://forum.elementaryos-fr.org/topic/1995-picto-inconnu-dans-la-barre-du-haut/
  3. Bon ma Dropbox semble bien fonctionner, c'est le principal, si l'icone déconne ce n'est pas bien grave. Merci pour vos avis !
  4. Bonjour, depuis quelques jour un pictogramme inconnu est apparu dans la barre du haut. Rectangle noir entouré de blanc avec un rond rouge barré au milieu. Quand je clique dessus une info bulle apparait mais elle est minuscule et il n'y a pas de texte dessus. Cf photos Qu'est-ce que cela peut bien être ? Système : eOS 0.3.2 Freya 64 bits sur ordi Dell Inspiron (j'ai une photo mais je ne sais pas comment la joindre au message, désolé alors la voici stocké sur google drive : https://drive.google.com/file/d/0B8xT_QRIf9vITk5VTWRmTGZtc2M/view?usp=sharing
  5. Bonjour, j'essaie d'installer un logiciel à partir d'une archive en .tar.gz, sans succès. Après quelques nuits de tentatives, je sèche un peu. Si quelqu'un peut m'aider ce serait super ! Système : eOS 0.3.2 Freya 64 bits sur ordi Dell Inspiron Logiciel à installer : modelio, logiciel libre de modélisation de système. Le logiciel n'est pas disponible dans la logithèque, je ne l'ai pas trouvé non plus en .deb Seule source connue : https://www.modelio.org/downloads/download-modelio.html Cette page indique : For information on supported operating systems and required libraries, check system requirements. Download Modelio from www.modelio.org/download. Extract the package into the directory of your choice. Start Modelio. Le fichier est disponible sous la forme d'une archive au format .tar.gz : Il s'agit donc d'après https://doc.ubuntu-fr.org/tutoriel/compilation un code source qu'il faut compiler. La page https://doc.ubuntu-fr.org/tutoriel/compilation indique : Pour compiler un programme il faut au préalable installer sur sa machine les programmes suivants : En résumé, vous devriez installer les paquets build-essential fakeroot checkinstall . build essential : OK déjà installé. fakeroot : idem Checkinstall n'était pas installé, je l'ai installé en cliquant sur le lien ci-dessus. Vérification des pré-requis demandés par la page de téléchargement : Je passe en revue le système en regardant dans Synaptic pour chacun de requirements suivants : - Ubuntu 12.04 LTS (i386/amd64) : Mon système est basé sur la plateforme Ubuntu 14.04. Je possède une plateforme plus récente. Est-ce qu'elle est compatible ? (suite : voir plus bas). Un forum indique que Ubuntu 14.04 peut faire marcher modelio, mais cependant il faut JDK 8. - libc6 : un certain nombre de paquets libc6 sont installés et en particulier le paquet nommé strictement libc6. D'autres ne le sont pas. On peut faire l'hypothèse que les paquets installés sont suffisants. Aucune action pour le moment - libatk : Un certain nombre de paquets libatk sont installés et en particulier le paquet nommé strictement libatk1.0-0 D'autres ne le sont pas. On peut faire l'hypothèse que les paquets installés sont suffisants. Aucune action pour le moment - libcairo : Un certain nombre de paquets libcairo sont installés et en particulier le paquet nommé strictement libcairo2 D'autres ne le sont pas. On peut faire l'hypothèse que les paquets installés sont suffisants. Aucune action pour le moment - libgtk2 : Un certain nombre de paquets libgtk2 sont installés et en particulier le paquet nommé strictement libgtk2.0-0 D'autres ne le sont pas. On peut faire l'hypothèse que les paquets installés sont suffisants. Aucune action pour le moment - libglib2 : Un certain nombre de paquets libglib2 sont installés et en particulier le paquet nommé strictement libglib2.0-0 D'autres ne le sont pas. On peut faire l'hypothèse que les paquets installés sont suffisants. Aucune action pour le moment - libwebkit-1.0 : Ce paquet n'est pas visible dans synaptic. On trouve par contre des fichiers libwebkitgtk qui semblent remplir la même fonction. On peut faire l'hypothèse que les paquets installés sont suffisants. Aucune action pour le moment - libxtst6 : Un certain nombre de paquets libgxtst6 sont installés et en particulier 2 paquets nommé strictement libxtst6. D'autres ne le sont pas. On peut faire l'hypothèse que les paquets installés sont suffisants. Aucune action pour le moment - stdc++6 : Un paquet libstdc++6-4.7 est disponible au téléchargement mais pas installé. Installation du paquet. Paquet libstdc++6-4.7 installé - Java 8 (from Modelio 3.3) : On peut supposer qu'il s'agit d'installer JDK8 comme indiqué sur le forum. Installation de JAVA JDK 8 Actuellement JAVA 7 est installé. Si on tape : sudo update-alternatives --config java on peut lire : Il existe 2 choix pour l'alternative java (qui fournit /usr/bin/java). Sélection Chemin Priorité État ------------------------------------------------------------ * 0 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071 mode automatique 1 /usr/bin/gij-4.8 1048 mode manuel 2 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071 mode manuel En recherchant java JDK 8 sur google on trouve cette page de téléchargement : http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html choix de la version à télécharger : Pour Linux x64, il y a le format .rpm et le format .tar.gz. Le premier format est réservé aux distributions linux basées sur Red Hat et n'est donc pas adapté, comme permet de le comprendre la page https://doc.ubuntu-fr.org/installation_non_standard_de_logiciel Je télécharge donc Java JDK 8u73 pour linux x64 au format .tar.gz L'instruction d'installation est : Installation of the 64-bit JDK on Linux Platforms This procedure installs the Java Development Kit (JDK) for 64-bit Linux, using an archive binary file (.tar.gz). These instructions use the following file: jdk-8uversion-linux-x64.tar.gz Download the file. Before the file can be downloaded, you must accept the license agreement. The archive binary can be installed by anyone (not only root users), in any location that you can write to. However, only the root user can install the JDK into the system location. Change directory to the location where you would like the JDK to be installed, then move the .tar.gz archive binary to the current directory. Unpack the tarball and install the JDK. % tar zxvf jdk-8uversion-linux-x64.tar.gz The Java Development Kit files are installed in a directory called jdk1.8.0_version in the current directory. Delete the .tar.gz file if you want to save disk space. Conformement aux instructions je fais : - lancement du terminal - execution de la commande % tar zxvf jdk-8u73-linux-x64.tar.gz Le système me répond : bash: fg: % : tâche inexistante je recommence sans le %. Des centaines de lignes s'écrivent, apparement sans message d'erreurs ! Je ne supprime pas l'archive. Pour savoir si Java JDK 8 est installé, je tape dans le terminal : sudo update-alternatives --config java Le terminal affiche : Il existe 2 choix pour l'alternative java (qui fournit /usr/bin/java). Sélection Chemin Priorité État ------------------------------------------------------------ * 0 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071 mode automatique 1 /usr/bin/gij-4.8 1048 mode manuel 2 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1071 mode manuel Appuyez sur <Entrée> pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné : De plus si je tape locate java-8 le terminal ne trouve absolument rien. Si je tape locate java-7, le terminal trouve plein de fichiers. Du coup je n'ai pas l'impression que JDK 8 soit installé. Retour à l'installation de Modelio : La page de téléchargement du code source indique également : No installation is required for launching Modelio. Just unzip the downloaded archive and use Modelio! Cela me déroute un peu mais bon on verra bien. Je télécharge modelio 3.4.1 pour linux 64 à l'aide du lien fournit dans la page https://www.modelio.org/downloads/download-modelio.html Je l'enregistre dans DOSSIERS_PERSO/0_logiciels_telecharges/Modelio A l'aide du gestionnaire d'archive j'extrais le dossier (nommé Modelio 3.4) de l'archive et l'enregistre à la même racine. J'ouvre le dossier. - Je clique sur un fichier nommé « modelio » de type « stript shell ». Au bout de quelques secondes, le système affiche une fenetre indiquant : « An error has occured. See the log file /home/idee/workspace/.metadata/.log - je clique sur le fichier M-bin, le même message d'erreur apparaît. Je décide de supprimer le dossier modelio 3.4 ainsi que le dossier .metadata puis j'execute la ligne de commande vue pour java, c'est à dire : tar zxvf modelio-open-201512081403-linux.gtk.x86_64.tar.gz Des centaines de lignes de commande s'incrivent sans erreur. Mais il s'agit apparement simplement d'une extraction de l'archive dans le dossier modelio 3.4. Est-ce différent comme opération que d'effectuer une extraction de l'archive à l'aide du gestionnaire d'archive ? Apparement non. Dans modelio 3.4 je reclique sur les mêmes fichiers et retombe sur les mêmes messages d'erreur. Je constate que le dossier metadata est lui aussi reconstitué. Modelio ne se lance pas. Mes questions : - Comment finaliser l'installation de java JDK 8 ? - Est-ce que la non installation de java JDK 8 est la seule raison du non fonctionnement de modelio ? - Est-ce que la procédure d'installation de modelio à partir de l'archive, une fois vérifié les pré-requis pour le système, consiste simplement à extraire le dossier de l'archive en .tar.gz ou bien faut-il faire d'autres chose ? - Une fois tout installé, comment faire pour lancer modelio ? Désolé pour la longueur du post, je préfère mettre un maximum de détails. Merci à ceux qui pourront apporter quelques conseils.
  6. J'écris ce post en inaugurant Elementary installé sur mon ordi !!! Donc merci beaucoup Nettlebay ! Tes conseils m'ont convaincu d'essayer l'install à partir d'un CD plutôt qu'une clef USB et ce fut payant tout a fonctionné du premier coup. En fait, étant donné que le fichier iso de freya fait 887 Mo et qu'un CD ne supporte que 700 Mo j'étais parti sur l'option clef USB. Suite à ton message j'ai quand même essayé de graver les 887 Mo sur un CD de 700 mais non, même au pied de biche ça ne rentrait pas. Du coup je me suis dis "bon, quand ils parlent de CD en fait c'est peut-être des DVD", du coup j'ai gravé l'iso sur un DVD (à l'aide du logiciel FreeIsoBurner), et c'est avec ce DVD que j'ai pu faire toute l'installation sans aucun problème. Donc ce n'était apparement pas un problème de formatage de disque dur. Merci encore pour le coup de pouce
  7. Bonjour Je n'arrive pas à installer Elementary sur mon ordinateur équipé d'un disque dur SSD neuf, ni même à le lancer en essai depuis la clef USB. Le lancement depuis la clef USB marche très bien sur un autre ordinateur. Je ne suis pas très calé en informatique. Historique des actions réalisées (sur ordinateur Dell) : - remplacement de l'ancien disque dur par un SDD Kingston V300 de 240 Go neuf et vierge - bootage d'Elementary sur clef USB, option "installer l'OS sur l'ordi" - début de la procédure d'installation. Rapidement apparait un message indiquant qu'il y a 0 bytes libres dans l'espace de stockage. - crash de la procédure d'install - utilisation d'EOS en mode sans installation. Arrêt volontaire de l'ordi - re-tentative d'install, re-message, re-crash, re-arrêt - 3ème tentative. L'ordi ne veut plus booter sur la clef, même en mode sans install. Le message suivant apparait : [1.519100] ACPI PCC probe failed [3.823730] sd 4:0:0:0:0 [sdb] no caching mode page found [3.823812] sd 4:0:0:0:0 [sdb] assuming drive cache : write through Busybox V1.21.1 (Ubuntu 1.1.21.0_1ubuntu1) built-in shell (ash) Enter "help" for a list of built-in commands (initramfs) stdin : not a typewriter Mount : mounting aufs on/root failed : no space left on device aufs mount failed Le disque SSD apparait dans le bios, avec un volume de 240 Go Comment résoudre ce problème ? Est-ce que c'est une question de formatage de disque ? Merci
×
×
  • Create New...