Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
Devil505

[A LIRE AVANT DE POSTER] MAJ du Kernel LTS sous Luna

Question

AVANT DE POSTER UN MESSAGE SUR LA MAUVAISE RECONNAISSANCE D'UN MATÉRIEL SOUS LA VERSION ELEMENTARY OS 0.2 LUNA (BASÉE SUR UBUNTU 12.04 PRECISE), PENSEZ À METTRE À JOUR LA VERSION DU KERNEL LTS

 

 

Avec le LTS Enablement Stack 1)Ubuntu 12.04 LTS n'est plus limité à la version du kernel linux fourni à sa sortie.

Suivant la date à laquelle on a installé Precise (12.04 LTS), on va se retrouver avec un noyau différent et une gestion de l'affichage différente ( comme le montre le schéma précédent) 
Ainsi, les nouvelles iso d'Ubuntu 12.0412.04.5 , intègrent un kernel 3.13.0-x de trusty plutôt qu'un kernel 3.2.0-x fourni à la sortie de Precise 
Ceci permettant d'installer une Ubuntu 12.04 LTS en bénéficiant de la prise en charge de nouveaux matériels intégré dans un kernel plus récent, celui de la version non LTS en cours.

Sur du matériel déjà reconnu le passage au HWE (Hardware Enablement Stack) de la LTS a peu d’intérêt, et est même déconseillé pour des machines virtuelles.

 

 

Procédure à suivre:

 

en ligne de commande tapez ceci afin d'installer le kernel LTS de la version d'Ubuntu 14.04.2 Trusty 

sudo apt-get install --install-recommends linux-generic-lts-trusty xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty

Ensuite, rebootez et vous aurez le kernel 3.13, tapez la commande uname -a pour vérifier

 

source: http://doc.ubuntu-fr.org/ltsenablementstack

 

 

 

Si votre problème n'est pas résolu, pensez aussi à faire une recherche sur google avec comme mot clés le modèle de votre matériel et des mots comme: Ubuntu 12.04 precise

 

Une solution fonctionnant pour Ubuntu 12.04 Precise devrait en toute logique être valable pour elementary OS 0.2 Luna.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Et pour Freya (actuellement en bêta, basée sur Trusty) ? Est-ce qu'il faut installer les paquets *-lts-utopic dispo actuellement, puis *-lts-vivid quand il sera disponible (etc.) ? ou bien il faut installer le *-lts-trusty (à la place du linux-generic d'origine) et s'y tenir ?

 

En fait, je ne comprends pas bien si le LTS enablement stack évolue automatiquement ou s'il faut installer un nouveau noyau manuellement à chaque fois qu'il y a une nouvelle version (14.04.1, 14.04.2...). D'autant que le gestionnaire de mise à jour ne me dit pas qu'il y a une nouvelle version disponible.

 

EDIT : question subsidiaire : si je passe au noyau *-lts-utopic, est-ce que je dois passer le PPA de Oibaf que j'utilise (et qui met à jour Xorg notamment) en version utopic ou rester en trusty ?

Share this post


Link to post
Share on other sites
  • 0

Et pour Freya (actuellement en bêta, basée sur Trusty) ? Est-ce qu'il faut installer les paquets *-lts-utopic dispo actuellement, puis *-lts-vivid quand il sera disponible (etc.) ? ou bien il faut installer le *-lts-trusty (à la place du linux-generic d'origine) et s'y tenir ?

 

En fait, je ne comprends pas bien si le LTS enablement stack évolue automatiquement ou s'il faut installer un nouveau noyau manuellement à chaque fois qu'il y a une nouvelle version (14.04.1, 14.04.2...). D'autant que le gestionnaire de mise à jour ne me dit pas qu'il y a une nouvelle version disponible.

 

EDIT : question subsidiaire : si je passe au noyau *-lts-utopic, est-ce que je dois passer le PPA de Oibaf que j'utilise (et qui met à jour Xorg notamment) en version utopic ou rester en trusty ?

 

Pour Freya, c'est moins utile car il y a déjà le 3.13, j'ai crée ce post surtout pour Luna qui peut souffrir de mauvaise reconnaissance matos sans le kernel LTS de trsuty. Une fois que la prochaine LTS (la 16.04) après Trusty sera sortie, là oui il sera judicieux d'installer le kernel de cette version. Je pense qu'il est possible d'ajouter le kernel utopic-lts aussi mais je n'ai pas testé.

 

Pour la question en bonus, je pense que ce n'est pas nécessaire, en fait tu installes le kernel utopic-lts sur une trusty donc il faut rester en trusty.

 

EDIT: Sur le site askubuntu, j'ai trouvé ceci pour les intéressés:

 

 

 

Now that 14.10 has been released, there is an easier and better way to get 3.16 on Ubuntu 14.04:

sudo apt-get install linux-image-generic-lts-utopic

This package will always depend on the latest 3.16 image available. (This method may not have been ready at the time of this article.)

 
1  
+1. This is a supported kernel backport in the hardware-enablement programme of Ubuntu LTS. More information here: wiki.ubuntu.com/Kernel/LTSEnablementStack As described on that page, make sure though, to also install the backported Xorg updates to prevent issues with your graphics/X stack (not available yet at the time of writing). –  gertvdijk Dec 16 '14 at 12:06

 

Donc il y a un risque sur le plan des pilotes graphiques s'ils ne sont pas compatibles.

Share this post


Link to post
Share on other sites
  • 0

Ouais, j'ai vu qu'il manquait le paquet xorg lts-utopic donc je vais éviter pour le moment. J'ai quand même installé les paquets lts-trusty, des fois que ça déclenche les mises à jour pour les prochaines versions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...