Jump to content
ElementaryOS France
  • 0
jeansbeul

plus d'interface graphique a l'aide!

Question

Bonjour à toutes et à tous! voila j'ai ma copine qui a un petit pc acer x1430 (une vrai daube entre nous!!) sa ramai a fond avec windows donc je lui ai mi linux a la place (elementary os) et je lui est mi une petite carte graphique interne (nvidia g210) pour remplacer le chipset graphique du processeur qui entre nous n'est pas une merveille en performance non plus!!

 

Bon jusqu'ici tous va bien!! apres avoir mi la carte graphique je me suis apperçu que les videos streaming saccadait donc j'ai installer flashplayer et sa ne m'a pas régler le probleme!! d'ailleur je cherche toujour à le régler!!. A partir de la je me dit bon ba je vais essayer sans la carte graphique pour voir donc je demarre sur le chipset graphique et la impossible de comfigurer correctement l'affichage à ma convenance!. Après plusieur essai et plein de gros mots!! je me résigne à remettre la carte et à chercher de nouveau une solution a se probleme de saccade.

 

Donc la je redemare avec la carte nvidia et la surprise!! plus d'interface graphique, que la console.

 

Quelqu'un d'entre vous saurai-t'il par le plus grand des hasard comment pourrai-je régler ce petit souci?

 

Merci à tous

  • Like 1

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0

bonjour tous le monde j'ai fais une sauvegarde des donnée et j'ai réinstaller le système! bien plus rapide! je vous remercie tous de votre aide et vous souhaite une bonne continuation.

Share this post


Link to post
Share on other sites
  • 0

Salut, démarre en recovery mode et choisi root puis essai ça:

X -configure

cp /root/xorg.conf.new /etc/X11/xorg.conf

reboot

Share this post


Link to post
Share on other sites
  • 0

Bonjour jeansbeul,

 

Vraisemblablement il doit te manquer les modules NVidia pour le boot. Pour te le faire valider, tu peux me communiquer le résultat de la commande suivante :

lsmod |grep nvidia

(normalement, tu ne devrais pas avoir de résultat).

 

Cordialement,

 

Nikos

Share this post


Link to post
Share on other sites
  • 0

bonjour

 

sudo apt-get remove --purge nvidia-<numero du driver que ta instaler> par exemple nvidia-340

 

puis

 

sudo reboot

Share this post


Link to post
Share on other sites
  • 0

merci pour vos réponse sa fait chaud au coeur!! on se sent mois seul!!

 

sabrimo, avant de remettre la carte nvidia j' ai installer les driver pour le chipset qui est de marque amd donc je ne connait pas le numéro du pilote nvidia!!

 

Nikos, j'ai essayer la commande que tu ma donner et sa me met comme résultat: nvidia(en rouge)             10618593    0

la euh ba je ne sait absolument pas se que sa veut dire!!

 

Guillaume, quand je teste la commande X -configure sa me met comme résultat: Fatal server error    could not create lock file in /tmp/.tX0-lock

 

Sa vous met peut-etre sur une piste?

Share this post


Link to post
Share on other sites
  • 0

essaye alors

 

sudo apt-get remove --purge nvidia-* ( l'etoile va desinstaler tous ce qui lié a ta carte graphique)

Share this post


Link to post
Share on other sites
  • 0

salut sabrimo et merci encore de ton aide!!. Alors j'ai essayer la commande avec l'option de l'étoile et sa me met:

 

W:Verrou non utilisé pour le fichier /var/lib/dpkg/lock en lecture seule

E: impossible d'écrire sur /var/cache/apt/

E:Les listes de paquets ou le fichier (status) ne peuvent être analysés ou lus.

 

????oups!!

Share this post


Link to post
Share on other sites
  • 0

Un verrou est toujours présent. Tente un reboot pour voir. Si cela ne résout pas ton soucis préviens moi, je t'expliquerai comment faire.

Share this post


Link to post
Share on other sites
  • 0

Pioupiou41, la commande sudo lightdm me met

failed to use bus name org.freedesktop.displayer, do you have appropriate permissions?

Share this post


Link to post
Share on other sites
  • 0

copie les lignes une par une pour réinstaller le driver NVIDIA, sans pour autant être sûr du résultat.

 

Si  64 bits

cd $HOME/Documents
wget http://fr.download.nvidia.com/XFree86/Linux-x86_64/340.65/NVIDIA-Linux-x86_64-340.65.run
sudo chmod 777 NVIDIA-Linux-x86_64-340.65.run
sudo ./NVIDIA-Linux-x86_64-340.65.run

Si 32 bits

cd $HOME/Documents
wget http://fr.download.nvidia.com/XFree86/Linux-x86/340.65/NVIDIA-Linux-x86-340.65.run
sudo chmod 777 NVIDIA-Linux-x86-340.65.run
sudo ./NVIDIA-Linux-x86-340.65.run

Share this post


Link to post
Share on other sites
  • 0

Ok tu peux me donner le résultat de la commande suivante ?

 

Fdisk -l

 

Nikos

Share this post


Link to post
Share on other sites
  • 0

Pourquoi pas...

 

Mais ça peut-être aussi un soucis de filesystem en Read Only, dans ce cas-là un fsck pourrait corriger l'affaire.

 

Mais ça peut-être aussi la présence du fichier lock qui en empêche la suppression des packages Nvidia, auquel cas un "simple" rm pourrait faire l'affaire. Attendons juste son retour pour statuer, t'en penses quoi Pioupiou ?

 

Nikos

Share this post


Link to post
Share on other sites
  • 0

J'en pense qu'il est tard et que les statues sont plus belles du coté de l'italie ou la grèce que par chez moi :)

Share this post


Link to post
Share on other sites
  • 0

si ce message s'affiche , c'est que ta quelques choses qui reste ouvert (logitheque, update....) ce qu'il faudra faire , c'est de commencer par faire un kill :

 

sudo killall -9 apt-get

 

si ça marche, tu fait la commande 

 

sudo apt-get remove --purge nvidia-*

 

si ça marche pas, je te conseil de suivre le tuto sur cette page : 

 

http://forum.ubuntu-fr.org/viewtopic.php?id=1206821

 

Bon courage

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...