Aller au contenu
ElementaryOS France
  • 0
couim

scintillement noir ecran Freya

Question

Bonjour,

 

Alors tout est dit dans le titre. J'ai installé Freya sur mon vieux Toshiba et quand j'utilise certainnes fonctionnalitées de l'interface (les coins intelligents par exemple ou les options de fond d'écran), et bien il me fait un scintillement noir, sur une demie portion en diagonale.

Et ça le fait sur un dixième de seconde mais plusieurs fois quand je bouge la souris

 

J'aimerai savoir si d'autres ont eu ce problème sous Freya, sachant que je n'avais aucun souci sous Luna :)

 

Merci d'avance !

Partager ce message


Lien à poster
Partager sur d’autres sites

18 réponses à cette question

Recommended Posts

  • 0

Problème de pilote graphique ?

 

J'ai une Nvidia et sans pilotes officiel c'est affreux le rendu sur Freya ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Salut ! Merci pour ta réponse!

 

Alors je le suis également posé cette question mais j'ai pas de pilotes additionnels proposés dans la liste :) et il n'y a pas de NVIDIA sur le mien du coup je sais pas trop

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Tape ça pour connaître ta carte graphique:

lspci | grep -i vga

Perso j'avais quelques soucis avec ma carte intel (HD4400) qui ont été résolu en mettant à jour le kernel en 3.19.3. Tu peux peut être essayer mais si ton matos est vieux je suis pas persuadé que ça aide...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Merci ! Je vais tester ça :-)

 

[EDIT]

Alors j'ai essayé et il me dit que j'ai un controller graphic intel

 

ducoup bah je vais voir si il n'y a pas de drivers pour ça mais je pense que c'est peine perdu si eOS n'a pas trouvé de Additionnal Drivers :/

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je ne sais pas si les problèmes de pilote intel sont résolus...

 

Tu n'as qu'un controleur graphic intel ? Ou tu as les deux ?

 

Que te dit la commande de Hide? Quelle est la référence du PC ?

 

Intérogatoire de police dis donc...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Tu ne trouvera pas de moyen simple de mettre à jour tes drivers intel, l'installateur n'étant plus compatible avec ubuntu 14.04 sur lequel est basée Freya. Le seul moyen simple d'espérer mettre à jour la compatibilité c'est de mettre à jour le kernel (ce qui est simple est sans risque).

 

Par contre je pense pas vraiment que ça résoudra ton problème puisque les nouveau noyaux - je crois - améliorent surtout la compatibilité avec du matos récent (ce qui était mon cas), or tu nous dis que tu fais ça sur un vieux toshiba... mais bon ça vaut le coup de tester à mon avis.

 

Par contre c'est vrai que des réponses aux questions de l'inspecteur Astianax aideraient -_-

 

"Nous afons les moyen te fou faire parler!" :lol:

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Astianax

Voici le résultat de la commande :

 

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)

 

Pour ce qui est de la référence du PC, il s'agit d'un Toshiba Satellite (je crois), je n'ai pas la référence exacte... On peut la trouver ? C'est un ordi qui date d'entre 2006 et 2008.
 

@Hiden, comment puis-je mettre à jour mon kernel ? Je veux bien essayer mais ça correspondrai à faire passer Linux 3.13 en linux 3.19 ? (Et il y a linux 4.0 qui est sorti)

 

@Los_titinos

Effectivement, mais essaie d'aller sur les options de bureau et d'afficher les fonds d'écran, il ne te fais pas un scintillement noir en diagonale ? :)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

bonjour,

 

Pour ma part c'est sur un HP Touchsmart TM2 avec ces foutues carte hybrides (ATI/INTEL). J'ai d'ailleurs pas été surpris de voir ces soucis graphique, vu le merdier que sont ces systeme hybride sous Linux. Cependant c'est la première depuis que je suis avec ce PC (3 ans) qui l'OS semble gerer ceci pas trop mal, même mieux que Ubuntu 14.10. Donc bravo a Freya.

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] (rev ff)
 
seb@seb-HP-TouchSmart-tm2-Notebook-PC:~$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
[sudo] password for seb: 
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0
2:DIS-Audio: :Off:0000:01:00.1
 

Et quand on changement de bureau, variety s'en occupe pour moi. Cependant je retrouve ce problème en overview (vue des fenêtre) et vue des bureau. 

 

Malgrés tout, cela ne semble pas impacter le fonctionnement du pc donc je ne pose pas trop de question a ce sujet.

 

Bonne journée.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Exactement ! Sur l'affichage des fenêtres ou des bureaux il y a le problème. C'est sans solution quoi....

 

L'erreur vient peut être du système ? Ou de la machine ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@couim : Non des pilotes linux en général pour intel... Le problème des gros fabriquant et de linux depuis des générations ;)

 

@Los_tintinos : si je ne dis pas de bêtises TLP ou laptop_mode_tools te permettent de couper une des cartes graphique. Tu peux gagner en autonomie et en en surchauffe sachant que deux en même temps ça ne sert pas à grand chose... Puis ça peut créer des conflits :wacko:

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

re,

 

drivers intel mise a jour sans résolution du probléme....

 

Comment t'as fait pour mettre jour tes drivers?

 

Franchement les gars tentez une maj du kernel ça peut résoudre pas mal de problème. Voilà les lien pour le 4.0 (en test sur ma machine depuis hier: aucun soucis)

 

64 bits:

cd /tmp/

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb

sudo dpkg -i linux-headers-4.0.0-*.deb linux-image-4.0.0-*.deb

32 bits:

cd /tmp/

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb

sudo dpkg -i linux-headers-4.0.0-*.deb linux-image-4.0.0-*.deb

Pensez à rendre grub visible au démarrage pour pouvoir booter sur l'ancien noyau en cas de pépin (ça m'est déjà arrivé de pas pouvoir le faire apparaitre et de devoir booter sur live-cd pour réparer le bouzin).

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

re,

 

 

@ astianax,

tu verra dans les tutos que j'en ai fait un pour couper les cartes discretes avec acpi_call. Mais depuis la 14.04 le systeme se met en Dynamique Off (Cf le cat  /... que j'ai mis dans mon message ci-dessus). et avec la 14.04 acpi-call ne tourne plus....

Et comme je le dit autant sous Ubuntuu gnome 14.04 l'autonomie tourne autour des 2h30/3h, sur eOS je tourne à 4h00 d'origine (soit comme avec la carte discrete en off avec acpi_call). Ainsi eOS gere parfaitement ce binz et je leur tire mon chapeau.

 

@Hidden 

 

J'ai suivi le tuto qui doit etre sur ce site je crois.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Hi,

 

J'ai tenté une mise a jour du kernel vers la 4.0.0 et me suis retrouvé sans wifi (carte non reconnu) sans réel changements sur l'ensemble de mes problémes. Donc retour à la 3.16...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour à tous,

Après moultes recherches  :huh: je viens de trouver ces deux commandes :

sudo  apt-get  purge  xserver-xorg-video-intel

sudo apt-get install xserver-xorg-core xserver-xorg-video-intel
pour la mise à jour pour les chipset intel  :wacko:
 
Un reboot plus tard ....
 
:D  :D  :D  plus aucun scintillement sur le multi-vue  :D  :D  :D
 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Salut à tous !

 

Je me permet de faire remonter ce(s) vieux posts, je pense que ça pourra aider certains :

 

Je suis sur un ACER Aspire avec chipset graphique Intel et j'ai pas mal cherché avant de réussir à résoudre ce problème de scintillement.

 

La réinstallation de xorg peut provoquer des instabilités du système et ça peut être compliqué de revenir en arrière pour certains, je vous le déconseille fortement (plus de soucis de scintillement mais un ralentissement général de la machine à la place...) !

 

Une solution plus simple et moins riquée pour éviter ce problème de scintillement est la suivante :

 

sudo apt-get install mesa-utils

 

sudo mkdir /etc/X11/xorg.conf.d/

 

echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf

 

sudo reboot

 

(cf. https://bugs.launchpad.net/elementaryos/+bug/1435861)

Voilà, j'espère avoir pu aider ceux qui passeraient par là  et qui voudraient éviter d'avoir à repartir sur une installation complète de l'OS ;)

Dites moi si ça marche chez vous, c'est le cas chez moi !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

a mon avis c'est simplement que le chip graphique gère mal certain effet du bureau

 

car ces vieux chip était bien reconnu avec les drivers libres

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×