Jump to content
ElementaryOS France
  • 0

impossible de passer le locksreen


Question

Bonjour ( chez moi), bonsoir chez vous.

 

je suis actuellement  devant un probleme de login / ecran de verrouillage.

 

je resume: j 'allume mon pc, qui tourne sous reya beta 2 ( oui je vient de me rendre compte que ma touche "f" vient de rendre l'ame Arg laptop bas de gamme...) je me suis rendu comte aussi il y a peu du passage final de freya.

 

boot normal, arriver au selecteur de session. je rentre sur ma session, met mon petit mot de passe (21 caractere) appuie sur entrée, l'ordi à l'air de l'accepter, me fais (comme toujours) un court ecran noir et.... je reviend au menu choix de session.

 

ayant changé de mot de passe il y a peu, j'ai donc betement essayer mon ancient mot de passe ( en me disant, mais si il la pris en compte... bizarre) et bah non. 

 

 

j'en ai fais une courte video pour vous montrez le probleme. elle est ici

 

 

voila, j'espere que mon cas peu etre résolu ( sinon, ca cesse d'etre un probleme: si pas de réponse)

 

 

ma config: http://image.noelshack.com/fichiers/2015/17/1430076177-screenshot-from-2015-04-26-16-22-12.png

Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 0

Bonsoir, question bête il n'y a pas de "F" dans ton mot de passe ?

 

Tu as fait une installation propre ( effacer le disque dur et installer Freya) ?

installation avec formatage du DD plusieur fois avec editeur sur clef usb, PUIS formatage à l'instalation de elementary OS. aucun souci a l'installation, Maj faite chaque semaine

 

 

 

je l'ai depuis une gros mois, et c'est la premiere fois que ça m'arrive. de plus, pour une raison obscure mon "f" cest remis a marcher. ( temps mieux vous allez me dire.)

Essaie avec un clavier qwerty c'est à la mode en ce moment avec eOS.

J'ai un clavier qwertz, et mon mot de passe ne contient ni "Y" ni "Z". 

 

J'aimerai souligner le faite que dans la video, on remarque bien la difference d'animation sur le premier mot de passe juste, le mot de passe erroner et le troisieme mot de passe juste.

 

 

Question hors sujet:

 

en suposant que je ne puisse plus acceder a ma session principal, savez vous comment je peux recuperer mes fichier ( crypter mais bien sur j'ai la longue clef) les decrypter sur une eventuelle autre machine, si besoin sous elementary os ( j'ai encore la clef usb avec un iso de deux moins de deux mois).

 

Ps: je vous avouerais que je suis dans la campagne perdu d'Argentine, sj'ouverai que telecharger le moins de logiciel possible serait bien, je download jamais à plus de 50/100 kb/s.

 

communautée d'EOs, je vous remerci d'avance pour vous penchez sur mon cas.

Link to post
Share on other sites
  • 0

Bonjour,

 

j'ai rencotré ce problème en installant Freya Stable (j'étais sous Luna avant). Il s'est avéré que c'était des problèmes de droits. Je n'ai pas trouvé de causes mais j'ai résolu moin problème avec chown.

 

A l'écran de connexion il faut aller en console avec CTRL+ALT+F1

Là tu te loggues avec ton utilisateur principal, tu vas dans le dossier home et tu t'appropries ton dossier personnel.

En résumé, si ton nom d'utilisateur est titouan (et que ton /home porte bien le nom titouan)

cd /home
sudo chown -R titouan titouan

Après un reboot je n'ai plus eu de problèmes avec ça.

 

En espérant que ça aide.

 

LCG

Link to post
Share on other sites
  • 0

Salut,

 

J'avais pas vu le vidéo j'etais a disney dans le car, c'etait pas simple  :D

 

Donc ton soucis que j'ai aussi vecu à été résolu grace à ce post : http://forum.elementaryos-fr.org/topic/299-resolu-boucle-sur-louverture-de-session/

 

pour la commande finale qui permet d'avoir les droits sur Xauthority ce sera, si ton login est bien rolland comme dans la video :

 sudo chown rolland:rolland .Xauthority

Depuis je n'est plus ce probléme.

Link to post
Share on other sites
  • 0

no such file or directory.

 

J'aimerai preciser que je reste un debutant sur linux.

 

ma premiere phrase est la reponsd a mes recherche de .Xauthority, il a pas l'air d'exister.

 

petite question, mon /home est chiffrer ( j'ai les clefs) ca dois avoir un rapport non ?

 

j'ai juste un petit probleme pour y acceder meme une fois déchiffré.

 

j'ai fais ecryptfs-recover-private, puis rentrer ma clef. j'ai eu un message de reussite mais la... je me sent bete, je trouve rien.

 

un ls decrypted ne passe pas, ( je maudit etre passer si vite sur les base linux... j'ai trop peu de temps ses temps ci pour le reprendre)

 

bref. en esperant trouver une solution.

je pensais dans le pire des cas, quelqu 'un pour m'apprendre a faire une sauvegarde du home a loguer sur un tty ?

 

:)

 

Sincere  salutation.

Link to post
Share on other sites
  • 0

Pour te logguer dans un tty, c'est comme j'ai dit dans mon message plus haut.

 

As-tu essayé mes commandes?

 

Une fois connecté en console, que donne un ls -a dans ton /home?

Link to post
Share on other sites
  • 0

Re,

 

Essaie comme ça : (un conseil, soit prend en photo l'ecran, ou imprime le, histoire d'avoir le tuto sous les yeux, c'est plus simple)

 

A l'ecran de connexion que tu ne peut pas passer tu fait CTRL+ATL+F1

 

Tu te retrouve en mode console

 

Puis entre ton login et ton password. Normalement ca doit passer, sinon je peut pas trop d'aider plus loin.

 

 

Toujours en supposant que ton login est "rolland" (attention c'est sensible à la casse donc respectes bien majuscule et minuscule)

cd /home/rolland

Puis 

rm .Xauthority* 

Il demande de valider par o

 

Et truc de fou tu lui dit oui...
 

Puis sort de la console avec ctrl+alt+F7

 

et enfin rentre ton mot de passe, et miracle ça doit fonctionner.

 

Une fois sur ta session graphique et histoire de ne pas avoir a refaire la manip a chaque boot, tu ouvre un terminal, et tu entre 

cd /home/rolland
sudo chown rolland:rolland .Xauthority

tu fait ton mdp et normalement c'est bon.

 

Voila, en esperant pouvoir t'aider.

J'ai suivi ce tuto et ca a marché a merveille. 

Link to post
Share on other sites
  • 0

Pour te logguer dans un tty, c'est comme j'ai dit dans mon message plus haut.

 

As-tu essayé mes commandes?

 

Une fois connecté en console, que donne un ls -a dans ton /home?

  

salut,

 

Vi j'ai vu LCG, mais je présuppose, a tort peut etre, que la commande ait été rentrée sans être dans le /home. Attention au Point devant le X aussi.

 

Enfin, bref je refait le tuto juste au cas ou.

 

Messieurs, j'ai bien suivi vos conseils. Je ci joins la photo des résultats.

 

1430251878-img-20150428-170316.png

Link to post
Share on other sites
  • 0

J'aimerai rajouter qu'un

 

Sudo Chown -R titouan titouan

 

N'a rien résolu. Je vient de le refaire, et suite à un reboot même problème.

 

( pourquoi replacer le dossier home au même endroit ?)

Link to post
Share on other sites
  • 0

Bonjour Titouan.

 

Chown ne sert à pas à déplacer un dossier ou un fichier mais à en changer le propriétaire.

Lorsque j'ai un problème de connexion comme le tient lors d'une réinstallation complète en utilisant un /home existant, je rencontre souvent un problème de droits. L'utilisation de chown sur tout le /home résout mon problème.

Los_Tintinos a supposé le même genre de problème mais sur un fichier bien précis (.Xauthority).

Tu as quelques explications ici.

 

Vu le screen que tu postes, je pense que l'encryptage de tes données empêche d'accéder à ce fichier et d'y faire un chown. Je n'utilise jamais l'encryptage, je ne sais pas comment faire pour accéder à tes fichiers à partir d'une console.

 

As-tu essayé de créer un nouvel utilisateur et de te connecter avec?

On saura alors si c'est un problème lié à un fichier de ton /home ou si c'est un problème plus général (du genre drivers graphiques).

 

Pour créer un nouvel utilisateur en console : adduser

En gros ça donne :

sudo adduser NomDuNouvelUtilisateur

A+

Link to post
Share on other sites
  • 0

salut,

 

Voui je suppose que le cryptage met le brin dans cette histoire.

 

Mes connaissances n'etant pas enorme je vais avoir du mal a t'aider d'avantage

 

Juste une idée, en mode console configurer une connexion automatique, tente un 

sudo scratch-text-editor /etc/lightdm/pantheon-greeter.conf 

et inserer un truc du genre :

[SeatDefaults]
autologin-user=youruser

Mais ceci fonctionne normalement pour lightgdm mais je ne sais pas si cela fonctionne pour pantheon-greeter

 

A voir avec les spécialiste du cru

Sinon mais sans conviction : http://voidandany.free.fr/index.php/decrypter-le-home-dun-utilisateur/

 

En gros essayer en console de décrypter le /home ou contourner l'ecran de connexion.

Link to post
Share on other sites
  • 0

Bonjour,

 

J'ai le même soucis. /home non crypté. Cela s'est passé quand j'ai fait des mises à jour et mis les langues fr, l'écran du PC s'est aussi éteind à un moment...

 

Aucune manip que vous avez donné ne fonctionne.

Et la session invité ne focntionne pas.

Link to post
Share on other sites
  • 0

salut,

 

le soucis vient certainement d'autre chose que d'un problème de login/mdp car dans mon cas, le mode invité a toujours fonctionné.

Tu n'a pas installé des pilotes graphiques dans le lot par hasard ?

 

Au pire tu fait une réinstalle complète en conservant le /home (qui pour ma part est sur un partition a part)

Link to post
Share on other sites
  • 0

De mon côté c'est une install nouvelle, mise à jour du système dans la foulée, configuration en français.

Et niveau graphique, c'est assez simple, c'est un portable avec i5 et Radeon dessus (Toshiba C875-152).

 

C'est assez rageant de juste configurer une nouvelle machine et de tomber sur ce genre d'erreurs / bugs...

Link to post
Share on other sites
  • 0

Après un log foireux vous avez essayé de trouver quelques chose dans les logs du système?

Avec dmesg en console.

 

Vous pouvez faire des recherches ciblées avec, par exemple : dmesg | grep -i nvidia (vous pouvez changer nvidia par le mot recherché)

 

C'est sans convictions hein, juste une idée. . . Je ne connais pas les éventuels problèmes des Radéons, j'ai toujorus été sous NVIDIA.

Link to post
Share on other sites
  • 0

J'ai rien installé concernant les pilotes graphiques, ma copine ne fera pas de jeux vidéos de toutes façons. Du coup ce sont les pilotes libres qui tournent, le pc est assez ancien pour que tous les chipset soient reconnus. (Voir : http://doc.ubuntu-fr.org/liste_portables_toshiba )

 

J'ai réinstallé le PC, sans faire les mises à jour, ni franciser (toujours ce bug de francisation à l'installation de Freya... :/ ). Je suppose que c'est soit la francisation du système qui mince ! quelque part, soit la mise à jour... Je verrai demain je vais franciser le système et voir ce qu'il en retourne.

 

Merci de vos réponses !

Link to post
Share on other sites
  • 0

Bonjour Titouan.

 

Chown ne sert à pas à déplacer un dossier ou un fichier mais à en changer le propriétaire.

Lorsque j'ai un problème de connexion comme le tient lors d'une réinstallation complète en utilisant un /home existant, je rencontre souvent un problème de droits. L'utilisation de chown sur tout le /home résout mon problème.

Los_Tintinos a supposé le même genre de problème mais sur un fichier bien précis (.Xauthority).

Tu as quelques explications ici.

 

Vu le screen que tu postes, je pense que l'encryptage de tes données empêche d'accéder à ce fichier et d'y faire un chown. Je n'utilise jamais l'encryptage, je ne sais pas comment faire pour accéder à tes fichiers à partir d'une console.

 

As-tu essayé de créer un nouvel utilisateur et de te connecter avec?

On saura alors si c'est un problème lié à un fichier de ton /home ou si c'est un problème plus général (du genre drivers graphiques).

 

Pour créer un nouvel utilisateur en console : adduser

En gros ça donne :

sudo adduser NomDuNouvelUtilisateur

A+

 

bonjour LCG, premierement merci de m'avoir éclairé sur le chown.

 

J'ai en effet recreer un utilisateur, je pense essayer d'y acceder, décrypter le home (titouan) et le passer sur le deuxieme utilisateur puis suprimer le premier utilisateur. de plus je me demandais a quoi sert le .Xauthority.

 

salut,

 

Voui je suppose que le cryptage met le brin dans cette histoire.

 

Mes connaissances n'etant pas enorme je vais avoir du mal a t'aider d'avantage

 

Juste une idée, en mode console configurer une connexion automatique, tente un 

sudo scratch-text-editor /etc/lightdm/pantheon-greeter.conf 

et inserer un truc du genre :

[SeatDefaults]
autologin-user=youruser

Mais ceci fonctionne normalement pour lightgdm mais je ne sais pas si cela fonctionne pour pantheon-greeter

 

A voir avec les spécialiste du cru

Sinon mais sans conviction : http://voidandany.free.fr/index.php/decrypter-le-home-dun-utilisateur/

 

En gros essayer en console de décrypter le /home ou contourner l'ecran de connexion.

j'ai essayer cette methode aussi, j'ai une impossibiliter a acceder a scratch ( j'ai essayer gedit aussi).

 

Ayant creer un autre utilisateur tenter d'y acceder a partir de se dernier.

 

ps: si vous avez des idée pour me faciliter la tache je suis preneur.

je vous tient au courant meme si j'ai peu de temps a y consacrer.

Link to post
Share on other sites
  • 0

salut,

 

pour gedit 

sudo apt-get install gedit

ca devrait passer. Mais ne pas avoir scratch parait trés zarb.

 

Si c'est en ligne de commande que tu bosse sans interface graphique alors c'est normal et  dans ce cas

sudo vi /etc/lightdm/pantheon-greeter.conf

Vim est un editeur de texte en mode console, austere mais diablement pratique et efficace.

 

 http://doc.ubuntu-fr.org/vim 

 

les commandes de base qui te permettront de sortir et d'utiliser vim 

i Passer dans le mode insertion

A Ajouter en fin de ligne

:q Quitter

:q! Quitter sans enregistrer

:w Enregistrer le fichier

:wq Enregistrer et quitter

:x Enregistrer (seulement en cas de modification) et quitter

Link to post
Share on other sites
  • 0

salut,

 

a l'ecran de connexion tu passe en mode console.

 

Ensuite 

 

sudo vi /etc/lightdm/lightdm.conf 

 

tu met que ca dedans 

 

[seatDefaults]
autologin-user=TONLOGIN
 
puis :x pour enregistrer et sortir de vim
 
Puis tu reboot le pc. Normalement le pc s'autoconnect au depart.
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...