Jump to content
ElementaryOS France
  • 0
Veganux

Démarrage du liveUSB impossible

Question

Bonjour,

 

Je voudrais installer Freya sur mon PC, pour ça j'ai fait un LiveUSB (qui fonctionne parfaitement sur mon PC portable). 

Seulement voilà, impossible d'arriver à quoi que ce soit. En UEFI j'ai juste un écran noir et rien ne se passe. Sans UEFI, ça boote bien avec un verbose qui s'arrête net après plusieurs lignes de quelque chose qui ressemble (grosso modo) à ça.

Intel pstate controlling core 1
Intel pstate controlling core 2
Intel pstate controlling core 3
Intel pstate controlling core 4

Ensuite, plus rien, ça reste comme ça indéfiniment.

 

J'ai tenté toutes les options de boot proposées par le menu de boot (F6) mais quoi que je choisisse, même avec toutes les options, le problème persiste.

 

 

Ma configuration :

 

CM : Z97-D3H

Proc : i7 4790k

CG : GTX 980

SSD (256Go dédié à Windows 7)

SSD (120Go que j'aimerais utiliser pour ElementaryOS)

8Go ram

 

 

Merci pour votre aide :)

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Bonjour !

 

  • Tu as fait ta live-usb avec quel appli ? Si c'était avec Unetbootin, normalement il devrait y avoir dans le menu (une sorte de Grub, au boot) une option "UEFI" et une normale (Non UEFI) pour chaque périphérique disponible. J'ai parfois des problèmes en mode UEFI. En principe, ça passe en mode standard. Je parle de Unetbootin Linux. J'ai toujours eu des problème avec la version Windows. Mais ça remonte à longtemps ! J'ai balancé Win par-dessus bord...clindoeil.gif

 

Création d'un live-USB depuis Windows
  • LinuxLive USB Creator (LiLi USB Creator) : logiciel libre (GPL) et gratuit pour Windows qui permet de créer une clé USB démarrable avec Ubuntu. Pour l'utiliser, il suffit de télécharger le fichier. A l'étape 3, choisissez "0 Mo" pour avoir un équivalent strict du liveCD (mode "Live", c'est à dire sans conservation des réglages). Attention! Il ne se mettais pas à jour seul (de mon temps..), donc, il faut le retélécharger si on veut faire live-usb d'une distro très récente.
  • Unetbootin (attention: crée un menu de boot non-standard ==⇒ Pourtant cela marche parfaitement en EFI ……
  • Rufus : logiciel libre (GPL) et gratuit pour Windows, très facile à utiliser et fiable, permet aussi de formater et vérifier la clé, supporte EFI, crée un log de ses actions…
 
Depuis UBUNTU
  • Usb-creator : c'est l'outil par défaut dans Ubuntu. Attention: il ne fonctionne que pour Ubuntu et dérivées. (par ex il ne fonctionne pas avec Debian stable).
  • MultiSystem : GPL-V3, pour créer un LiveUSB MultiBoot facilement. Compatible avec de nombreuses distributions (WinXP, 7).
  • Unetbootin : compatible avec de nombreuses distributions. Attention: crée un menu de boot non-standard. Mode persistance. Les problèmes sont rares dans la version Linux. Truc: ouvrir le gestionnaire de fichiers et monter le périphérique où se trouve l'iso ou la clé USB (je ne sais plus..).
 
D'après http://doc.ubuntu-fr.org/live_usb et moi-même
 
  • Pstate est en rapport avec le contrôle du ou des CPU (fréquence, température...). Apparemment, il se substitue à Cpufreq (pour Intel seulement).
Edited by nettlebay

Share this post


Link to post
Share on other sites
  • 0

Vu que tu n'as que windows d'opérationnel  RUFUS ou Lili seront tes seul amis, pour moi y'a que eux qui fonctionne

Share this post


Link to post
Share on other sites
  • 0

Non, tu peux créer ton live-usb via un autre live-cd si tu veux absolument utiliser Unetbootin Linux. Et puis, Lili ne fonctionne pas à tous les coups non plus. Rufus, je ne connais pas suffisamment pour en parler.

Sous Linux, on peut le faire en ligne de commande aussi...http://doc.ubuntu-fr.org/live_usb

Edited by nettlebay

Share this post


Link to post
Share on other sites
  • 0

J'ai créé la clé avec liliusb sous Windows 7. J'ai cette option de choisir en uefi ou non à la sélection du périphérique à booter, mais en uefi comme en legacy, le problème est le même.

Share this post


Link to post
Share on other sites
  • 0

Reste plus qu'à griller un CD*...

Est-ce que Lili te propose bien Freya Stable?

Essaye là: https://www.google.com/search?q=Elementary+OS+live-usb+not+working

Est-ce que ça fonctionne avec une autre distro (Ubuntu, Mint...)?

Ta CG est une Nvidia. Ça peut venir de là. Il y a peut-être quelque chose à glaner ici: http://www.reddit.com/r/elementaryos/comments/32dcw7/issue_booting_live_usb_of_freya_on_macbook_pro_51/

 

* Il m'est arrivé plusieurs fois que la live-usb ne voulait pas fonctionner alors qu'avec un live-Cd, " ça passait comme une lettre à la poste"...

Edited by nettlebay

Share this post


Link to post
Share on other sites
  • 0

il sera confronté au pb de choix de boot entre UEFI et legacy a cause de w8, il faut qu'il arrive a créer une clé uefi

Share this post


Link to post
Share on other sites
  • 0

J'ai Windows 7, pas 8.

Pour la version, c'est la Freya proposée sur le site, j'ai téléchargé directement l'ISO plutôt qu'un téléchargement par LiliUSB.

 

Ce que j'ai du mal à comprendre c'est que sur le PC portable (âgé de quelques années) je rencontre pas de problème avec ce live usb.

Share this post


Link to post
Share on other sites
  • 0

Il faut (peut-être) aller voir dans le bios. Dans le mien (j'ai un Brix Gigabyte), il y a une option Windows 7 ou Windows 8. Peut-être toi aussi ? Personnellement, je me suis interrogé sur ces options sans comprendre. Je commence à mieux comprendre maintenant... Mais je n'ai eu aucun problème que se soit sur une option ou une autre. Mais il est vrai que mon ordi n'a jamais été "souillé" ;) par Windows... (c'est un barebone vendu sans OS, sans RAM, sans HD). De plus, j'ai seulement une vague idée de ce qu'est l'UEFI. J'essaye d'aider...

Share this post


Link to post
Share on other sites
  • 0

L'UEFI c'est le remplaçant du bon vieux BIOS, c'est pareil sauf que t'as une couche logiciel sur une petite partition hdd (si j'ai bien compris) 

 

ça permet de verrouiller la machine pour un OS.

Ceci dit au vu de ce qui était prévu au début ils ont dûs ajouter la possibilité de désactiver l'option pour que les gens utilisent leur pc comme ils voulaient.

 

 

 

 

Si tu as windows 7 tu dois booter en mode legacy (si ta carte mère gère l'UEFI)

 

Donc normalement tu devrais pas avoir de problème, si ça bloque c'est que la clé usb à mal été créer, ça m'arrive très souvent.

Avec windows fais un formatage complet (lent) en FAT32, puis refais l'essai avec LILI, les options de RUFUS concernant l'UEFI ou le legacy sont un peu obscure ;)

Share this post


Link to post
Share on other sites
  • 0

La clé était bonne, ça j'en suis certain puisqu'elle marchait pour le portable sans problème

Mais après d'autres essais hier soir, ça ne s'arrange pas :

 

- en créant la clé avec Ruffus, le boot de la clé s'arrête sur deux erreurs de Nouveau (visiblement ma carte graphique est trop récente pour les pilotes libres)

- En créer un liveCD, même problème.

 

Donc, en créant un liveUSB avec LiliUSB, c'est peut-être un problème avec pstate auquel je suis confronté. Je dis peut-être, car aucune certitude.

En créant un liveUSB avec Ruffus ou un liveCD, c'est Nouveau qui ne prend pas en charge mon matériel.

 

De quoi se tirer les cheveux.

 

edit : dans les deux cas ce n'est pas un problème avec UEFI, puisque la clé commence à booter. C'est bien un problème de support matériel (processeur et/ou carte graphique) de Linux qui pose soucis.

Share this post


Link to post
Share on other sites
  • 0

même si ta GTX 960 n'est pas pleinement suporter sur le live  tu aurais qd même un affichage, après avec la mise à jour des drivers ça s'arrange.

 

si tu utilise l'utilitaire de gravure d'iso de windows ça marche toujours pas?

Share this post


Link to post
Share on other sites
  • 0

C'est comme ça que je l'ai fait. 

Je suis en train de graver Ubuntu pour voir si le problème est le même ou si c'est spécifique à Elementary. Je vous tiens au courant.

Share this post


Link to post
Share on other sites
  • 0

J'ai retéléchargé l'ISO de Elementary et regravé avec le créateur de disque de Windows, toujours le même problème :

 

[   0.628086] nouveau E[   DEVICE] [0000:01:00.0] unknown chipset, 0x124000a1

[   0.628121] nouveau E[        DRM] failed to create 0x80000080, -22

 

Et ça reste bloqué à ça.

Share this post


Link to post
Share on other sites
  • 0

là je saurais plus taider j'ai jamais eu ça, tu as retelechargé le fichier, verifier le md5 ?

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Essayes de créer ta live-usb à partir du live-cd d'Ubuntu. Tu télécharges Unetbootin à partir du CD. Les problèmes avec Unetbootin sous Linux sont rares. Tu peux aussi essayer avec Usb-creator qui doit être déjà pré-installé, je suppose.

 

AJOUTÉ: Pour formater une clé sous Windows, il y a des logiciel adaptés pour ça (mais je ne me rappelle plus le nom). Vaut mieux pas formater avec l'Explorateur (clic droit), c'est pas conseillé...

Edited by nettlebay

Share this post


Link to post
Share on other sites
  • 0

Le problème étant le même avec un live cd je doute que ça change quelque chose. Mais je vais essayer en rentrant, au cas où.

Share this post


Link to post
Share on other sites
  • 0

Tu peux tester, installer en dur Ubuntu et faire l'essai unetbootIN voir, mais j'y crois pas trop.

 

Essai une autre clé, j'en ai deux chez moi et une marche très bien pour Ubuntu/suse... l'autre que pour eOS, je sais pas pourquoi

Share this post


Link to post
Share on other sites
  • 0

Pareil pour moi, j'ai une clé USB qui fonctionne 1 fois sur deux. De fait, j'utilise toujours la même (1 Gb) qui pourtant date pas mal...

Par contre, je n'ai jamais de problèmes avec les cartes SDHC.

Pour Veganus, je conseille fortement > Unetbootin sans persistance pour commencer.

Share this post


Link to post
Share on other sites
  • 0

ATTENTION ! Sous Linux, Unetbootin ne formate pas la clé! Bon à savoir!

 

Il est préférable de formater préalablement la clé avec Gparted.

 

N'oubliez pas non plus de supprimer le dossier .Trash s'il est présent (corbeille des périphériques amovibles)*

 

Pour le voir, cochez "Afficher les fichiers cachés". Si vous avez formaté avec Gparted, ".Trash" aura disparu.

 

 

 

 

 

*Merci pioupiou41 du rappel !

Edited by nettlebay

Share this post


Link to post
Share on other sites
  • 0

oui il faut le faire avant, surtout que suprimer les fichiers ne fait que les placer dans le dossier .trash dans la clé

Share this post


Link to post
Share on other sites
  • 0

Y'a bien que Ubuntu et ses variantes qui ne posent aucun soucis. Elementary ne veut pas, quoi que je fasse : cd, clé usb (démarrage en uefi et en bios normal), clé usb faite sous Kubuntu, faite sous Windows, avec liliusb, unetbootin, ruffus... Non, y'a vraiment rien qui peut régler le problème, Elementary ne passe pas. Et c'est pareil avec Mint d'ailleurs,ça veut pas.

Du coup je vais garder Kubuntu (qui est pas dégueulasse avec la dernière version de KDE alors que je détestais KDE avant) et attendre la prochaine Elementary, mais c'est pas pour demain.

 

Merci pour votre aide quand même !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...