Aller au contenu
ElementaryOS France
  • 0
Scratch

Clavier qwerty jusqu'au chargement du bureau

Question

Bonjour à tous et à toutes =)

 

J'ai un petit soucis vraiment bénin, lorsque je démarre mon ordi et que j'arrive sur l'écran de connexion, le clavier passe en qwerty.

Manque de pot, mon nouveau mot de passe, plus complexe que le précèdent, contient un "a" eheh :rolleyes:

Une fois le système chargé all right !

Mon système est à jour et le problème doit être la depuis ... une semaine maxi.

 

Merchi =)

  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites

23 réponses à cette question

Recommended Posts

  • 0

Bonjour,

 

Le "a" est à la place de "q" (si ça peut aider...)

J'ai eu aussi ce problème que j'ai tout simplement résolu en me mettant en auto-login (je ne sais plus comment on fait). Mais une petite recherche chez Google devrait te donner la réponse. C'est un problème récurrent sous Linux et en particulier sous Ubuntu. Ce n'est pas spécifique à eos-ombr%25C3%25A9-deca32l.jpg

RAPPEL! eos-ombr%25C3%25A9-deca32l.jpg est un dérivé d'Ubuntu. Quand tu ne trouves pas une solution à ton problème, cherche dans Google: ubuntu+problème et non pas Elementary+problème... Les recherches en Anglais donnent aussi plus de résultats.

Chez moi, ce n'est pas vraiment embêtant car j'utilise un clavier QWERTY portugais* et que ça ne pose pas problème pour mon mot de passe même quand il repasse en QWERTY US. Et sous Lubuntu, que j'utilise le plus souvent, j'ai résolu le problème je ne sais plus comment...)

 

Sinon, recherche https://www.google.fr/search?q=ubuntu+ecran+login+clavier+qwerty

 

(Pour ouvrir un terminal à l'écran de login (et toujours d'ailleurs): Ctrl+alt-t (T minuscule)) NE FONCTIONNE PAS À L'ÉCRAN DE LOGIN ?

 

Tu peux aussi utiliser "mon" moteur de recherche pour eos-ombr%25C3%25A9-deca32l.jpg. Il est plus performant que celui du forum et il cherche en même temps sur le forum en Anglais. Mets-le en favoris !

J'y ai trouvé ça: http://forum.elementaryos-fr.org/topic/1288-ecran-de-verrouillage-eos-freya/

 

Pour passer en auto-login: https://doc.ubuntu-fr.org/lightdm

 

Passer en auto-login (je ne sais pas si ça fonctionne puisque je suis déjà en auto-login):

 

Dans /etc/lightdm/lightdm.conf.d/ créer un fichier 50-myconfig.conf (en root) et y ajouter ceci:

[SeatDefaults]
autologin-user=nom-utilisateur

*Acheté dans un discount par erreur mais je l'ai gardé quand même car il est vraiment génial pour les accents et les Ç.

Modifié par nettlebay

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

une réponse plus ciblée elementary que nettlebay ;-) ,

dans le centre de contrôle d'eOS, il y a la section langue, il y a en bas la section "appliquer à tout les utilisateurs" ou un truc comme ça....

Il faut appliquer le français à tout le système et le problème est normalement résolu.

Dites-moi si cela fonctionne.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Apparemment, le gars est déjà reparti ailleurs ou a résolu le problème tout seul... 

Je vais tout de même aller faire un tour sur Freya voir ça... (je l'utilise de moins en moins triste.gif)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

On peut aussi essayer dans Applications » Paramètres systeme » Clavier » Disposition et jouer avec le switch "autoriser des agencements différents pour chaque fenêtre". (À essayer)

Mais le meilleur moyen, c'est de rechercher sur Google... 

Certains utilisateurs commencent par demander avant de chercher eux-mêmes. C'est de l'assistanat clindoeil.gif

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@TSG: "Appliquer pour l'écran de connexion, le compte invité et les nouveaux utilisateurs" . C'est dans Applications » Paramètres systeme » Langue & Région

ScreenshotLanguage.png

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Actuellement le soucis se règle très facilement en installant le language EN, puis le FR appliquer a tout le system et il faut garder l'EN.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@nettlebay : oui, je sais (ou pas) mais je suis plu sous eOS et donc ne peut simplement pas voir ou c'est que c'est.

Je pense reprendre un multiboot Win 7 / ubuntu 15.04 !

@+

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Vivid Vervet? C'est pas une LTS, donc support 9 mois maxi... C'est court! Mais bon, comme tu changes souvent...clindoeil.gif

Ça va autrement?

On ne voit plus beaucoup Cédric non plus... Il doit bosser le pôvre!

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Tiens mon gestionnaire de langue & région est vide...

 

Et mon logscreen est en anglais...

 

Comment qu'on fait du coup la hein ? :P

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bon ...

Non seulement ça n'a rien changé (enfin, l'autologin est plus un compromis, je préfère garder un mot de passe par sécurité), mais en plus ça me permet de remarquer que rien n'est traduit, constatez :

Screenshot_from_2015_07_09_20_44_35.png

 
Screenshot_from_2015_07_09_20_44_57.png
Merci ^^'

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je me demande si c'est pas à cause d'une MAJ parce que moi, c'est Synaptic qui est complètement (ou presque) repassé en Anglais... Pas grave, mais bizarre quand même...

 

UFrBI9O.png

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Re.

Tout est redevenus en FR

A la (toute première) connexion le clavier est toujours en QWERTY (a et q inversés par ex...)

L'heure, qui avait disparue du panel, s'affiche de nouveau mais en format AM/PM, bien que j'ai coché 24h dans les paramètres.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Apparemment, le gars est déjà reparti ailleurs ou a résolu le problème tout seul... 

Je vais tout de même aller faire un tour sur Freya voir ça... (je l'utilise de moins en moins triste.gif)

SI tu parles bien de moi, et bien non ce n'est pas résolus malheuresement.

J'ai passé en auto-login pour contourner le soucis, mais lorsque je me déco-reco il me demande malgrès tout mon mot de passe.

 

Quelqu'un à des nouvelles concernant sa résolution ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Salut,

 

Effectivement, j'ai également été confronté à des problèmes de languages non mis à jour et de clavier revenant au clavier anglais.

A noter que je n'avais pas ce problème sur une installation que j'avais faite en mai/juin !

 

La solution pour l'écran de connexion (lightdm) avec le clavier querty est la suivante :

Il faut créer le fichier /etc/default/keyboard avec une ligne comme :

XKBLAYOUT="fr,us"

qui active un clavier azerty (et qwerty).

 

A+,

L@u

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ne fonctionne toujours pas chez moi (Lubuntu). Dans l'écran de Lightdm, je n'ai que Français et Français Canadien. Ça ne me gêne pas plus que cela (j'ai en fait un QWERTY Portugais) mais j'aimerais comprendre... 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Mais c'est un problème récurrent avec Ubuntu pas spécialement avec Lubuntu ou Xubuntu (qui sont assez proches). De plus, je ne trouve pas le forum Lubuntu-fr si sympa que ça... Et puis, tout ça, c'est Ubuntu (à part Unity).
 
Mon /etc/default/keyboard

XKBMODEL="pc105"
XKBLAYOUT="pt,us,fr"
XKBVARIANT=""
XKBOPTIONS=""

C'est moi qui avais rajouté "pt,us" il y a déjà bien longtemps mais ça n'avait rien changé. Je pense que ce fichier est obsolète et ne sert plus à rien dans Trusty (c'est une idée comme ça). Bon, je me répète, ce problème est récurrent sous Ubuntu et même sur d'autres distros. J'ai l'impression que ce problème survient lors de l'installation. Mais je ne peux pas en jurer puisque j'utilise rarement LightDM (je suis en auto-login sauf sur un de mes ordis et là, pas de problèmes heureusement. C'est Lubu aussi). Encore une fois, ce n'est pas un gros problème pour moi, mais j'aimerais comprendre...

Modifié par nettlebay

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

 

 

Qu'est ce qu'il y a dans ton fichier /etc/default/keyboard ?
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="latin9"
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Mais c'est un problème récurrent avec Ubuntu pas spécialement avec Lubuntu ou Xubuntu (qui sont assez proches). De plus, je ne trouve pas le forum Lubuntu-fr si sympa que ça... Et puis, tout ça, c'est Ubuntu (à part Unity).

 

Mon /etc/default/keyboard

XKBMODEL="pc105"
XKBLAYOUT="pt,us,fr"
XKBVARIANT=""
XKBOPTIONS=""

C'est moi qui avais rajouté "pt,us" il y a déjà bien longtemps mais ça n'avait rien changé. Je pense que ce fichier est obsolète et ne sert plus à rien dans Trusty (c'est une idée comme ça). Bon, je me répète, ce problème est récurrent sous Ubuntu et même sur d'autres distros. J'ai l'impression que ce problème survient lors de l'installation. Mais je ne peux pas en jurer puisque j'utilise rarement LightDM (je suis en auto-login sauf sur un de mes ordis et là, pas de problèmes heureusement. C'est Lubu aussi). Encore une fois, ce n'est pas un gros problème pour moi, mais j'aimerais comprendre...

J'aimerai bien comprendre aussi (et le résoudre !)

Toujours pas de solutions donc.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Scratch : bizarre !

Essaye quand même de rajouter us dans la ligne XKBLAYOUT (comme je l'indique plus haut)

 

@nettlebay : ben normal, tu utilises d'abord le clavier portugais, puis le clavier US et en dernier le Français : passe le fr en premier (comme indiqué plus haut) et ça ira mieux ! !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@nettlebay : ben normal, tu utilises d'abord le clavier portugais, puis le clavier US et en dernier le Français : passe le fr en premier (comme indiqué plus haut) et ça ira mieux ! !

 

Je pense que tu as mal lu, mal compris ou encore... que je me suis mal expliqué...

Mon clavier est portugais! Et justement, je ne veux pas de clavier FR...!

Mais bon, c'est pas grave, vu que j'ai remplacé eOs hier soir par linuxliteos Beta que je trouve génial (et aucun bug pour le moment).

 

Et mon autre clavier est... US, en plus!

Modifié par nettlebay

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'ai fait deux réinstallation (deux laptops) le week end dernier et en UEFI je n'ai pas eu le problème. Tout est Fr (clavier + logsreen + OS).

 

Est-ce que ce serait une c****** à l'installation?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

pour tout ce qui est problème de clavier, dans un terminal :

 

Taper ibus-setup

Modifier le clavier pour le mettre en français

 

au prochain reboot le clavier est en français dès la saisie du mot de passe.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×