Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
Nymeria

xorg utilise 100% du CPU

Question

Bonjour à tous,

 

Je suis actuellement sous elementary OS freay 0.3 (installé depuis lundi)

 

je dipose qu'une carte graphique intel xeon

lspci -nnk | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)

mon système est à jour, je suis sur le kernel 3.19


uname -r

3.19.0-33-generic

et lorsque je lance eclipse, xorg prend tout mon CPU, comme vous pouvez le voir sur le screen suivant :

 

GUq9.png

 

et ce, quelque soit ma version de java (openjdk, oracle jdk)

 

 

PS :

 

j'ai regardé, j'ai vraiment très peut de log dans xorg, voici le peut de log dont je dispose :

[   512.332] (II) AIGLX: Suspending AIGLX clients for VT switch
[   516.888] (II) AIGLX: Resuming AIGLX clients after VT switch
[   516.889] (II) intel(0): switch to mode 1920x1080@60.0 on DP2 using pipe 0, position (0, 0), rotation normal, reflection none
[   516.944] (II) intel(0): switch to mode 1920x1080@60.0 on VGA1 using pipe 1, position (1920, 0), rotation normal, reflection none
[   517.355] (II) XKB: reuse xkmfile /var/lib/xkb/server-79DA8A0BAEB4CF1B2497C5C301111BA2CA0B8D85.xkm
[   517.371] (II) XKB: reuse xkmfile /var/lib/xkb/server-79DA8A0BAEB4CF1B2497C5C301111BA2CA0B8D85.xkm
[   517.382] (II) XKB: reuse xkmfile /var/lib/xkb/server-CB68CBA0A2BB0721F394F6BCC014574648F8C537.xkm
[   517.383] (II) XKB: reuse xkmfile /var/lib/xkb/server-79DA8A0BAEB4CF1B2497C5C301111BA2CA0B8D85.xkm
[   517.401] (II) XKB: reuse xkmfile /var/lib/xkb/server-CB68CBA0A2BB0721F394F6BCC014574648F8C537.xkm
[   517.412] (II) XKB: reuse xkmfile /var/lib/xkb/server-79DA8A0BAEB4CF1B2497C5C301111BA2CA0B8D85.xkm
[   517.425] (II) XKB: reuse xkmfile /var/lib/xkb/server-CB68CBA0A2BB0721F394F6BCC014574648F8C537.xkm
[   517.425] (II) XKB: reuse xkmfile /var/lib/xkb/server-79DA8A0BAEB4CF1B2497C5C301111BA2CA0B8D85.xkm
[   517.442] (II) XKB: reuse xkmfile /var/lib/xkb/server-CB68CBA0A2BB0721F394F6BCC014574648F8C537.xkm
[   517.455] (II) XKB: reuse xkmfile /var/lib/xkb/server-CB68CBA0A2BB0721F394F6BCC014574648F8C537.xkm
[   524.755] (II) XKB: reuse xkmfile /var/lib/xkb/server-CB68CBA0A2BB0721F394F6BCC014574648F8C537.xkm

 

 

Je ne sais pas quoi faire, je suis perdu

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Comment ce fait-il que tu sois sur un kernel 3.19 ???

Pour moi, uname -r retourne: 3.16.0-53-generic.

Et je suis sur Freya 0.3.1 toujours maintenu à jour.

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

 

Est-ce que cela pourrais venir du fait que j'utilise docker ?

 

Voici ma version exacte d'elementary :

 


➜  lsb_release -a

No LSB modules are available.
Distributor ID:    elementary OS
Description:    elementary OS Freya
Release:    0.3.1
Codename:    freya

Le truc, j'ai remarqué que cela était uniquement avec eclipse 4.5. Pour toutes les version antérieure, cela fonctionne correctement. C'est marrent parce que eclipse 4.5 fonctionne parfaitement avec ubuntu 14.04, manjaro kde aussi.

Share this post


Link to post
Share on other sites
  • 0

Je pense que c'est un bug du kernel plutot, car d'après ton screen c'est 181,3% du CPU qui est utilisé, donc je dirais que le kernel calcul mal ton cpu.

 

Tu as de fort rallentisement ?

Share this post


Link to post
Share on other sites
  • 0

Salut pioupiou,

 

Effectivement j'ai de fort ralentissement puisque le pc freeze, tellement le CPU est utilisé, je suis obliger de passer en en ttyx et de killer le process à la main.

 

Du coup je me suis rendu compte que ça fonctionnais parfaitement avec tout les eclipses sauf la dernière version (la 4.5).

C'est vraiment très étrange comme bug, car, comme signaler ça fonctionne sur manjaro linux, ubuntu 14.04,15.04,15.10 mais pas avec elementaryOS qui est basé sur 14.04.

 

Est-ce que la team elementary à un launchpad ou quelque chose pour signaler les bugs ? car c'est un bug "grave"

Share this post


Link to post
Share on other sites
  • 0

Bonsoir,

 

Il y a bien un launchpad, par contre je ne pense pas que cela soit lié à elementary OS.

 

Eclipse dispose aussi d'un certain nombre de pages relatant ce soucis.

 

Cordialement Nikos

Share this post


Link to post
Share on other sites
  • 0

Il semblerait y avoir un lien entre Intel, Java et le bug que tu rencontres

Share this post


Link to post
Share on other sites
  • 0

Bonsoir,

 

Il y a bien un launchpad, par contre je ne pense pas que cela soit lié à elementary OS.

 

Eclipse dispose aussi d'un certain nombre de pages relatant ce soucis.

 

Cordialement Nikos

 

Pardonne mon manque de connaissance, mais si eclipse fonctionne sur ubuntu, manjaro (et autres) mais pas sur elementaryOS, le bug ne viendrais pas plutôt d'élémentary ? Genre ils utilisent pas la bonne version d'un paquet ou quelque chose dans le genre

Share this post


Link to post
Share on other sites
  • 0

L'IDE Eclipse Platform est principalement écrit en Java.

Ton problème ressemble à un disfonctionnement de la bibliothèque graphique de Java (SWT) sur ton matériel.

Commence par voir qu'elle version de Java tu as sur Ubuntu (qui arrive à faire tourner Eclipse sur la même machine)

java -version

Puis compare la avec celle que tu as sur Elementary OS. Si elles diffèrent, je pense que tu peux commencer par essayer de mettre la même version de Java de ton Ubuntu sur ton Elementary OS.

Share this post


Link to post
Share on other sites
  • 0

Bonsoir,

 

Comment as-tu installé éclipse ?

 

Pourrais-tu me donner le résultat de la commande suivante :

apt-cache policy eclipse

Cordialement,

 

Nikos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...