Jump to content
ElementaryOS France
  • 0

Nouvel interface langue


Astianax
 Share

Question

Bonjour a tous,

 

je reviens sur freya après avoir arrête quelques temps et je suis en galère avec les langues...

 

dans l ordres ou je tente de changer de langue

 

mini_419215Capturedu20151224125630.png

 

je déverrouille

 

mini_171830Capturedu20151224125640.png

 

toujours rien après déverrouillage

 

mini_168695Capturedu20151224125655.png

 

j installe la langue mais si je ferme et re ouvre je repars de 0 avec tout de vide

 

je m excuse pour l écriture bâclée mais je suis en qwerty donc c est un peu la mouise

Link to comment
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Alors essaye...

LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:fr
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8

... + un reboot et tu ne devrais plus avoir de problème de date (entre autre).

Link to comment
Share on other sites

  • 0

Et si tu fais un

timedatectl

... ça te retourne quoi dans le champ "Timezone".

Si c'est autre chose que "Europe/Paris (CET, +0100)" (vu les images que tu as posté ce doit être autre chose) alors tu peux tenter un...

timedatectl set-timezone Europe/Paris
Link to comment
Share on other sites

  • 0


LANG=fr_FR.UTF-8

LANGUAGE=fr_FR

LC_CTYPE="fr_FR.UTF-8"

LC_NUMERIC=ca_FR.UTF-8

LC_TIME=ca_FR.UTF-8

LC_COLLATE="fr_FR.UTF-8"

LC_MONETARY=ca_FR.UTF-8

LC_MESSAGES="fr_FR.UTF-8"

LC_PAPER=ca_FR.UTF-8

LC_NAME=ca_FR.UTF-8

LC_ADDRESS=ca_FR.UTF-8

LC_TELEPHONE=ca_FR.UTF-8

LC_MEASUREMENT=ca_FR.UTF-8

LC_IDENTIFICATION=ca_FR.UTF-8

LC_ALL=

Link to comment
Share on other sites

  • 0

Moi de mon côté :

LANG=fr_FR.UTF-8
LANGUAGE=fr_FR
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=fr_FR.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8
LC_ALL=

que donne le résultat de cette commande

locale -a
Link to comment
Share on other sites

  • 0

Bon, on commence à y voir un peu plus clair.

Vu ce que t'a affiché la commande "locale" je dirais que tu est au Canada, voir au Québec plus exactement (LC_TIME=ca_FR.UTF-8) pour ce qui est de la date et de l'heure. D'ailleurs, tu as un douteux mélange entre du fr_FR.UTF-8 et ca_FR.UTF-8.

Je pense que la solution qui se trouve sur ce forum est la bonne pour toi (j'ai la flemme de la recopier ici).

Link to comment
Share on other sites

  • 0

Alors j'ai fait :

sudo update-locale LANG="fr_FR.UTF-8" LANGUAGE="fr_FR"
sudo dpkg-reconfigure locales

Ensuite j'ai fait cette partie :

Perhaps adding LANG and LANGUAGE in /etc/environment could force a change. Try logout/login or rebooting.

Par contre j'ai chécké ces fichiers :

locale will show your current locale for the current user. Perhaps it's worth checking out these files just to be sure no local language variables are set: ~/.profile ~/.bashrc ~/.bash_profile

Mais aucune allusion à une quelconque langue dans aucun des fichiers...

 

Et j'ai toujours pareil. Je tente le reboot.

 

edit: toujours en canadien après reboot.

 

Si je regarde /etc/default/locale j'ai :

LANG=fr_FR.UTF-8
LANGUAGE=fr_FR
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8

Mais toujours la date en canadien...

Link to comment
Share on other sites

  • 0

Dans ton fichier /etc/environment, c'est bien...

LANG="fr_FR.UTF-8"
LANGUAGE="fr_FR"

... que tu as essayé de mettre à la fin?

 

Sinon tu peux aussi essayer la solution qui se trouve avant l'UPDATE soit:

sudo locale-gen fr_FR
sudo locale-gen fr_FR.UTF-8
sudo dpkg-reconfigure locales
sudo update-locale LANG=fr_FR.UTF-8
Link to comment
Share on other sites

  • 0

Bonjour à tous, j'ai exactement le même problème. J'ai installé eOS sur un nouveau PC, avec la dernière iso disponible et tout mon système est bien en français sauf l'heure dans le panel qui est en ... allemand je dirais ! Et l'heure est aussi en allemand dans le "light-dm"... !

Dans la fenêtre de gestion des langues je suis bien en fraçais il me dis que je dois me reloguer pour que tout soit pris en compte mais rien n'y fait !

Je vais essayer les astuces fournies dans le fil...

@+

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...