Jump to content
ElementaryOS France
  • 0
judas56

Problème de résolution

Question

Bonjour,

 

Je viens de brancher ma tour sous EOS sur ma télé. Mais j'ai un problème de résolution... En gros, tout est immense comme si ma résolution était de 400 par 300. J'ai tenté de modifier la résolution mais dans le menu Affichage, lorsque le clique sur la roue rien ne se passe. Étonnamment l'écran de connexion au démarrage n'a pas ce problème... Des idées ? Merci d'avance

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Merci pour vos réponses. Je ne peux pas changer la résolution depuis ma télévision (je peux juste dire que sous Ubuntu, il n'y avait pas de problème, en 14.04 ou 15.10)... Et je suis branché en HDMI. A priori ma carte graphique est une intel (pas de pilote propriétaire type NVIDIA)...

Share this post


Link to post
Share on other sites
  • 0

Si tu es branché en HDMI, que tu allume la TV avant le PC, normalement ce dernier doit trouver la TV correctement.

Dans ce cas là ton pc sortira normalement du 1920x1080.

Après il est possible que tu ai un model de TV qui gère uniquement le signal HD des pc via l'entrée PC ( D-Sub 15) Prise bleue.

 

Mais il n'y a pas de raison que ça fonctionne avant et plus maintenant ;-)

Share this post


Link to post
Share on other sites
  • 0

Salut :)

 

As tu essayé de changer la résolution en passant par le terminal ?

 

Que te donne le retour de

xrandr

Pour changer la résolution, tu peux essayer

xrandr -s 1920x1080

(ou la résolution la plus élevée que te donne le retour xrandr)

Share this post


Link to post
Share on other sites
  • 0

Merci pour vos retours. PiouPiou41, je ne sais que répondre, c'est une prise hdmi standard (la même que ma freeboxplayer). Man, je me suis "amusé avec xrandr et la résolution 1920 par 1080 fonctionne a peu près, l'image est légèrement trop grande pour la télé (mais les autres résolutions n'y font rien) et l'image n'est pas nette. Ce qui me surprend vraiment c'est que l'écran de connexion lui est bien détecté, c'est juste une fois connecté à ma session...

Share this post


Link to post
Share on other sites
  • 0

Tu as essayé toutes les résolutions que la commande "xrandr" te renvoie ?

 

"arandr" te permet de faire ces modifications sans passer par le terminal (sudo apt-get install arandr)

 

Connais tu la résolution max. de ta TV ?

 

Si la résolution de ta TV n'es pas proposée par xrandr, tu peux la "créer" avec ce tuto.

 

 

Pour ajouter une résolution par exemple de 1366x768_60 sur une sortie VGA :

  • Demandez d'abord les informations sur la résolution avec la commande :
     cvt 1366 768 60
  • Puis copiez les informations données en retour :
    "1366x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
  • Essayez la résolution dans la console :
    xrandr --newmode "1366x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
    xrandr --addmode VGA1 1366x768_60.00
  • Pour la persistance créez le fichier 45x11-xrandr avec les droits d'administration dans /etc/X11/Xsession.d/, en y mettant les 2 lignes ci-dessus.

 

 

Share this post


Link to post
Share on other sites
  • 0

Hey Man...  ;), t'as lu les précédents messages?

 

"Ça marchait bien avant sous Ubuntu" !

 

Pour ce qui est de "créer" une résolution avec xrandr, c'est plutôt galère. J'ai eu justement ce genre de problème avec une TV/Moniteur* et j'ai eu chaud!

J'ai bien cru que je n'aurai plus jamais d'affichage... Une catastrophe!

 

De toutes manières, même si on y arrive, la qualité d'image reste généralement médiocre.

 

Pas grave, c'était pour "ma tendre et douce" qui s'en fiche de ne pas avoir du 1920x1080... Donc, c'est resté en 1400 quelque chose... :rolleyes:

 

*Maintenant, toutes les TV font aussi Moniteur, mais je préfère nettement les Moniteurs qui font TV...

Share this post


Link to post
Share on other sites
  • 0

.... l'image est légèrement trop grande pour la télé (mais les autres résolutions n'y font rien) et l'image n'est pas nette.....

 

Dans ce cas de figure, est-ce que c'est net ? hors mis l'étalonnage de l'écran qui n'est pas bon ?

 

Car si oui, alors c'est que c'est le bon règlage, il te faut après aller dans les paramètre de la TV pour étalonner le signal correctement au bord de l'écran

Share this post


Link to post
Share on other sites
  • 0

Merci pour vos retours. Finalement, j'ai remis Ubuntu sur ma tour (mais rassurez-vous, j'utilise toujours eos sur mon portable que j'utilise au quotidien).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...