Jump to content
ElementaryOS France
  • 0

Problème de date ? Début de solution


Question

Bonsoir à tous,

 

Lors de mes tests de Plank 0.11 sur elementary OS Freya, j'ai volontairement forcé l'installation et cela n'a pas fonctionné, enfin le sujet n'est pas là.

 

Lors de ma réinstallation je me suis retrouvé avec une interface à moitié francisée et en canadien, j'ai réussi à analyser cette problématique et souhaite partager avec vous mes trouvailles :

 

Lors de ma réinstallation, voici la configuration de mes locales :

nikos@nikos-virtual-freya:~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=ca_FR.UTF-8
LC_TIME=ca_FR.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=ca_FR.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=ca_FR.UTF-8
LC_NAME=ca_FR.UTF-8
LC_ADDRESS=ca_FR.UTF-8
LC_TELEPHONE=ca_FR.UTF-8
LC_MEASUREMENT=ca_FR.UTF-8
LC_IDENTIFICATION=ca_FR.UTF-8
LC_ALL=

Donc, lorsque je demande à l'OS de m'afficher la date, celle-ci se trouve dans un format autre que le français :

nikos@nikos-virtual-freya:~$ date
dv mar 18 19:39:20 CET 2016

Pour la gestion du temps traduit, c'est la variable locale LC_TIME qui régit comment doit-être affiché le résultat, si je force volontairement LC_TIME avec la valeur fr_FR.UTF-8 via la commande suivante :

nikos@nikos-virtual-freya:~$ LC_TIME="fr_FR.UTF-8"
nikos@nikos-virtual-freya:~$ date
vendredi 18 mars 2016, 19:41:00 (UTC+0100)

Là, la date est bien en français. Toutefois, pour comprendre d'où peut venir réellement le problème (oui, car à chaque déconnexion, la date ne sera plus en français), en creusant la documentation ubuntu je tombe sur un fichier présent à la racine de mon profile et qui se nomme .pam_environment, dont voici le contenu :

LANGUAGE=fr_FR
LANG=fr_FR.UTF-8
LC_NUMERIC=ca_FR.UTF-8
LC_TIME=ca_FR.UTF-8
LC_MONETARY=ca_FR.UTF-8
LC_PAPER=ca_FR.UTF-8
LC_NAME=ca_FR.UTF-8
LC_ADDRESS=ca_FR.UTF-8
LC_TELEPHONE=ca_FR.UTF-8
LC_MEASUREMENT=ca_FR.UTF-8
LC_IDENTIFICATION=ca_FR.UTF-8
PAPERSIZE=a4

Je sens que je suis sur la bonne piste, LC_TIME a la valeur erronée. Je me sens joueur et je vais tenter cela : remplacer toutes les occurrences de ca_FR.UTF-8 en fr_FR.UTF-8 de ce fichier.

Parce que je suis un peu fainéant (mais dans le bon sens), je vais lancer cette commande :

sed -i 's/ca_FR.UTF-8/fr_FR.UTF-8/' ~/.pam_environment

Maintenant, mon fichier .pam_environment a comme contenu :

LANGUAGE=fr_FR
LANG=fr_FR.UTF-8
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8
PAPERSIZE=a4

Allez, un reboot et on voit ce que cela donne avant :

 

20160318-locale_bad.png

 

et ensuite :

 

20160318-locale_good.png

 

Je le précise, ce test a été réalisé suite à une fresh install ainsi que les différentes mises à jour réalisées !

 

Cordialement,

 

Nikos

 

 

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...