Aller au contenu
ElementaryOS France
  • 0
ubuntu

Clavier azerty au moment du login?

Question

Bonjour,

 

Apres un réinstalle complète de EOS, mon clavier ne passe en français qu'une fois loggé. Ceci m'oblige a taper mon mot de passe de connexion (lightdm) sur un clavier qwerty (d'où un peu de gymnastique cérébrale)...

comment puis-je être en azerty dès que le pc démarre?

 

Merci d'avance pour votre aide...

Partager ce message


Lien à poster
Partager sur d’autres sites

21 réponses à cette question

Recommended Posts

  • 0

Merci pour ta réponse, la commande me renvoit ceci:

 

cat /etc/default/keyboard

# Check /usr/share/doc/keyboard-configuration/README.Debian for

# documentation on what to do after having modified this file.

 

# The following variables describe your keyboard and can have the same

# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options

# in /etc/X11/xorg.conf.

 

XKBMODEL="pc105"

XKBLAYOUT="fr"

XKBVARIANT="oss"

XKBOPTIONS=""

 

# If you don't want to use the XKB layout on the console, you can

# specify an alternative keymap. Make sure it will be accessible

# before /usr is mounted.

# KMAP=/etc/console-setup/defkeymap.kmap.gz

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

bon ce sont les bonnes références pourtant, tu peux forcer une reconfiguration du clavier avec

 

sudo dpkg-reconfigure keyboard-configuration

 

Et regarde au reboot si tu as toujours le problème.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Salut,

 

Sinon si ce n'est pas encore fait.

 

Application - Paramètres Système - Prise en charge des langues - appliquer à tous le système (ce qui normalement devrait te mettre le login à la sauce FR)

 

Si déjà fait, après je vois pas...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Salut,

 

Sinon si ce n'est pas encore fait.

 

Application - Paramètres Système - Prise en charge des langues - appliquer à tous le système (ce qui normalement devrait te mettre le login à la sauce FR)

 

Si déjà fait, après je vois pas...

 

Merci.

 

Je viens de faire ça, effectivement il y a eu du mouvement mais ma situation au démarrage n'a pas changé.... sniif

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
bon ce sont les bonnes références pourtant, tu peux forcer une reconfiguration du clavier avec

 

sudo dpkg-reconfigure keyboard-configuration

 

Et regarde au reboot si tu as toujours le problème.

 

Merci!

 

Cela ne fonctionne pas non plus.... dommage...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

bah pas le bon clavier choisi ;)

 

dans les paramètre du clavier, il te faut installer soit le fr defaut soit l'autre et donc tester les deux configuration.

 

ça dépend beaucoup de ton clavier en fait, le mien passe en clavier fr defaut, celui de ma femme (qui est le même clavier exactement) marche avec l'autre config.

Modifié par pioupiou41

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Hello,

 

Aucune nouvelle idée pour ce problème ?

J'ai le même problème

Et je ne m'y habitue pas...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour à tous,

cette manip m'a permis d'avoir mon clavier en français

dans un terminal

Taper ibus-setup

Modifier le clavier pour le mettre en français

et le tour est joué !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

même problème pour moi, rien n'a fonctionné jusqu'à ce que je fasse :

sudo dpkg-reconfigure lightdm

je n'ai pas testé la commande de GHS-35 par contre ...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

 

J'ai également le même problème et aucune commande ci-dessus ne me l'a résolu

dans mon cas c'est vraiment étrange car c'est un ordinateur portable le plus souvent docké

et le clavier logitech usb est en qwerty alors que le clavier intégré à l'ordi est en azerty 

 

comment 2 claviers connectés peuvent avoir une config differente??? ça me laisse perplexe

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonsoir,

 

Et quel clavier souhaites-tu disposer : AZERTY ou QWERTY ?

 

Peux-tu me donner le résultat des commandes suivantes :

locale
cat /etc/default/locale

Nikos

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

 

j'ai bien LANG=fr_FR.UTF-8 

 

et clavier fr dans /etc/default/keyboard

 

j'ai remarqué un autre comportement étrange si je branche le dongle usb du clavier après que lightdm soit affiché, mon clavier est bien en AZERTY

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

C'est bien d'avoir LANG=fr_FR.UTF-8 mais ça ne suffit pas.

As-tu aussi LC_IDENTIFICATION=fr_FR.UTF-8 ?

Tu devrais donner le résultat des commandes que Nikos te demande pour qu'on puisse t'aider.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

j'avais pas vue pour la commande locale voilà le résultat

 

LANG=fr_FR.UTF-8
LANGUAGE=fr_FR
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
bon après quelques recherches le problème touche principalement les utilisateurs de lightdm (toute distrib) avec certain claviers logitech

le bug est en tout cas de ce coté là, et personne n'a de solution

 

en attendant je débranche et rebranche le clavier immédiatement pour qu'il repasse en azerty  :D

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

je viens de réinstaller mon Eos

et quand l'ordi ce mets en veille

et que je  reviens dessus et que je bouge la souris

il me demande mon password

le mot de passe est en version Qwerty et non azerty

du coup pas simple d'écrire le pass pour le log à Eos

 

et quand je suis sur Eos , pourtant mon clavier et bien azerty

à n'y rien comprendre :wacko:

 

du coup j'ai enlever la mise en veille pour l'instant

si vous avez une soluce?

 

merci

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Lors de ta première connexion (une fois ton ordinateur allumé), est-ce que ton clavier est en qwerty ?

 

Nikos

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

dés la fin de l'install de EOS et au redemarrage

on arrive sur l'écran de login d'Eos

au moment de taper le mot de passe qui déverouille

j'ai bien un clavier AZERTY mais quand je tape le mot de pass il le mets en version QWERTY

donc pas simple de taper sont mot de passe lol

 

peut être une erreur de ma part à l'install

j'ai réussi à me débrouiller mais j'aurai voulu quand même comprendre un peu ;)

au moins je corrigerai facilement en cas de réinstall

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à cette question…

×   Vous avez collé du contenu avec mise en forme.   Supprimer la mise en forme

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Créer...