Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
Hiden

Video tearing , Linux, Xorg... Vivement wayland hein!

Question

Bon, je suis content d'être repassé sous GNU: je passe du bon temps dans le terminal a tripatouiller des machins, des bidules et tout mais y'a vraiment un truc qui me fatigue... c'est cette vielle momie de Xorg qui gère pas correctement la synchronisation verticale, le video-tearing etc...

 

C'est toujours la même chose, quelle que soit la distribution, le materiel, ou l'environnement de bureau. Alors je sais que beaucoup de chanceux n'ont pas ce problème mais ça tombe à chaque fois sur moi faut croire :lol:. Si vous voyez pas de quoi je parle ->  un petit exemple ici.

 

Voilà ce que j'ai essayé:

 

Créer le fichier xorg.conf et activer l'option tearfree du driver intel (désactivée par défaut bien sur...) en rajoutant ceci :

Section "Device"
   Identifier  "Card0"
   Driver      "intel"
   Option      "TearFree"    "true"
EndSection

Mais ça ne fonctionne pas cat /var/log/Xorg.0.log | grep Tear me renvoie toujours

[27.108] (==) intel(0): TearFree disabled

J'ai essayé en activant/désactivant les options

"SwapbuffersWait" false
"AccelMethod" "sna"

Mais rien ne fonctionne. J'ai pas encore essayé de changer de méthode d'accélération pour UXA mais je suis sur que ça va rien résoudre.

 

Je sais pas trop quoi faire, peut être que je m'y prend mal pour activer les options du drivers intel? Si c'est le cas merci d'éclairer ma faible lanterne :lol:

 

[EDIT] Freya stable, Intel HD4400, kernel 3.19.3. ;)

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Bon le tearing est moins visible - et donc moins génant - après mise à jour du kernel en 4.0. Mais le problème est toujours là :(

Share this post


Link to post
Share on other sites
  • 0

Salut

 

Si tu n'as pas encore trouvé de solution :

Effectivement, le tearing, c'est une horreur ! je viens d'écumer le web ces dernières heures et j'ai trouvé un truc qui marche plutôt bien : compton !

Si j'ai bien compris, c'est un "compositor" pour X qui permet de bufferiser les rendus des fenêtres des applis lancées et de dessiner ton bureau au bon moment (synchro verticale). Un truc comme ça quoi :P

 

Bref, j'ai juste ajouté cette ligne magique dans mon .xinitrc :

compton --backend glx --vsync opengl-swc --paint-on-overlay &  # https://github.com/chjj/compton/wiki/vsync-guide

Et quasi plus de tearing ! (sauf sur les videos youtube en fullscreen, mais ça va encore).

 

Attention à bien ajouter ton utilisateur au groupe "video" pour lancer compton sans sudo ou sans être root.

 

Bonne continuation !

Share this post


Link to post
Share on other sites
  • 0

Le problème vient surement du fait qu'on parle pas d'une carte vidéo dédié mais d'un chip vidéo intel, c'est malheureusement récurent chez eux.

Et comme les drivers intel sont pas super super chez GNU on a des problèmes.

 

J'ai pas d'intel donc je vous serais d'aucune utilité, cependant il serait bon de tenir ce fil à jour sur les méthodes pouvant permettre d'obtenir un rendu parfait.

 

 

 

Désoler de pas aider plus et bon courage pour vos recherche.

Share this post


Link to post
Share on other sites
  • 0

J'avais du tearing aussi sous KDE j'avais regardé l'option double buffering video. Avec par exemple un lecteur vidéo qui gère le double buffering tu n'as plus de tearing

Share this post


Link to post
Share on other sites
  • 0

ça veut donc dire que ça vient pas de la gestion de l'entrelacement mais bien du stockage temporaire de l'info

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...