Jump to content
ElementaryOS France
  • 0

bluetooth sur t400


varuna
 Share

Question

Hello ' comme YVES84 en fait....

Jusqu'a présent , no problemo avec bluetooth qui s'affichait dans la barre, et pouvait être actif ou non . Ce matin j'ai  transféré vers  mon téléphone une image. 

Puis plus rien

La commande dpkg --get-selections | grep indicator me donne

r1.2-appindicator3-0.1            install
indicator-application                install
indicator-bluetooth                install
indicator-datetime                install
indicator-keyboard                install
indicator-messages                install
indicator-power                    install
indicator-session                install
indicator-sound                    install
libappindicator3-1                install
libindicator3-7                    install

 

donc il doit être là .

J'ai essayé plusieurs manip avec la commande hard , les combinaisons de touches .. rien .

BT n'est plus dans la barre, ni bien sur dans les paramètres système. message " aucun adaptateur trouvé ..

autres commandes

aruna@varuna:~$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 17ef:1004 Lenovo Integrated Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 08ff:2810 AuthenTec, Inc. AES2810
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
varuna@varuna:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.2 IDE interface: Intel Corporation Mobile 4 Series Chipset PT IDER Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)

et ( là je pompe pas ou est le BT)

sudo lshw -C network
[sudo] password for varuna:
  *-network               
       description: Ethernet interface
       produit: 82567LM Gigabit Network Connection
       fabriquant: Intel Corporation
       identifiant matériel: 19
       information bus: pci@0000:00:19.0
       nom logique: eth0
       version: 03
       numéro de série: 00:24:7e:68:76:af
       capacité: 1Gbit/s
       bits: 32 bits
       horloge: 33MHz
       fonctionnalités: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=1.8-3 latency=0 link=no multicast=yes port=twisted pair
       ressources: irq:28 mémoire:fc000000-fc01ffff mémoire:fc025000-fc025fff portE/S:1840(taille=32)
  *-network
       description: Interface réseau sans fil
       produit: PRO/Wireless 5100 AGN [Shiloh] Network Connection
       fabriquant: Intel Corporation
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       nom logique: wlan0
       version: 00
       numéro de série: 00:22:fa:c7:b7:fa
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-72-generic firmware=8.83.5.1 build 33692 ip=192.168.1.21 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       ressources: irq:32 mémoire:f4300000-f4301fff

il est là et il tourne

$ sudo service bluetooth start

start: Job is already running: bluetooth



 

Link to comment
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Hello,

 

J'aurais besoin du résultat des commandes suivantes :

bluetoothctl
list

Dans mon cas, mon périphérique bluetooth m'est retourné :

Controller F4:B7:E2:CE:07:A0 nikos-carbon-loki [default]

Il me faudrait aussi le retour de la commande suivante :

rfkill list

Cette commande te retournera la liste de tes périphériques sans fils ainsi que leurs états :

0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: tpacpi_wwan_sw: Wireless WAN
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

En fonction du résultat de ces commandes, je pourrais t'en dire plus.

 

Nikos

 

Link to comment
Share on other sites

  • 0

salut N

C'est un T400 , y 'a la touche Thinkvantage qui te permet de booter depuis une clef ou autre ( probablement le bios mais mes souvenirs de système info, unix etc ont 25  ans mini  alors :blink::blink:) .

je fais un essai

Link to comment
Share on other sites

  • 0

salut N

Avec la touche bleue TVantage je suis entré dans le BIOS puis config puis network : pas vu de bluetooth là , ni ailleurs , tout est "enable" .

la version du bios est 2.16 du 21/4/09 : vieille bécane ah ah

la touche F12 ne fait rien

a suivre .

Link to comment
Share on other sites

  • 0

salut N 

Dans mon BIOS dans config  y'a pas 

WLAM device

ni

wireless 

a mon avis il doit y avoir une commande dans le terminal que j'ai du faire qui a bloqué le truc  puis que le 

wireless LAN is not blocked ( ante ) 

suite : je viens de faire 

 

ça ne donne rien ( c'est pour un 410) , je crois qu'il y a un conflit entre ubuntu et les commandes de ce bios . 

BIS

ensuite les commandes ( trouvées sur fofo  ubuntu  T400 US

$ gksudo gedit/etc/rec.local
Gtk-Message: Failed to load module "pantheon-filechooser-module"

(gksudo:2302): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gksudo:2302): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gksudo:2302): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gksudo:2302): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gksudo:2302): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »
Gtk-Message: Failed to load module "canberra-gtk-module"


puis

sudo chmod +x /usr/sbin/bluetooth

 

 

PUIS

sudo service bluetooth restart

bluetooth stop/waiting
bluetooth start/running, process 2566

enfin

https://ubuntuforums.org/showthread.php?t=2269744

( message 2 )

je bloque là ///

Le process es là; il est actif et rien

 

 

 

 

 

 

Link to comment
Share on other sites

  • 0

suite

j'ai trouvé cette  commande sur un fofo US pour le même problème avec ubuntu 14.04

dmesg | grep -i blue
[   24.142003] Bluetooth: Core ver 2.21
[   24.142029] Bluetooth: HCI device and connection manager initialized
[   24.142035] Bluetooth: HCI socket layer initialized
[   24.142038] Bluetooth: L2CAP socket layer initialized
[   24.142045] Bluetooth: SCO socket layer initialized
[   24.343842] Bluetooth: RFCOMM TTY layer initialized
[   24.343850] Bluetooth: RFCOMM socket layer initialized
[   24.343856] Bluetooth: RFCOMM ver 1.11
[   24.404036] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   24.404040] Bluetooth: BNEP filters: protocol multicast
[   24.404046] Bluetooth: BNEP socket layer initialized

 

confirmation donc de la présence et de l'activation .

 

Link to comment
Share on other sites

  • 0

suite ( ouais j'ai du temps :ph34r:)

ce n'est pas TLP : j'ai desinstallé , idem , puis réinstallé idem

un truc curieux : à l'allumage le voyant " bluetooth " clignote puis s'éteint

essayé : interrupteur wireless ( fait bluet et wifi) débranché puis branché

le contraire , avec ou sans tlp ....

 

Link to comment
Share on other sites

  • 0

OK

voila

varuna@varuna:~$ hciconfig -a
varuna@varuna:~$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 17ef:1004 Lenovo Integrated Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

 

SACHANT QUE J'ai désinstallé rous les logiciels " bluettooth" de la logithèque !!!

bluetooth

transfert de fichiers bluetooth

configuration de bluetooth

rechargement  de " config de periph BT" donne

hciconfig -a
varuna@varuna:~$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 17ef:1004 Lenovo Integrated Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root

la même chose ... et toujours le voyant s'allume au lancement

Link to comment
Share on other sites

  • 0

salut Nikos

mois aussi j'ai un doute mais BT a fonctionné au début ?

$ bluetoothctl
bluetoothctl : commande introuvable
varuna@varuna:~$ list
La commande « list » est introuvable, vouliez-vous dire :
 La commande « klist » du paquet « heimdal-clients » (universe)
 La commande « klist » du paquet « krb5-user » (universe)
 La commande « flist » du paquet « nmh » (universe)
 La commande « listg » du paquet « nauty » (multiverse)
 La commande « bist » du paquet « bist » (universe)
 La commande « dist » du paquet « nmh » (universe)
 La commande « gist » du paquet « yorick » (universe)
 La commande « last » du paquet « sysvinit-utils » (main)
 La commande « slist » du paquet « ncpfs » (universe)
 La commande « hist » du paquet « loki » (universe)
list : commande introuvable

et

bluetoothctl list
bluetoothctl : commande introuvable

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...