Jump to content
ElementaryOS France
  • 0
Llen

Manque la batterie, le son et le défilement à deux doigts

Question

Bonjour à tous,

Fervent utilisateur de Debian et d'Archlinux avec openbox, j'ai passé un hp netbook de base 2 en 1 sous elementaryOS Juno pour convaincre ma femme avec un système un peu plus léché et moins velu. Tout va bien, ça tourne, l'écran tactile fonctionne.

Mais, je n'ai pas de son sur la sortie analogique. J'ai farfouillé partout et même passé le noyau en 4.20 pour du cx2072x mais c'est très exotique, je laisse tomber.

Je n'arrive pas à afficher le niveau de batterie. J'ai essayé elementary-tweaks, super-wingpanel et autre. Rien ne fait.

Enfin, j'ai beau l'avoir activé dans les paramètres, le défilement à deux doigts sur le trackpad ne fonctionne pas. Chose étrange avec cet élément, en livecd, il ne fonctionnait pas. À la première connexion non plus. Je n'ai rien fait et après le reboot, ô surprise, il fonctionne.

Dans l'espoir de vous lire. 

Bisous.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hello @Llen,

Je suis actuellement sur mon PC de bureau, je regarderai sur mon portable pour voir la partie batterie et défilement pendant le week-end.

Nikos

Share this post


Link to post
Share on other sites
  • 0

Hello,

J'ai bien l'indicateur de batterie sur mon portable. Il se pourrait que certains indicateurs soient manquants, on va valider cela, pourrais-tu me donner le résultat de la commande suivante :

dpkg --get-selections | grep power

Chez moi, le résultat est le suivant :

nikos@nikos-juno:~/Téléchargements$ dpkg --get-selections | grep power
gnome-power-manager				install
libupower-glib3:amd64				install
powermgmt-base					install
switchboard-plug-power				install
upower						install
wingpanel-indicator-power	

Nikos

Share this post


Link to post
Share on other sites
  • 0

Bonjour Nikos, 

Tout d'abord merci de t'intéresser à mon cas.

Voici le résultat du dpkg :

[sudo] Mot de passe de moi:          
gnome-power-manager				install
indicator-power					install
libupower-glib3:amd64				install
powermgmt-base					install
switchboard-plug-power				install
upower						install
wingpanel-indicator-power			install

Donc à priori ça ne vient pas d'un paquet absent. J'avoue que je suis perplexe. Je pense que ça vient la machine qui est très particulière niveau matériel et pas la distribution. J'ai continué à chercher avec les références machine et c'est bcp de problèmes aussi avec CentOS, Debian, Archlinux qui sont quand même sérieuses elles aussi niveau driver et compatibilité.

 C'est bête parce que ma femme est très contente du rendu et de la fluidité d'EOS par rapport à W10 dessus. Et qu'en 5 ans c'est la première fois qu'elle est d'accord pour rester sous un système GNU/linux.

 

Share this post


Link to post
Share on other sites
  • 0

Hello @Llen,

On va essayer de trouver une solution, pour l'instant, on va s'attacher à confirmer si l'OS détecte bien l'état de la batterie, pour cela on va utiliser upower, avec cette première commande pour lister les devices liés à l'alimentation:

upower -e

Voici un exemple du résultat chez moi:

/org/freedesktop/UPower/devices/line_power_AC
/org/freedesktop/UPower/devices/battery_BAT0
/org/freedesktop/UPower/devices/DisplayDevice

Les informations de la batterie sont interrogeables via le chemin /org/freedesktop/UPower/devices/battery_BAT0

Pour voir l'état de la batterie d'un point de vue système :

upower -i /org/freedesktop/UPower/devices/battery_BAT0

Ce qui donne, par exemple :

  native-path:          BAT0
  vendor:               SMP
  model:                45N1071
  serial:               11597
  power supply:         yes
  updated:              dim. 13 janv. 2019 12:17:25 CET (2 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    warning-level:       none
    energy:              30,44 Wh
    energy-empty:        0 Wh
    energy-full:         30,44 Wh
    energy-full-design:  46,03 Wh
    energy-rate:         14,314 W
    voltage:             16,435 V
    time to empty:       2,1 hours
    percentage:          100%
    capacity:            66,1308%
    technology:          lithium-polymer
    icon-name:          'battery-full-symbolic'

Tu peux faire le même test en débranchant le câble d'alimentation, l'état state évoluera.

Si cette étape est correcte, on regardera un niveau au dessus, à savoir côté indicator elementary OS.

PS : Je me permets de détailler un maximum les infos pour que d'autres personnes n'ayant pas les mêmes connaissances que toi, puissent suivre ;)

Nikos

Share this post


Link to post
Share on other sites
  • 0

Hello @Nikos

Ça commence mal avec upower -e

:~$ upower -e
/org/freedesktop/UPower/devices/line_power_ADP1
/org/freedesktop/UPower/devices/DisplayDevice

La batterie n'apparait même pas dans les devices. 

Edited by Llen
Oublie de citation

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...