Jump to content
ElementaryOS France
  • 0
JARHEAD

1h30 d'autonomie...

Question

Bonsoir à tous, 

Comme indiqué dans ma présentation, je rencontre un seul problème avec mon ordi, c'est la consommation de batterie hallucinante. 
Sous Windaube je suis à 8h environ d'autonomie, alors que sur Linux ( toute distro confondu) je suis à 1h30 maximum d'autonomie (même en ne faisant rien). 

J'adore Elementary en plus (je sors de 8ans d'OSX, que j'ai énormément apprécié pour son ergonomie)

Ma config: 
Razer Blade 15 Based 
i7 9750H 
GPU: RTX 2060  ( il parait que le problème viendrait de là... (?) ) 

Que puis-je faire pour résoudre mon problème et pouvoir consommer justement ma batterie ? 

En vous remerciant

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

J'ai installer (de base) le pilote propriétaire Nvidia 335.21

Dans Xserver, j'ai activé le GPU Intel intégré au processeur. 

Dois-je mettre les pilotes LLB plus récents (440.44 Dec 2019) que les SLB (Août 2019) disponible sur le site de Nvidia?

Share this post


Link to post
Share on other sites
  • 0

Non 😕 malheureusement... je ne la trouve pas 
Comment puis-je l'installer en l'ayant téléchargé depuis le site de Nvidia je l'ai en fichier .run  ?


Tiens regarde, j'ai pris ça toute à l'heure en capture... ça fait froid dans le dos 😅

Capture d'écran du 2020-01-12 17.21.28.png

Share this post


Link to post
Share on other sites
  • 0

Bon pas après une relance, j'ai d'un coup la possibilité de les installer, chose que j'ai fait de ce pas, à instant ou je t'écris, le tout charge. 

J’espère y voir une amélioration


Edit: Pas vraiment d'amélioration, toujours 1h d'autonomie d'affiché lorsque je suis sur la batterie...  ( On va trouver une solution j'en suis sur, je vais fouiner un peu sur les forums amerloque voir si il y en a d'autre qui on eu le même soucis) 

Capture d'écran du 2020-01-12 23.45.54.png

Edited by JARHEAD
avancé chronologique

Share this post


Link to post
Share on other sites
  • 0

bah tout bonnement je n'ai pas mate-optimus. 

Je n'ai que Nvidia-Xserver-setting... et dans le centre d'app, je n'ai pas mate-optimus a dispo 😕

D'ailleurs sur ma barre d'applet comme tu as pu le remarquer, je n'ai aucun indicateur de GPU

Toute fois dans Nvidia Xserver j'ai bien des le début mis Intel comme GPU. 

Deux question: 

- Est-ce que le fait que le disque sur lequel j'ai eOS est chiffré joue sur l'autonomie?
- Est-ce que le fait que eOS soit sur une USB (128Go) joue aussi sur l'autonomie ?

 

Share this post


Link to post
Share on other sites
  • 0

Bon du coup je n'ai toujours pas trouvé, d'ailleurs j'ai constaté que j'ai plus d'autonomie en étant sur mon GPU Nvidia qu'en utilisant celui du CPU... 
super... 

Que dois-je faire ? 

 

Share this post


Link to post
Share on other sites
  • 0
Le 13/01/2020 à 17:07, JARHEAD a dit :

- Est-ce que le fait que le disque sur lequel j'ai eOS est chiffré joue sur l'autonomie?

oui cela peut impacter l'autonomie.

Le 13/01/2020 à 17:07, JARHEAD a dit :

- Est-ce que le fait que eOS soit sur une USB (128Go) joue aussi sur l'autonomie ?

Tout dépend du temps d’accès au périphérique, après je n'ai pas  d'expérience a ce niveau pour confirmer cela.

Share this post


Link to post
Share on other sites
  • 0

Salut, si cela peu te rassuré entre guillemet JARHEAD, j'ai exactement le même soucis que toi sur mon PC portable. J'ai essaye pas mal de distrib Linux et il est vrai que je me suis posais la même question.

Honnêtement je n'ai pas pris le temps de regarde pour résoudre ce problème. Il doit bien y avoir une solution, as tu fais un HTOP pour pouvoir si ton matériel consomme ?

Share this post


Link to post
Share on other sites
  • 0

^^ Merci pour ta réponse, effectivement, ça ne me rassure pas trop, c'est même un peu dommage. Parce que clairement je préféré être sur Elementary que sur windaube. 
J'ai au moins compris que j'avais plus d'autonomie en affichant via le GPU Nvidia qu'avec celui d'intel. C'est dommage de ne pas pouvoir moduler l'utilisation du processeur et du GPU à sa guise.
Dans htop, c'est Xorg qui affiche des piques d'utilisation de CPU, jusqu'à 30% des fois mais sur 1sec, ainsi de gala qui pique à 45% lui aussi

Share this post


Link to post
Share on other sites
  • 0

Effectivement il y a beaucoup de petites choses comme le bluetooth activé quand on ne s'en sert pas, le wifi , une musique en pause depuis 6 jours qui prennent de  la batterie. 

Je suppose que tu as déjà installé tlp ? Vérifie qu'il est bien activé :

sudo systemctl status tlp

Il y avait des indicateurs cpufreq pour agit sur la fréquence du processeurs et d'autres paramètres depuis le panel mais je n'en ai pas trouvé d'accessibles depuis elementary (même avec atanaya depuis qu'on n'a plus accès aux indicateurs). 

J'aime bien aussi powertop Tu peux l'installer avec

sudo apt-get install powertop

Il est plus spécifique que tlp. Tu le lances en ligne de commande :

sudo powertop

dans le premier onglet vue d'ensemble, tu as les applis qui bouffent le plus ta batterie (c'est comme htop si tu veux) , avec  TAB tu peux te déplacer dans les onglets, l'onglet tunable te montre les config sur ton poste qu'il estime mauvaises pour ta batterie, c'est là que c'est dangereux en de mauvaises mains, dans le sens où c'est des suggestions, tu ne peux peut-être pas tout désactiver, il faut prendre son temps, surveiller et se renseigner.  N'hésite pas à nous faire part de tes découvertes.

Share this post


Link to post
Share on other sites
  • 0

Encore une fois, merci, je suis sur Powertop, je test, je vous fait un retour. 
jusqu'à présent je me suis informé un peu par-ci par-là de l'utilisation de Powertop. 
je test...et reviens vers vous ;)

Share this post


Link to post
Share on other sites
  • 0

il y a une certaine optimisation, qui affecte le clavier, et ainsi la saisie. je me suis rendu compte en vous repondant, le clavier avait tendance à se mettre en veille, et la sortie de veille prend quelques secondes, du coup pendant 3 - 4 secondes le clavier ne prend aucune frappe, et en 4sec, on en écris des mots... ^^'

Share this post


Link to post
Share on other sites
  • 0

salut @JARHEAD,

j'ai refait des tests, avec la wifi désactivée, pas de musique (dur), pas de souris sans fil, tous les tunables de powertop passés sur Bon, la luminosité baissée (mais raisonnablement quand même)   et en tapant juste du texte dans un éditeur  ma batterie tient 4 heures (elle promettait 6 et elle est quasi neuve). C'est pas le top mais ça peut faire 1/2 journée de prises de notes à l'extérieur.

Je cherche encore.

Share this post


Link to post
Share on other sites
  • 0

Il semble que l'autonomie de batterie annoncée par les fabricants est souvent obtenue en utilisation minimale, (ordinateur allumé, luminosité à 50% ou moins, pas beaucoup d'activité du processeur ) ce qui n'est jamais le cas d'une utilisation normale.

 

Share this post


Link to post
Share on other sites
  • 0
Le 06/02/2020 à 10:27, lafy a dit :

Il semble que l'autonomie de batterie annoncée par les fabricants est souvent obtenue en utilisation minimale, (ordinateur allumé, luminosité à 50% ou moins, pas beaucoup d'activité du processeur ) ce qui n'est jamais le cas d'une utilisation normale.

 

Yes, je comprend tout à fait, comme pour nos autonomie de voiture, toute fois, il faut avouer que sur Windaube, l'ordi en utilisation de base me fait 7h-8h facilement, là j'ai l'impression d’être à 240km/h sur l'autoroute et de voir ma jauge descendre à vitesse grand V. 

Et je ne comprend toujours pas pourquoi je consomme moins en utilisant mon GPU dédié, plutôt que le GPU interne au CPU :/

Je compte basculer mon eOS à l’intérieur de mon ordi, et non pas le laisser sur sa clef USB en crypté ( je pense que ça améliorera les performances) comment puis-je m'y prendre sans perdre toute les modifs que j'ai actuellement faite? je pensais a faire comme une time-machine est-ce la meilleur chose à faire ?


Désolé pour ce retard de retour, mais j'étais à l’étranger, sans mon ordi.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...