Jump to content
ElementaryOS France
  • 0
vongéo

Gestionnaire de mise à jour

Question

sofware updater

Bonsoir par moments le gestionnaire me dit :

 
 
W: Impossible de récupérer http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/source/Sources 404 Not Found
, W: Impossible de récupérer http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found
, W: Impossible de récupérer http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found
, E: Certains fichiers index a échoué à télécharger. Ils ont été ignorés, ou les anciens utilisé à la place.
 
ou alors il me parle de "" failed to download repository information  """
 
pourtant il m'a installé le dernier Kermel 3.16.0-40-generic (x86_64) hier le 13 alors il ce passe quoi ,
 
au même moment sur un autre poste sous xubuntu 12.04 pas de soucis de maj ...
Merci pourvotre éstimé éclairage -_-
  • Like 1

Share this post


Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0

Ça doit être un ppa qui est obsolète ou ne convient pas...

Ah, je viens de voir... Il ne faut pas utiliser les dépôts "versable" avec Freya

Ré-édite ton message et essaye de casser tes liens parce qu'on ne voit pas ce qu'il y a dedans...

Share this post


Link to post
Share on other sites
  • 0

Merci , c'est dans les preferences du gestionnaire de maj qu'on régle ?  ça je vais voir merci

Sur le poste de mon voisin ça le fait aussi c'est un proc intel core duo.

 

un temps +tard : non je ne vois pas donc :

comment régle t'on celà ?  svp merci

Share this post


Link to post
Share on other sites
  • 0

Je précise que je n'ai pas fait de mise à niveau depuis Luna . J'ai fait une installation propre de Freya.

Je pense bien qu'il doit y avoir une commande via terminal ... ? nan ??

Share this post


Link to post
Share on other sites
  • 0

voilà casser les liens ...

 

j'avais pas capté sur  le coup

 

failad download repository information


W:Failed to fetch http://ppa. launchpad.net/versable/elementary -update/ubuntu/dists/trusty/main/source/Sources  404  Not Found
, W:Failed to fetch http://  ppa . launchpad.net/versable/elementary -update/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found
, W:Failed to fetch http://ppa. launchpad.net/versable/elementary -update/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.

 

merci

Share this post


Link to post
Share on other sites
  • 0

Tu as le PPA "versable " qu'il ne faut pas utiliser avec Freya. Il faut le supprimer de ton source.list. Ça se fait avec "sudo", hein!

 

http://ppa. launchpad.net/versable/elementary -update/ubuntu/dists/trusty/main/source/Sources 

/etc/apt/sources.list 
et 
/etc/apt/sources.list.d

Voici quelques liens vers le forum où on parle de "versable". Trouvés avec "mon moteur de recherche" https://dl.dropboxusercontent.com/u/19586410/HTML/eOs_search.html

 

forum.elementaryos-fr.org/topic/1426-modifier-le-slingshot/
9 mai 2015 ... Il est bidon ce tuto car le dépôt versable n'est pas compatible pour freya, il n'y a aucun paquet pour Trusty. https://launchpad.ne...ementary- ...
 
forum.elementaryos-fr.org/.../1419-thème-plastico-tweaks-freya/
7 mai 2015 ... Donc l'auteur n'a pas fait de paquet pour la trusty ou freya :/. EDIT: c'est un paquet du dépôtversable qui n'est pas compatible avec freya.
 
forum.elementaryos-fr.org/.../1411-tweak-sur-freya-personalisation/
 
5 mai 2015 ... Administrateurs; 846 messages. Posté 06 mai 2015 - 16:38. Le dépôt mpstark est compatible avec Freya, c'était celui de versable qui était pour ...
 
forum.elementaryos-fr.org/topic/1403-ppa-recalcitrant/
 
3 mai 2015 ... ... sudo ppa-purge http://ppa.launchpad.net/versable/elementary-update/ubuntu/ dists/trusty/main/binary-i386/Packages Updating packages lists ...
 
forum.elementaryos-fr.org/.../1401-mise-à-jour-de-la-documentation/
 
2 mai 2015 ... Je ne veux pas que des nouveaux mettent le PPA versable qui n'est pas compatible avec Freya par exemple. Retour en haut; Signaler ...
 
forum.elementaryos-fr.org/.../1346-w-impossible-de-récupérer- httpppalaunchpadnetversableelementary-updateubuntudistst...
 
23 avr. 2015 ... W: Impossible de récupérer http://ppa.launchpad.net/versable/elementary-update /ubuntu/dists/trusty/main/binary-i386/Packages 404 Not ...
 
forum.elementaryos-fr.org/.../1256-freya-03-probleme-dépot/
25 mars 2015 ... W: Impossible de récupérer http://ppa.launchpad.net/versable/elementary-update /ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not ...
 
forum.elementaryos-fr.org/.../1253-depot-elementary-os-freya/
21 mars 2015 ... W: Impossible de récupérer http://ppa.launchpad.net/versable/elementary-update /ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not ...
 
forum.elementaryos-fr.org/.../1211-modifier-la-taille-des-vignettes-des- dosssiers-de-fichiers/
 
23 févr. 2015 ... A déplacer dans problèmes. Il te faut elementary tweaks : sudo apt-add- repository ppa:versable/elementary-update sudo apt-get update sudo ...
 
forum.elementaryos-fr.org/.../932-ppa-versable-elementary-update-pour- freya/
18 oct. 2014 ... Or en installant le ppa:versable, celui-ci m'indique à chaque fois qu'il est introuvable dans le terminal "404 not found". Pour elementary-tweaks ...

Share this post


Link to post
Share on other sites
  • 0

merci ça ce présice

donc la voie est droite mais pentue ... je fait

sudo mais quelle commande ? quand tu note : /etc/ je met quoi à la place de etc ?

Share this post


Link to post
Share on other sites
  • 0

Merci nettlebay , merci je tourne mais je n'ai pas encore la soluc

je ne met pas assez les mains dans le cambouille c'est la faute à mon mac :P

mais je bosse la question à plus, salutat !

Share this post


Link to post
Share on other sites
  • 0

ATTENTION, LES MANIPULATIONS SUIVANTES PEUVENT EMPÊCHER TON ORDI DE DÉMARRER ! (si tu rates quelque chose)

 

Je ne sais pas où se trouve exactement le PPA "versable" (que je n'ai pas, bien sûr), mais le meilleur moyen de le savoir c'est de commencer par aller voir dans le source.list (Liste des sources)

 

Tu remplaces gedit par ton éditeur de texte qui est probablement scratch-text-editor.

 

Mais ce serait bien d'installer aussi Gedit car c'est celui qu'on rencontre le plus souvent sur Ubuntu; et presque tous les exemples que tu trouveras seront avec Gedit..

C'est pas obligatoire, mais ça te prendras seulement quelques secondes (sans surcharger ta distro) et ça te feras gagner souvent du temps. De plus, Gedit fait systématiquement une sauvegarde de chaque fichier que tu manipules. Ça peut te sauver aussi la vie...

sudo apt-get install gedit

Ensuite...

gedit /etc/apt/sources.list

À ce stade, même si tu fais des changements, ils ne peuvent pas être enregistrés car tu n'es pas en "root" (administrateur).

Dans le fichier qui s'ouvre, tu recherches les lignes qui contiennent "...launchpad.net/versable/elementary -update/..." . Si elles n'y sont pas, on cherchera ailleurs... Si elles y sont, tape ou copie-colle toujours dans un Terminal...

sudo gedit /etc/apt/sources.list

C'est la même chose sauf que là, on a mis "sudo" devant pour être en administrateur. Le mieux serait de faire une sauvegarde de ton fichier sous le nom de source.list~ (un ~ derrière signifie "sauvegarde" mais tu peux mettre autre chose comme .back)

Recherche les lignes que je t'ai indiqué et supprimes-les. Ne supprime rien d'autre, hein!

Enregistre

Puis...

sudo apt-get update

..pour mettre à jour les dépôts.

 

Normalement, il ne devrait plus y avoir d'erreur.

 

Si ces lignes ne sont pas dans le source.list... hé bien, il faudra chercher ailleurs... Mais à chaque jour sa peine...clindoeil.gif

 

Les lignes de commandes sont évidemment à taper dans le Terminal (Ctrl+Alt-T)

 

Attention, ne touche à rien d'autre dans le source.list parce que là, bonjour les dégâts!

 

NE PAS TRAVAILLER SANS FILET ! Une bonne chose serait de lancer avant toute "bidouille" une sauvegarde-image de ta partition ou même du disque entier avec Clonezilla (on en parle dans le forum). C'est la sécurité maxi! Je le fais régulièrement et surtout avant chaque grosse mise à jour ou quand je fais des essais dangereux.... Bien sûr, pour ça, il faut un disque externe pour les sauvegardes. Ça m'a souvent sauvé la mise... (encore récemment) surtout quand je débutais sous Linux. Je le faisais d'ailleurs déjà aussi sous Windows car je me lançais souvent là aussi dans des aventures dangereuses ! Je ne comprends pas qu'il y ait si peu d'utilisateurs qui connaissent et utilisent Clonezilla. C'est un outil indispensable pour les "bidouilleurs".

 

Désolé de ne pas m'étendre plus, mais "j'ai attrapé la crève" et là, j'ai du mal à garder les yeux ouverts... Oui-oui, on peut attraper la crève aux Antilles aussi ! (souvent avec la "clim")

Share this post


Link to post
Share on other sites
  • 0
nettlebay

un grand merci là ça fait déjà beaucoup de choses à faire ... pour les sauvegardes pas de soucis j'ai tout sur DDe , je suis du genre à suvegarder les sauvgardes ... perdre c'est apprendre  aussi ^_^  La semaine commence je m'y colle merci et Salutat . je te tiendrais informé oui la clim c'est chaud ...

ici il pleut du frais nature :D

Share this post


Link to post
Share on other sites
  • 0

Ha-ha-ha... Tu crois? Je peux te dire qu'avoir la grippe par 30ºC, c'est pas glop... Mais bon, c'est pas la mort non plus... Ici, les gens attrapent la crève le plus souvent avec la clim dans les voitures (surtout), dans les maisons ou au boulot. Autrement, les vêtements trempés par une averse + du vent peuvent faire tomber la température apparente à 20-22º ce qui est suffisant pour attraper un bon rhume voire une pneumonie (comme un de mes amis qui a tout de même failli y rester...). Autrement, il y a la Dengue et le Chikungunya (transmis par les moustiques-tigres) qui sont pas mal aussi. Et puis, on peut attraper la grippe aussi amenée par les touristes!

Bon, moi, c'est pas encore le cas, ça va beaucoup mieux aujourd'hui...

 

PS: et le rhum est excellent pour la grippe! LOLanim.gif

Share this post


Link to post
Share on other sites
  • 0

Le rhum est aussi excellent quand on n'a pas la grippe :P

Share this post


Link to post
Share on other sites
  • 0

Faut s'en méfier quand même. C'est un sacré poison -presqu'une drogue dure- contrairement à ce qui se dit... Sérieusement!

Share this post


Link to post
Share on other sites
  • 0

Je te crois !

Perso je suis plus Hydromel/Chouchen et autres boissons qui s'en rapprochent !

En écoutant un bon pagan Métal et en bidouillant mon eOS...

Share this post


Link to post
Share on other sites
  • 0
Moi, ce serait plutôt le Lambig (Calva breton)...

J'aime bien aussi le Pommeau de Bretagne mais malheureusement introuvable ici aux Antilles.

Mais bon, on va arrêter là car on va se faire censurer par le "chef"!

 

L'abus d'alcool est dangereux pour la santé, à consommer avec modération... (pour se faire pardonner)

Edited by nettlebay

Share this post


Link to post
Share on other sites
  • 0

... pour les sauvegardes pas de soucis j'ai tout sur DDe , je suis du genre à suvegarder les sauvgardes ... 

 

Attention, si tu fais des sauvegardes à partir de Windows, aucun logiciel d'imaging (à ma connaissance*) ne sauvegardera tes partitions Linux. Il les ignorera tout simplement. Par contre, Clonezilla est capable de sauvegarder un disque complet Windows/Linux (ou autres) sans grandes difficultés. Si tu fais une image de ton disque complet avec un logiciel Windows et que tu restaures cette image, Linux aura disparu. Pas génial pour un logiciel de sauvegarde!

 

* si ça existe, ça doit être récent...

 

Mon "tuto" concernant Clonezilla (plutôt une information et quelques tuyaux) http://forum.elementaryos-fr.org/topic/1453-clonezilla-permet-de-cr%C3%A9er-une-image-de-sauvegarde-de-son-disque-dur-ou-de-ses-partitions-et-den-effectuer-la-restauration-si-n%C3%A9cessaire/

Edited by nettlebay

Share this post


Link to post
Share on other sites
  • 0

lt nettlebay , pas de soucis je ne vois que de loin le windows parfois à un cyber café, si-non d'office sur les postes des voisins je leurs met une distribution linux , puis l'installe en dur  , et chaque fois je suis content  ! Et eux aussi !

Sur mon mac c'est TimeMachine mais bon c'est autre chose ...

pour revenir à ce ''versable' versatiole ?? :P

gedit ne me le montre pas .

Par contre sur une doc ubuntu au sujet des PPA j'ai trouvé la commande et le versable (dans la mer je veux)

voilà:

pascal@pascal-imedia-S3210:~$ ls -l /etc/apt/sources.list.d/
total 56
-rw-r--r-- 1 root root 146 juin  15 01:45 bmeznarsic-icon-themes-trusty.list
-rw-r--r-- 1 root root 146 juin  15 01:45 bmeznarsic-icon-themes-trusty.list.save
-rw-r--r-- 1 root root 142 juin  15 01:45 elementary.list
-rw-r--r-- 1 root root 142 juin  15 01:45 elementary.list.save
-rw-r--r-- 1 root root 242 juin  15 01:45 elementaryos-fr-community-ppa-trusty.list
-rw-r--r-- 1 root root 242 juin  15 01:45 elementaryos-fr-community-ppa-trusty.list.save
-rw-r--r-- 1 root root  73 juin  15 01:45 elementary-os-stable-trusty.list
-rw-r--r-- 1 root root  73 juin  15 01:45 elementary-os-stable-trusty.list.save
-rw-r--r-- 1 root root 332 juin  15 01:45 mpstark-elementary-tweaks-daily-trusty.list
-rw-r--r-- 1 root root 334 juin  15 01:45 mpstark-elementary-tweaks-daily-trusty.list.save
-rw-r--r-- 1 root root 150 juin  15 01:45 patches.list
-rw-r--r-- 1 root root 150 juin  15 01:45 patches.list.save
-rw-r--r-- 1 root root 130 juin  15 01:45 teejee2008-ppa-trusty.list
-rw-r--r-- 1 root root 130 juin  15 01:45 teejee2008-ppa-trusty.list.save
-rw-r--r-- 1 root root   0 juin  15 01:34 versable-elementary-update-trusty.list
-rw-r--r-- 1 root root   0 juin  15 01:34 versable-elementary-update-trusty.list.save

bon après ça ne réponds pas à la commande pour suppr

J'ai tout de même obtenu une maj : elementary base
j'ai voulu ici coller une capture d'écran ,mais il me dit mon message est trop court !! nan

bref
donc je pense qu'il n'y a pas le feu, mais il faut noyer versable :D
 

Share this post


Link to post
Share on other sites
  • 0

et bien ... de " /etc/apt/sources.list" et de cela """recherches les lignes qui contiennent "...launchpad.net/versable/elementary -update/..."

donc j'ai trouvé avec la commande

" ls -l /etc/apt/sources.list.d/"

. donc le versable il est là , mais je n'ai rien trouvé pour le supprimer .

Mais malgré celà j'ai tout de même obtenu une maj .

 

Au final je vais le laisser et si le gestionnaire ne le trouve pas il va  l'ignorer et moi aussi  , bonne journée à Toi Vénéré nettlebay :) salutat et encore merci pour ton aide beaucoup

Je vais surveiller ...

Share this post


Link to post
Share on other sites
  • 0

Tu n'as pas fait ce que je t'ai dit: Il faut éditer le source.list en root. S'il n'y est pas, effectivement, tu le trouveras peut-être dans /etc/apt/sources.list.d/

Tu tapes

sudo thunar /etc/apt/sources.list.d/ 

Il faut changer "thunar" par ton gestionnaire de fichiers: pantheon-files

Là, tu supprimes la ligne avec "versable", puis:

sudo apt-get update

geQV085l.jpg

Share this post


Link to post
Share on other sites
  • 0

Salut,

 

les erreurs 404 mènent à une erreur de apt-get update et apt-get peut refuser de mettre à jour la liste des paquets si certains sont inacessibles (erreur 404) :S

 

Donc pour palier à celà, tu peux utiliser aptitude :

apt-get install aptitude

puis

aptitude update

(équivalent de apt-get update mais pas de fail on error)

 

puis

aptitude full-upgrade

pour mettre tous les paquets à jour.

 

Aptitude c'est un peu comme apt-get mais en plus souple.

Bien sûr, il faur être root pour pouvoir lancer ces commandes.

 

a+

Share this post


Link to post
Share on other sites
  • 0

Merci à vous nettlebay j'ai fait tu a dit  puis ai supprimer la ligne "versable" et kéos  tout me semble  okai :)

Maintenant c'est aussi BO que mon bureau à voir  :D  tip top horloger c'est un de mes métiers, le dernier pratiqué .. salutat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...