Jump to content
ElementaryOS France
  • 0
culebra

Comment installer un .deb sur Loki?

Question

Très étonné de ne pas pouvoir installer de .deb directement avec l'app center! J'ai installer GDebi pour palier à ce problème mais il n'installe toujours pas le . deb : "The package file does not exist".

Et via la ligne de commande il me met: "unsupported file".

Que faire?

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0
  • Faites un clic droit sur un fichier.deb et "ouvrir avec Gdebi" ou quelque chose d'approchant. 
  • Si l'Option "Gdebi" n'est pas disponible, choisissez "ouvrir avec une autre application" (ou quelque chose du même genre...) et recherchez Gdebi.
  • il doit se trouver dans /usr/bin ou /usr/share/gdebi/gdebi (enfin, sur Ubuntu, c'est comme ça...)

C'est quand même un comble de la part des développeurs d'avoir oublié ça!

 

Sur la page donnée par Jack720, https://itsfoss.com/fix-application-installation-issues-elementary-os-loki/ , d'autres bugs ou bizarreries sont décrites et comment les résoudre... Si vous êtes fâché avec l'Angliche, utilisez Google Traduction.

Share this post


Link to post
Share on other sites
  • 0

Tu l'as pris où ton .deb ?
 
tu as bien tenté une commande du type sudo dpkg XXX.deb ?

Share this post


Link to post
Share on other sites
  • 0

Avec Gdebi j'ai toujours la même erreur mais je parviens à l'installer via la commande:

sudo dpkf -i "fichier"

Une question: quelle est la différence avec un sudo apt install "fichier.deb"?

 

Merci en tout cas pour vos aides précieuses

Share this post


Link to post
Share on other sites
  • 0

J'ai eu une réponse des dévellopeurs à ce sujet:

"Appcenter will not include a deb installer."

 

Et bien c'est dommage, ça aurait été tellement plus simple.

Share this post


Link to post
Share on other sites
  • 0

Surement pour éviter d'installer des paquets non-vérifiés.

Peut être, mais du coup les applis que tu installes à la main parce qu'elles ne sont pas dans l' Appcenter ne font pas les mises à jour comme on le faisait auparavant (exemple la version évolution de LibreOffice) 

Share this post


Link to post
Share on other sites
  • 0

Peut être, mais du coup les applis que tu installes à la main parce qu'elles ne sont pas dans l' Appcenter ne font pas les mises à jour comme on le faisait auparavant (exemple la version évolution de LibreOffice) 

 

Attention au petit quiproquo, il faut savoir qu'elementary n'a pas souhaité autoriser l'installation des packages deb via une interface graphique (mais cela reste possible en ligne de commande).

 

Une application packagée deb ne se mettra jamais sauf si le développeur a volontairement intégré un processus de mises à jour via ces propres dépôts. L'exemple le plus flagrant reste Chrome qui est disponible au format DEB (mais n'est pas disponible sous l'AppCenter) mais qui se mettra à jour via aussi l'AppCenter

 

Nikos

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Attention au petit quiproquo, il faut savoir qu'elementary n'a pas souhaité autoriser l'installation des packages deb via une interface graphique (mais cela reste possible en ligne de commande).

 

Une application packagée deb ne se mettra jamais sauf si le développeur a volontairement intégré un processus de mises à jour via ces propres dépôts. L'exemple le plus flagrant reste Chrome qui est disponible au format DEB (mais n'est pas disponible sous l'AppCenter) mais qui se mettra à jour via aussi l'AppCenter

 

Nikos

Merci, je me demandais justement comment Chrome pouvais se mettre à jour alors qu'il n'apparaissait pas dans la liste de l'AppCenter  :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...