Jump to content
ElementaryOS France

Question

Bonjour à tous,

nouvel utilisateur de Elementary OS je n'arrive pas à faire fonctionner le wifi.

Je précise que ma cle wifi est une tp-link TL-WN823N version 2

lspci
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1d.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #12 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 062a:4101 Creative Labs Wireless Keyboard/Mouse
Bus 001 Device 003: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
Bus 001 Device 002: ID 2357:0109  
Bus 001 Device 006: ID 04e8:6863 Samsung Electronics Co., Ltd GT-I9500 [Galaxy S4] / GT-I9250 [Galaxy Nexus] (network tethering)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
iwconfig
enp0s20f0u10  no wireless extensions.

enp4s0    no wireless extensions.

lo        no wireless extensions.

wlx18d6c7092652  IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1

Pour le montage des disques j'ai relevé la dernière ligne dans /etc/mtab apprès avoir cliqué sur le disque en question dans l'explorateur de fichier. Puis j'ai coller cette ligne à la fin du fstab en remplaçant par le UUID correspondant sinon plantage au boot.

Enfin j'ai réussi à installer le pilote RTL8192EU de https://github.com/Mange/rtl8192eu-linux-driver et voilà le résultat

iwconfig
lo        no wireless extensions.

enp4s0    no wireless extensions.

wlx18d6c7092652  IEEE 802.11bgn  ESSID:"MonWifi"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.452 GHz  Access Point: 88:83:22:99:D4:D4   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=100/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

En suivant cette procédure :

sudo apt-get install git linux-headers-generic build-essential dkms
git clone https://github.com/Mange/rtl8192eu-linux-driver
sudo dkms install rtl8192eu-linux-driver
echo "blacklist rtl8xxxu" | sudo tee /etc/modprobe.d/rtl8xxxu.conf
echo "options 8192eu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/8192eu.conf
sudo update-grub
sudo update-initramfs -u
reboot

J'ai doublé mon débit, plus besoin de débrancher ma clé wifi à chaque redémarrage.

Share this post


Link to post
Share on other sites
  • 0

Bonjour @carl11

je confirme que ces petites clé USB wifi fonctionnent j'en ai mis une sur un vieux Mac qui avait un vieux pilote propriétaire qui m'arrachait les cheveux et ça marche. Je l'ai insérée, en gardant une liaison par un câble Ethernet et hop Elementary l'a installée automatiquement.

As-tu regardé sur la boite si Linux était mentionné comme compatible ?

 

Share this post


Link to post
Share on other sites
  • 0

Je ne comprends pas ils me disent de faire un make mais le fichier pilote est un zip..Dois je le dézipper ??

Si je me rends dans le répertoire et que je tape make clean puis make 

pascal@pascal-System-Product-Name:~/Téléchargements$ make clean
make: *** Aucune règle pour fabriquer la cible « clean ». Arrêt.
pascal@pascal-System-Product-Name:~/Téléchargements$ make
make: *** Pas de cible spécifiée et aucun makefile n'a été trouvé. Arrêt.

Share this post


Link to post
Share on other sites
  • 0

Alors là je comprends pas si je débranche ma cle wifi et que je la rebranche la connexion s'établie. qu'en pensez vous ?

 

Share this post


Link to post
Share on other sites
  • 0

Pour moi, il n'y a pas besoin de faire un make ou de recompiler, ce n'est pas une antiquité c'est un pilote récent et accessible.

Si la connexion s’est établie le pilote a été trouvé , c'est du "plug and play" des-fois ça marche.

Si c'est aléatoire ou si ça ne marche plus au prochain reboot, peut-être que la clé est défectueuse.

Share this post


Link to post
Share on other sites
  • 0

Merci mais la clé marchait très bien sur mes autres OS.

là mon débit est très mauvais en plus 😢, par contre j'ai maintenant compilé plusieurs pilotes, est ce que c'est possible de reinstaller les pilotes par défaut de elementary os et comment ?

Share this post


Link to post
Share on other sites
  • 0

Je comprends pas toujours les nouveaux utilisateurs, pourquoi ne pas découvrir Elementary tranquillement avec les outils graphiques disponibles et garder les compils dans les docs en japonais/coréen pour un  peu plus tard ? 🤨

Si tu tiens à bien te prendre le chou tous les drivers disponibles pour wifi sont stockés là :

/lib/modules/4.15.0-64-generic/kernel/drivers/net/wireless/ (avec 4.15.0-64-generic le noyau que tu utilises  @Wolf117Warrior t'as montré comment le trouver )

Share this post


Link to post
Share on other sites
  • 0

Je suis sur la version 4.15.0-64-generic. Je souhaite juste que ma cle wifi fonctionne correctement car pas de box j'utilise la 4g de mon tel pour me connecter sur internet.

Maintenant pour changer le kernel je vais devoir potasser encore. Est ce que cette méthode qui a été posté dans un autre post peut me convenir :

sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install ukuu

 

 

Share this post


Link to post
Share on other sites
  • 0

Ukuu est passé payant du coup, il me semble que le paquet n'est pas dispo sur le PPA.

Télécharge la version du kernel que tu souhaites sur ppa/mainline.

Et ensuite tu lances cette commande pour l'installation: 

sudo dpkg -i linux-*.deb

Redémarre ton PC pour passer sur le nouveau kernel.

 

Share this post


Link to post
Share on other sites
  • 0

Je crois vraiment que tu devrais arrêter de compiler des trucs et de les copier sans les comprendre et d'installer des ppa, maintenant ce n'est que mon avis ça peut marcher aussi si tu insistes pour en baver. Il y a aussi la médecine douce: laisse ton kernel comme il est ou alors fais une mise à jour comme @Wolf117Warrior te l'a proposé, mais par pitié  arrête de potasser et de modifier tes sources... Dans ta doc quand tu as fais la commande cp tu as copié ton machin compilé vers une destination que tu as précisée, tu devrais donc pouvoir retrouver  ce que tu as copié hier et l'enlever si tu y tiens.

Déjà pourquoi n'y a t'il pas de wifi de base sur ton ordi ?

Le 25/09/2019 à 13:00, carl11 a dit :

Alors là je comprends pas si je débranche ma cle wifi et que je la rebranche la connexion s'établie.

Le 25/09/2019 à 16:46, carl11 a dit :

là mon débit est très mauvais en plus 😢

Donc j'en déduis qu'hier ça marchait, et aujourd'hui ? ça ne marche plus ou alors ça marche et c'est trop lent ? Il me semble que le débit dépend de la clé, en fait plus elle est chère plus elle est rapide.

 

Share this post


Link to post
Share on other sites
  • 0

Je comprends ton point de vue @lafy et te remercie pour tes conseils avisés; mais j'ai beaucoup appris en mettant "les mains dans le cambouis" notamment pour d'autre systèmes que je ne citerais pas.

Citation

Donc j'en déduis qu'hier ça marchait, et aujourd'hui ? ça ne marche plus ou alors ça marche et c'est trop lent ? Il me semble que le débit dépend de la clé, en fait plus elle est chère plus elle est rapide.

En fait cette clé était sur mon autre système et son débit était 2 à 3 fois supérieure donc j'en conclue que le pilote est moins bien optimisé mais peut être y a t-il d'autres paramètres qui rentre en compte. Le fait de devoir la débrancher et rebranché n'est pas normal et cela la fait avant que je touche à quoi que ce soit.

Merci @Wolf117Warrior, je vais essayer cette commande mais pas tout de suite, seulement si vraiment le problème persiste dans le temps...

 

Share this post


Link to post
Share on other sites
  • 0

@carl11 très souvent, dans ce genre de cas une mise à jour du kernel résout tout de suite le problème.  Car le 4.15 n'est plus tout récent et les versions 5 ont fait de réels progrès dans la compatibilité. 

Par exemple,  mon Teclast f7, le touchpad ne fonctionnait pas avec le 4.15. Il fallait passer par la compilation du pilote.  Mais en passant directement sur le 5 plus de soucis .

Share this post


Link to post
Share on other sites
  • 0

Je suis tenté d'éssayer mais la stabilité de mon système ne sera pas affaiblie ?

Et d'après ce que jai vu si il a y un soucis je pourrais repasser à un kernel plus ancien au démarrage ?

Share this post


Link to post
Share on other sites
  • 0

Oui, la stabilité sera améliorée.

Et oui si tu ne supprime pas tes autres kernel tu peux y retourner.

Si tu n'as pas le grue au démarrage appuie sur shift pour le faire apparaitre. 

 

Share this post


Link to post
Share on other sites
  • 0

J'ai taper la commande que tu m'a dit et j'ai rebooter le pc mais quand je fais uname - r   j'ai toujours le kernel 4.15 😮

J'ai choisi ce kernel linux-headers-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb

Shift ne fait pas apparaitre le grub... Est ce que je peux faire ça ? :

sudo nano /etc/default/grub

puis décocher GRUB_TIMEOUT=5 et sudo update-grub et reboot

Share this post


Link to post
Share on other sites
  • 0

Bon j'ai réussi à faire apparaître le menu du grub en cochant GRUB_TIMEOUT_STYLE=hidden. Seulement dans la liste des kernel je n'ai pas le 5.3.1...

Share this post


Link to post
Share on other sites
  • 0

As-tu pris ces 4 liens :
Build for amd64 succeeded (see BUILD.LOG.amd64😞
  linux-headers-5.3.1-050301_5.3.1-050301.201909210632_all.deb
  linux-headers-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb
  linux-image-unsigned-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb
  linux-modules-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb

 

Et passe par ce soft Grub-customizer pour régler le grub, cela sera plus simple avec GUI.

 

Edited by Wolf117Warrior
Suppression du dernier lien lowlatency

Share this post


Link to post
Share on other sites
  • 0

Mea culpa je n'ai pris que le 2ème lien..😓 Grrrrr

 

sudo dpkg -i linux-*.deb
[sudo] Mot de passe de pascal :       
(Lecture de la base de données... 214274 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de linux-headers-5.3.1-050301_5.3.1-050301.201909210632_all.deb ...
Dépaquetage de linux-headers-5.3.1-050301 (5.3.1-050301.201909210632) sur (5.3.1-050301.201909210632) ...
Préparation du dépaquetage de linux-headers-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb ...
Dépaquetage de linux-headers-5.3.1-050301-generic (5.3.1-050301.201909210632) sur (5.3.1-050301.201909210632) ...
Sélection du paquet linux-image-unsigned-5.3.1-050301-generic précédemment désélectionné.
Préparation du dépaquetage de linux-image-unsigned-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb ...
Dépaquetage de linux-image-unsigned-5.3.1-050301-generic (5.3.1-050301.201909210632) ...
Sélection du paquet linux-image-unsigned-5.3.1-050301-lowlatency précédemment désélectionné.
Préparation du dépaquetage de linux-image-unsigned-5.3.1-050301-lowlatency_5.3.1-050301.201909210632_amd64.deb ...
Dépaquetage de linux-image-unsigned-5.3.1-050301-lowlatency (5.3.1-050301.201909210632) ...
dpkg-deb: erreur: 'linux-modules-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb' is not a Debian format archive
dpkg: erreur de traitement de l'archive linux-modules-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb (--install) :
 dpkg-deb --control subprocess returned error exit status 2
Paramétrage de linux-headers-5.3.1-050301 (5.3.1-050301.201909210632) ...
Paramétrage de linux-headers-5.3.1-050301-generic (5.3.1-050301.201909210632) ...
/etc/kernel/header_postinst.d/dkms:
 * dkms: running auto installation service for kernel 5.3.1-050301-generic

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j4 KERNELRELEASE=5.3.1-050301-generic -C /lib/modules/5.3.1-050301-generic/build M=/var/lib/dkms/virtualbox/5.2.32/build....(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.3.1-050301-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.2.32/build/make.log for more information.
   ...done.
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-unsigned-5.3.1-050301-generic :
 linux-image-unsigned-5.3.1-050301-generic dépend de linux-modules-5.3.1-050301-generic ; cependant :
  Le paquet linux-modules-5.3.1-050301-generic n'est pas installé.

dpkg: erreur de traitement du paquet linux-image-unsigned-5.3.1-050301-generic (--install) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-unsigned-5.3.1-050301-lowlatency :
 linux-image-unsigned-5.3.1-050301-lowlatency dépend de linux-modules-5.3.1-050301-lowlatency ; cependant :
  Le paquet linux-modules-5.3.1-050301-lowlatency n'est pas installé.

dpkg: erreur de traitement du paquet linux-image-unsigned-5.3.1-050301-lowlatency (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 linux-modules-5.3.1-050301-generic_5.3.1-050301.201909210632_amd64.deb
 linux-image-unsigned-5.3.1-050301-generic
 linux-image-unsigned-5.3.1-050301-lowlatency

 

 

Share this post


Link to post
Share on other sites
  • 0

Trop tard, mais jai pu enfin choisir dans le grub le 5.3.1 generic 😃

Pour le lien lowtency c'est grave ?

Maintenant plus qu'a tester ma cle wifi.

Merci pour ta patience 👍

Share this post


Link to post
Share on other sites
  • 0

ah ok il lance par défaut le lowtency qui est premier dans la liste des kernel et me crée un kernel panic.

Donc comment le supprimer ?

Sinon pour ma clé le débit est bien meilleur mais toujours obligé de la débrancher et rebrancher pour qu'elle fonctionne...

Share this post


Link to post
Share on other sites
  • 0

Du coup, c'est quand tu redémarres le pc que tu es obligé de débrancher brancher ta clé wifi? 

Si oui, alors je pense un soucis de montage auto de ta clé. 

Share this post


Link to post
Share on other sites
  • 0

Oui c'est ça quand je redémarre le pc, une ligne à rajouter dans le fstab tu penses ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...