Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
lenonlinuxien

Problème de mise à jour

Question

Bonjour,

 

J'ai un problème quand je tente de faire des mises à jour.

D'abord, si je les fais avec l'Appcenter, la mise à jour semble se lancer quand je clique sur Update, je rentre le mot de passe, j'ai un message "Waiting for packag manager lock", puis la mise à jour s'arrête.

Si je tente la mise à jour avec le Terminal :

"sudo apt update" :

Hit:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial InRelease
Hit:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                                             
Get:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]                                                                     
Hit:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                                                 
Hit:6 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial InRelease                                                                      
Hit:7 http://packages.elementary.io/appcenter xenial InRelease                                                                      
Fetched 109 kB in 1s (67.4 kB/s)                                                   
Reading package lists... Done
Building dependency tree       
Reading state information... Done
75 packages can be upgraded. Run 'apt list --upgradable' to see them

En lançant "apt list --upgradable", j'ai une longue liste que je ne sais pas exploiter. Si nécessaire je la posterai.

avec sudo apt upgrade : "E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem."

J'ai copié sur un fichier txt le résultat du sudo dpkf configure a, mais il était si gros que je n'ai pas voulu le poster ici.

Merci et cordialement,

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Bonjour,

ce genre de problème arrive souvent après une installation qui n'a pas abouti, hors Appcenter, si tu te souviens de ce que tu as essayé d'installer ça peut te donner une piste. Par exemple si tu as utilisé un ppa récemment essaie de l'enlever par

ppa-purge ppa:nom_du_ppa_a_enlever

puis de mettre à jour les dépôts  (update + upgrade)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...