Jump to content
ElementaryOS France

lenonlinuxien

Membres
  • Posts

    91
  • Joined

  • Last visited

  • Days Won

    5

Everything posted by lenonlinuxien

  1. J'ignore si ma réponse est pertinente mais je me lance. Il me semble qu'un fichier .xz est une archive utilisée sous Linux, un peu comme un .zip ou .rar sous Windows. Je n'ai pas de fichier .xz sur mon ordinateur mais j'ai un fichier .gz qui est un autre format d'archive. Si je veux savoir ce qu'il y a dedans, je fais clic droit et "ouvrir avec gestionnaire d'archives". Dans le gestionnaire d'archives je peux me balader dans les dossiers et fichiers zippés un peu comme avec 7zip sous Windows. Voilà dis-nous si ça marche ou pas, ma réponse est peut-être trop simple et tu avais déjà tenté cela et cela n'avait pas marché.
  2. Bonjour, Même s'il est vrai que j'avais autrefois rajouté de la place en augmentant la taille de la partition, il semblerait que Linux rajoute sans cesse de nouveaux fichiers et donc je pense qu'il faut faire de la place de temps en temps. J'ai utilisé les commandes suggérées. sudo apt autoremove -- purge a marché mais j'ai eu un message d'erreur dpkg - lors de la suppression de linux-modules5.4.0-45-generic le répertoire "lib/modules/5.4.0-45-generic" n'était pas vide donc il n'a pas été supprimé. J'ai aussi eu droit à ce message d'erreur avec d'autres version du noyau. Je pense que ce message n'est pas grave car le but est de faire de la place et ce répertoire ne doit pas être trop lourd. J'ai ensuite fait sudo apt autoclean. La commande sudo journal ctl --disk-usage m'a appris que mon journal utilisait 1,3 Go, et avec sudo journalctl --vacuum-time=30d j'en ai supprimé 1,2 Go. Je pense que maintenant je n'aurai plus le message, merci à vous.
  3. Bonjour, Mon ordinateur m'envoie des messages qu'il n'y a plus assez de place sur l'espace racine. Je crois savoir qu'il existe une commande sudo apt autoremove pour enlever toutes les versions précédentes d'eOS. Ma question est, est-il possible d'effacer seulement certaines versions précédentes mais pas toutes? Si je vais dans /boot, il y a un fichier nitrd.img-5.3.0-62-generic ; si je cherche à le supprimer, j'ai un message qui me dit qu'il n'est pas possible de modifier ce dossier. J'aurais aimé garder certaines versions antérieures d'eOS pour faire en cas de problème une restauration plutôt qu'une réinstallation. Merci et cordialement,
  4. Bonjour, Suite à un accident, l'écran de mon portable est mort (chute d'un meuble) et je dois donc brancher mon ordinateur portable à un écran HP. Je voudrais ne pas rabattre complètement l'écran de l'ordinateur portable pour conserver l'accès au clavier (évite de brancher un nouveau clavier puisque le clavier du portable a lui survécu contrairement à l'écran). Quand je ne rabats pas l'écran du portable, celui-ci est allumé ainsi que l'écran HP. Comme il est complètement fichu, cela ne sert à rien, c'est juste un gaspillage d'énergie. Quelqu'un sait-il comment éteindre l'ordinateur du portable sans le rabattre, vu qu'il est branché à un autre écran? Si je vais dans "Paramètres du système", "Affichage", elementary affiche un gros rectangle rose "Hewlett Packard 23" et un rectangle foncé plus petit "Affichage intégré". Chaque rectangle a en haut à droite un engranage. Si je vais sur l'engrenage de "Affichage intégré" et que je clique sur "utiliser cet écran" pour ne plus l'utiliser, cela ne change rien. [URL=https://www.casimages.com/i/201207033212606072.png.html][IMG]https://nsa40.casimages.com/img/2020/12/07/201207033212606072.png[/IMG][/URL] Il est possible que ce que je souhaite faire ne soit pas disponible dans cette version d'eOS. Merci et cordialement,
  5. Merci Nikos. Je savais que j'avais fait une mauvaise manip et je me demandais comment faire pour l'annuler. Grâce à toi, en quelques secondes.
  6. Bonjour, Dans le gestionnaire de fichiers standard, mes icônes ont grossi si je suis en "vue en grille". Pour que mes icônes diminuent en taille, je dois passer par la "vue en liste" ou la "vue en colonnes". Elles sont devenues énormes. Quelqu'un sait-il comment avoir des icônes de taille standard tout en restant dans la "vue en grille"? D'avance merci.
  7. Le problème a disparu de lui-même, sans intervention (consciente en tout cas) de ma part. Peut-être a-t-il été réglé lors d'une mise à jour. Il y a eu au moins une mise à jour depuis que j'ai posté mon problème.
  8. Bonjour, Le problème que j'ai avec le site dealabs sous Epiphany est qu'il n'affiche que le contenu de la dernière fois ou j'ai été sous dealabs. Par exemple, là, la dernière fois que j'ai été sur ce site de promotions c'est le 19 novembre et là il affiche les résultats au 19 novembre, alors qu'on est quand même le 21 novembre. Il n'affiche donc pas de résultat actualisé. A noter que cela ne le fait que pour les résultats "à la une" (www.dealabs.com) mais pas pour les autres résultats : "Hot" www.dealabs.com/hot par exemple affiche des résultats actualisés). Bien entendu j'ai essayé d'actualiser la page avec F5 ou en allant sur une autre partie du site puis en revenant sur la page d'accueil mais j'ai toujours des résultats non actualisés. Je précise que ce genre de site affiche des promotions dont il faut profiter rapidement pour qu'elles soient encore valables ; celles d'il y a deux jours sont le plus souvent périmées. Pour l'instant la seule manière de consulter le site dealabs est d'aller sur Firefox au lieu de rester sur Epiphany mais j'aimerais mieux rester sur Epiphany car il est plus rapide que Firefox et mon vieil ordi de 2008 est assez lent. Si quelqu'un a une idée de ce qu'il faut faire merci. Peut-être en allant vider le cache Epiphany ce dont je suis actuellement incapable.
  9. Je ne me souviens plus exactement comment j'avais réglé le problème il y a presque un an. Est-ce que tu as testé toutes les commandes : "sudo apt update" "sudo apt upgrade" "apt list --upgradable" et surtout "sudo dpkg --configure -a". Il me semble - mais c'est loin - qu'à l'époque, la commande "sudo dpkg --configure -a" avait résolu le problème. J'étais sous elementary 0.4 Loki, cela devrait probablement fonctionner sous 0.5 je pense. Si mon souvenir n'est pas trop mauvais...
  10. Si tu vas dans le Terminal et que tu tapes dpkg--configure-a, qu'est-ce que ça donne?
  11. Bonjour, J'utilise aussi Wine et le programme n'apparaît pas non plus dans la liste des applications. Je pense que c'est dû au fait que Wine s'utilise en ligne de commande. La ligne de commande c'est wine "Chemin du programme/programme.exe". Je pense qu'il est correctement installé. Est-ce que, si tu tentes de lancer un programme Windows avec Wine, cela fonctionne?
  12. Bonjour et bienvenue, Ton problème avec les touches directionnelles ne me semble pas dû au système d'exploitation vu que tu as le même problème sous chrome OS (je le dis prudemment quand même). S'il y avait un lien avec le système d'exploitation, il faudrait repasser ce post en "Un problème?" ; à argumenter puisque tu as le même problème sous chrome...
  13. Bonjour, Je viens de voir tout à l'heure des stickers Linux sur dealabs à 1€ les 10, si ça intéresse quelqu'un : https://www.dealabs.com/bons-plans/lot-de-10-stickers-decoupes-sur-le-theme-unix-1915819 Je précise qu'il s'agit de Linux et non d'elementary, du coup ça ne correspond pas totalement au titre du post, mais ça pourra peut-être en intéresser quelques-uns.
  14. Cela me semble intéressant. Quand je vais dans "Paramètres système" / "Langue & région", j'ai un message , dans un bandeau jaune orange en haut de l'écran "La prise en charge des langues supplémentaires n'est pas entièrement installée" "Terminer l'installation". Et je ne vois pas comment enlever les langues que je n'utilise pas. Il y a quand même le danois, le vietnamien, le chinois, le suédois. Dois-je cliquer sur "Terminer l'installation" avant de pouvoir enlever les langues que je n'utilise pas? Comment les enlever sinon?
  15. Voilà ce que j'ai fait : J'ai créé un fichier nommé "bash loading device.sh" qui se trouve dans "/home/shinobi". J'ai donné à ce fichier les droits "777" et je l'ai rattaché au groupe "sudo". En faisant clic droit et exécuter, il me dit qu'il est nécessaire de s'identifier pour lancer la commande "/bin/mount" en tant que super-utilisateur. Je rentre le mot de passe et j'ai un message d'erreur "Une erreur s'est produite lors du montage de la partition /dev/sdb1. Veuillez vérifier le fichier /var/log/messages" Comme /dev/sdb1 n'existe pas sur mon disque, je le remplace par /dev/sda3 qui contient l'émulateur. (comme je n'ai modifié que ça, je préfère ne pas poster le code ici) J'ai ensuite le message suivant : "La partition /dev/sda3 a été montée ici : /media/shinobi" En allant dans Files, je vois qu'effectivement DONNES PERSO est monté. Par exemple, si je clique droit sur DONNES PERSO, il me propose de le démonter. Donc mon premier bash qui fonctionne sous elementary OS. Comme je n'aime pas rentrer des mots de passe, je viens d'aller dans mon sudoers. sudo visudo -f /etc/sudoers.d/custom-shinobi depuis Konsole, shinobi étant mon nom d'utilisateur le texte dans mon sudoers étant shinobi ALL=(ALL) NOPASSWD: /usr/bin/apt update, /usr/bin/apt upgrade -y, /usr/bin/mount Je dois encore faire quelques tests pour voir si j'ai réussi à faire ce que je voulais. Merci pour votre aide.
  16. J'ai donc (re)créé ce fichier bash Il s'appelle kegafusion.sh . Il est situé dans /home/shinobi. Il contient #!/bin/bash rep=$(sudo mount | grep -c /dev/sda3) if [ $rep -eq 0 ] then sudo mount /dev/sda3 /media/shinobi fi echo "lancer programme Fusion" "/media/shinobi/DONNES PERSO/Emulateurs/Kega Fusion/Fusion363/Fusion/Fusion" et si je clique droit dessus en faisant exécuter rien ne se passe. Je crois lui avoir donné les droits : en allant dans Propriétés / Permissions, il peut tout faire (code 777). Si je comprends bien le bash signifie : si le /dev/sda3 (le D:) n'est pas déjà monté, que l'ordi le monte. Je me suis demandé si ce n'était pas dû à ce que je n'aie pas entré le mot de passe. J'ai donc fait un "sudo mount /dev/sda2 /home/shinobi" ce qui m'a fait rentrer le mot de passe. Normalement après j'ai un certain délai où je peux rentrer des commandes sans rentrer à nouveau le mot de passe. Je clique droit, à nouveau, sur mon fichier kegafusion.sh, clique exécuter. Mais dans Files aucune partition n'est montée...
  17. Bonsoir, Je préférerais le faire via un ajout au fichier sudoers (ou à un fichier sudoers pour faire le puriste - il me semble qu'il y en a un pour tous les utilisateurs et un par utilisateur) ou via systemd (que je ne connais pas dans ce rôle) (ce que je veux dire, je ne préférerais pas de montage automatique de partition). En effet, la modification du sudoers ne me pose pas de problème car je ne considère pas le montage d'une partition comme une opération risquée. Sous Windows, c'est même automatique. Enfin, je considère que même s'il y avait un risque à lancer la partition via un raccourci clavier , ça ne serait pas plus dangereux que de faire un montage automatique au démarrage des partitions souhaitées (via la modification de fstab). Sinon je veux en fait pouvoir monter deux partitions : Le D de Windows qui contient Kega Fusion Le C de Windows qui contient Diablo II que je lance via Wine selon mes envies de joueur Si j'ai le mode d'emploi pour en monter une je pense pouvoir monter l'autre. Vu la lenteur en générale de mon ordinateur portable de 2008 je vais essayer de ne pas monter inutilement une (ou deux) partitions (s) à chaque démarrage. Je n'ai pas besoin des partitions qui contiennent les jeux à chaque fois que j'allume l'ordinateur.
  18. Bonsoir Nikos, Personnellement, mes préférences seraient les suivantes : Le point de montage ne se monterait pas automatiquement au démarrage afin de gagner un peu de temps de démarrage ; Il se ferait par une ligne de commande simple, sans avoir besoin de mot de passe. Je pourrais ainsi associer un raccourci clavier à cette ligne de commande (par exemple, j'ai associé un raccourci clavier à la commande sudo apt upgrade -y et maintenant les mises à jour se font par un raccourci clavier) Je ne sais pas si créer un bash fonctionnerait. Un bash me semble être une simple suite de lignes de commande et je pense que si une ligne de commande ne fonctionne pas dans Terminal ou Konsole elle ne fonctionnera pas non plus dans le fichier bash. Systemd : est-ce qu'il faut installer quelque chose? Je m'y connais moins que vous. Pour l'instant, pour monter une partition, je vais sur Files et je clique droit sur la partition souhaitée en sélectionnant "monter". Évidemment il y a le temps de lancer Files et de faire la manip donc je voudrais trouver encore plus simple. Au départ, je ne croyais que j'étais obligé d'aller, dans Files, dans la partition souhaitée pour la monter (ce qui prend encore plus de temps).
  19. J'avais un message d'erreur : avec shinobi@shinobi-Satellite-P300:~$ sudo mount /dev/sda3 /media/shinobi je me suis rendu compte que c'était parce que le /dev/sda3 était déjà monté. Genre, je rentre la commande une fois, il me demande le mot de passe et l'exécute, la deuxième je la rentre parce que je n'ai eu aucun message dans Konsole que le /dev/sda3 était monté et en fait le /dev/sda3 est monté et donc j'ai un message d'erreur. Le problème que j'ai c'est qu'il demande le mot de passe. Du coup je ne peux pas associer la commande "sudo mount /dev/sda3 /media/shinobi" à un raccourci clavier (je pense) Je viens de tenter le fichier bash (.sh), je lui ai donné les droits mais quand je clique gauche dessus / exécuter, rien ne se passe. Il s'appelle bash kegafusion.sh en /home/shinobi/Documents. C'est mon premier ficher bash.
  20. Le résultat des commandes suggérées est le suivant : shinobi@shinobi-Satellite-P300:~$ sudo mount /dev/sda3 /media/shinobi Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command. shinobi@shinobi-Satellite-P300:~$ sudo mount -L "DONNES PERSO" /media/shinobi Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command. shinobi@shinobi-Satellite-P300:~$ sudo mount | grep -c /dev/sda3 1 Pour vérifier que le D : qui contient l'émulateur n'est pas monté, j'ai lancé mon raccourci vers Kega Fusion qui n'a pas fonctionné puisque pas monté. Pour l'instant j'utilise uniquement la ligne de commande, je tenterai le bash après (je n'ai jamais utilisé de bash sous Linux).
  21. Je te confirme que c'est bien un disque dur et non une clef USB. C'est un disque non-SSD. shinobi@shinobi-Satellite-P300:~$ sudo blkid [sudo] Mot de passe de shinobi : /dev/sda1: LABEL="WinRE" UUID="1ACA7F0ACA7EE205" TYPE="ntfs" PARTUUID="123e0781-01" /dev/sda2: LABEL="Vista" UUID="F282814582810EF3" TYPE="ntfs" PARTUUID="123e0781-02" /dev/sda3: LABEL="DONNES PERSO" UUID="2BEED06C667949C2" TYPE="ntfs" PARTUUID="123e0781-03" /dev/sda5: UUID="b7626c70-3e69-455a-8a8b-0b845792407c" TYPE="ext2" PARTUUID="123e0781-05" /dev/sda6: UUID="83ac04c8-d371-4122-997c-22818fd60dbe" TYPE="swap" PARTUUID="123e0781-06" /dev/sda7: UUID="5a0425ed-6f06-4aa0-bfc5-584af6ffbf63" TYPE="ext4" PARTUUID="123e0781-07" /dev/sda8: UUID="a63f2dee-c4a3-4101-b1aa-553781b5fb53" TYPE="ext4" PARTUUID="123e0781-08" /dev/loop0: TYPE="squashfs" /dev/loop1: TYPE="squashfs" /dev/loop2: TYPE="squashfs"
  22. Ca me semble intéressant si le système ne me demande pas de mot de passe lorsqu'il charge une partition. Je ne savais pas qu'il fallait monter une partition avant de l'utiliser. Pour info je vieux de lancer la commande "sudo fdisk -l" et voici la réponse : Périphérique Amorçage Début Fin Secteurs Taille Id Type /dev/sda1 2048 3074047 3072000 1,5G 7 HPFS/NTFS/exFAT /dev/sda2 * 3074048 249571327 246497280 117,6G 7 HPFS/NTFS/exFAT /dev/sda3 249571328 392931327 143360000 68,4G 7 HPFS/NTFS/exFAT /dev/sda4 410273790 488396799 78123010 37,3G 5 Étendue /dev/sda5 460001280 462616575 2615296 1,3G 83 Linux /dev/sda6 410273792 414273535 3999744 1,9G 82 partition d'échange Linux / Solaris /dev/sda7 462618624 488396799 25778176 12,3G 83 Linux /dev/sda8 414275584 459999231 45723648 21,8G 83 Linux Les entrées de la table de partitions ne sont pas dans l'ordre du disque. J'ai besoin de monter les partitions suivantes : pour jouer à l'émulateur Kega Fusion, /dev/sda3 qui correspond au D : de Windows ; il apparaît dans le gestionnaire de fichiers comme "/media/shinobi/DONNES PERSO" pour jouer à Diablo II, /dev/sda2 qui correspond au C : de Windows ; il apparaît dans le gestionnaire de fichiers comme "/media/shinobi/Vista" Je voudrais notamment savoir s'il est préférable de monter une partition par une ligne de commande puis une nouvelle ligne de commande pour lancer le jeu ou une seule ligne de commande pour les deux, le montage de la partition et le jeu. Je ne sais pas comment faire un bash sous Linux.
  23. Merci beaucoup pour ces indications. J'ai réussi à faire ce qui m'était demandé et cela semble avoir marché. En fait, le système d'exploitation ne me demande plus de mot de passe quand je veux faire une mise à jour en ligne de commande ("sudo apt update && sudo apt upgrade -y"). Le raccourci clavier que j'ai affecté à la commande "sudo apt upgrade -y" (touche Windows + U comme update) a aussi fonctionné. Par contre, même si cela ne me gêne pas, pour ceux qui voudraient faire pareil, même avec cette manipulation, si on veut faire la mise à jour depuis l'Appcenter, elementary demande toujours le mot de passe.
  24. Pour info je n'ai pas installé de librairies KDE. Je ne savais pas que Konsole était le terminal de KDE. J'ai juste installé Konsole parce que mon Terminal ne s'ouvrait plus (il s'affichait dans le Dock quand je le lançais, mais en faisant alt tab je ne pouvais pas l'afficher) et installer Konsole a réglé mon problème. Je pense que Konsole est un tout petit peu plus léger que notre Terminal de base. Sinon en allant dans le dossier /etc j'ai vu que mon fichier s'appelait sudoer et pas sudoers - j'ignore si cela change quelque chose - et aussi qu'il y avait un panneau sens interdit, qui signifie probablement que je devrais faire les manipulations d'une manière particulière.
  25. Je reprends ce vieux thread parce que j'ai une question. 1. D'abord pour préciser mon ancien post, l'émulateur Kega Fusion peut se lancer en ligne de commande. Actuellement la ligne de commande appropriée est : "/media/shinobi/DONNES PERSO/Emulateurs/Kega Fusion/Fusion363/Fusion/Fusion" Et là j'avais des messages d'erreur du genre : failed to load atk-bridge ou failed to load gtk-module En cherchant des mots sur google on peut tomber sur la bonne façon de "charger" la bibliothèque appropriée. Comme je n'ai plus mes anciens messages d'erreur, ni de nouveau message d'erreur, en lançant Kega Fusion, j'en déduis que j'ai pu "charger" les bonnes "dépendances" (j'ignore si c'est le bon vocabulaire; possible mais pas certain). 2. Maintenant j'ai une autre question : J'ai rattaché la commande "/media/shinobi/DONNES PERSO/Emulateurs/Kega Fusion/Fusion363/Fusion/Fusion" à un raccourci dans Paramètres du système / Clavier / Raccourcis / Personnalisé (c'est touche Windows + K). La commande ne semble fonctionner que si avec le gestionnaire de fichiers j'ai déjà visité le D : de Windows sur lequel se trouve l'émulateur, lors de ma session Linux. Sinon j'ai droit à un message d'erreur. J'ai le même problème avec l'émulateur Wine. Je voudrais lancer Diablo II avec Wine. Diablo II se trouve sur le C : de Windows. J'ai paramétré dans les raccourcis que wine "/media/shinobi/Vista/Program Files/Diablo II/Diablo II.exe" était affecté à la touche Windows +D. Cela ne fonctionne que si, avec le gestionnaire de fichiers, j'ai visité préalablement le C : de Windows. Quelqu'un saurait-il pourquoi le raccourci clavier lié à un exécutable (je pense qu'il s'agit plutôt d'un exécutable que d'un programme puisqu'il n'est pas accessible depuis Applications) ne fonctionne que si la partition contenant ce programme a déjà été visitée avec le gestionnaire de fichiers? Et surtout comment enlever cette limitation, si c'est possible et que cela ne crée pas un temps d'attente supérieur au fait de lancer le C ou le D : dans le gestionnaire de fichiers (mon ordi est vieux et lent et oui c'est pour cela que j'ai eOS). Merci à tous ceux qui essaieront de répondre.
×
×
  • Create New...