Jump to content
ElementaryOS France
  • 0

Échec de la mise à jour de « Mises à jour du système »


 Share

Question

Bonjour,

Ca fait 2 semaines que je n'arrive plus à mettre eOS à jour... J'ai maintenant un peu de temps pour m'en occuper.

Quand je lance la mise à jour, je reçois ce message:

Citation

The following packages have unmet dependencies:
xserver-xorg-video-nvidia-495: Dépend: xserver-xorg-video-nvidia-515 but it is not going to be installed
libnvidia-cfg1-510: Est en conflit avec: libnvidia-cfg1-any
libnvidia-cfg1-515: Est en conflit avec: libnvidia-cfg1-any

J'ai regardé sur ce forum et Stack Exchange et trouvé cette solution:

Citation

 

Remove all Nvidia-related packages

  1. Log in to a terminal: Ctrl+Alt+F1 (terminal is visible with a blank screen)

  2. sudo apt-get remove --purge nvidia-*

Start from scratch

  1. sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Reinstall everything

  1. sudo apt-get install nvidia-common
  2. sudo apt-get install xserver-xorg-video-nouveau
  3. sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigure the X server

  1. sudo dpkg-reconfigure xserver-xorg

 

https://askubuntu.com/questions/41681/blank-screen-after-installing-nvidia-restricted-driver

Ca marche un peu près mais ne change rien.

Comment pourrais-je mettre à jour mon eOS?

Merci!

Link to comment
Share on other sites

15 answers to this question

Recommended Posts

  • 1

Et ça s'est réglé tout seul.

J'avais fait la solution du message précédent 2x, redémarré et ça ne changeait rien.

J'avais alors mis ça de côté et pensais aujourd'hui demander de l'aider dans un autre forum. J'ai alors lancé la mise à jour pour être sûre de mon message d'erreur... Et pas d'erreur cette fois-ci.

Après 3 semaines de non mises à jour, je suis contente haha

  • Like 1
Link to comment
Share on other sites

  • 0

Bonjour,

même problème depuis un bon mois. Mise à jour du système dans le centre d’applications: je clique sur « mettre à jour », apparait la barre de chargement et tout s’arrête pendant le chargement du cache.

  • Like 1
Link to comment
Share on other sites

  • 0

Bonjour Stephan,

Je compatis...

Note que, à chaque fois que ça m'arrivait, ça remarchait à un moment donné. Donc, perds pas courage, ça marchera.

Et c'est pas comme si eOS ne marchait plus à cause de ça, non?

Link to comment
Share on other sites

  • 0

J'avais besoin de modifier mon schéma de partition.
J'ai donc fait un backup format install restaure

Tout ne s'est pas passé comme prévu
étrangement alors qu'il n'y avait pas d'erreur dans les logs les fichiers de ~/.local appartenaient à root
un sudo chown -R a résolu le pb.
j'ai utilisé TimeShift
 

Dans le centre d'application les applis fournies par défaut restaient toutes avec des mise à jour même après avoir fait les mise à jour.
J'ai remarqué que les appli en question étaient dispo dans Snap AppCenter et AppCenter(system)
J'ai alors décidé de les désinstaller et réinstaller

et tout est redevenu normal

reste les mise à jour système dans AppCenter là pas de pop menu pour choisir et pas de possibilité de supprimer pour remettre
J'ai donc systématiquement une pastille (1) sur l'icone de AppCenter
cela concerne

  • io.elementary.Platform.Locale
  • io.elementary.Platform
  • io.elementary.Platform.GL.default


Au passage il y a un défaut d'affichage depuis longtemp

environnement d’exécution FlatPack s'affiche environnement d'exécution FlatPack

A+JYT

Link to comment
Share on other sites

  • 0
23 hours ago, Stephan said:

Toujours le problème.

c’est quoi la commande « Ubuntu driver »?

La commande ubuntu-driver permet de faciliter l'installation des drivers Nvidia, j'en déduis par ta réponse que tu ne l'as pas utilisé ;)

Nikos

Link to comment
Share on other sites

  • 0
18 minutes ago, Nikos said:

La commande ubuntu-driver permet de faciliter l'installation des drivers Nvidia, j'en déduis par ta réponse que tu ne l'as pas utilisé ;)

Nikos

Non je crois que les drivers Nvidia ne sont pas recommandés pour mon MacBook. Mais l’installation remonte a un bout de temps, je ne sais plus ce qui a été fait ou pas.

Link to comment
Share on other sites

  • 0
4 minutes ago, Stephan said:

Non je crois que les drivers Nvidia ne sont pas recommandés pour mon MacBook. Mais l’installation remonte a un bout de temps, je ne sais plus ce qui a été fait ou pas.

Tu es sur un Mac ? je ne savais pas qu'il y avait du Nvidia chez la marque à la pomme.

3 minutes ago, Stephan said:

Pour moi ça?

Avec les - - au milieu comme ça?

Ce sont deux tirets (ou la touche moins).

Nikos

Link to comment
Share on other sites

  • 0
1 hour ago, Nikos said:

Tu es sur un Mac ? je ne savais pas qu'il y avait du Nvidia chez la marque à la pomme.

Ce sont deux tirets (ou la touche moins).

Nikos

Oui je suis sur Mac. Je ne fais pas les màj Nvidia même si le sytème me les propose (y’en a 3 ou 4).

Je teste ça dès que je ressort l’ordi et te fais un retour. Merci.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...