Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
Gin

Impossible de booter sur eOS - Pas de Bootloader

Question

Bonjour à tous.

 

J'ai récupéré un Asus S301LA-C1033H qui a pour OS de base Win8.1

 

J'ai partitionné le disque afin d'avoir de l'espace pour installer une distrib en dual boot.

J'ai changé les paramètres de boot dans le BIOS pour permettre de booter sur clé (secure boot etc) puis j'ai fait mon installation d'elementaryOS luna qui s'est bien déroulée.

 

Cependant je n'ai pas l'impression que Grub se soit bien installé puisque le PC boot automatiquement sur Win.

 

J'ai donc essayé plusieurs solutions afin de "réparer" grub (grub-repair, super-grub etc) mais sans succés. J'ai en général un message d'erreur qui me demande une distrib EFI-compatible.

J'ai essayé d'installer des distribs qui sont "EFI-compatibles" comme Ubuntu 14.04 et fedora 20 mais toujours pas possible de booter sur Linux..

 

Avez-vous des idées pour régler le problème ? Si possible sans avoir à supprimer Win (ce sera mon dernier recours ..)

 

Merci d'avance

 

tl;dr : pas accès à un bootloader au démarrage, eOS semble bien être installé.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Bonjours, prends nous des photos de ton bios, il semblerait que tu n'ai pas activé correctement le boot legacy

Share this post


Link to post
Share on other sites
  • 0

@Gin

Bienvenue :P

 

Donc j'avais (j'ai) toujours le même problème. Lorsque j'installe Elementary OS sur mon PC, impossible de le retrouver et le démarrer. Je suis aussi sous EFI (Secure Boot et Legacy activé)

Ce problème est connu ;)

Il y a quelques solutions que l'on peut trouver afin de fixer le problème : http://www.reddit.com/r/elementaryos/comments/2ep10g/elementary_os_freya_uefi_support/.

Je suis actuellement en train d'essayer. Je t'en redirais des nouvelles et détaillerais mes manipulations

Share this post


Link to post
Share on other sites
  • 0
Bonjours, prends nous des photos de ton bios, il semblerait que tu n'ai pas activé correctement le boot legacy

 

Je ne trouve pas le paramètre justement .. ! Voici les menus de mon bios.

 

2gy80av.jpg

 

23ued5s.jpg

 

2chb34n.jpg

 

6qk7q8.jpg

 

2s8qura.jpg

 

118hys1.jpg

 

Donc j'avais (j'ai) toujours le même problème. Lorsque j'installe Elementary OS sur mon PC, impossible de le retrouver et le démarrer. Je suis aussi sous EFI (Secure Boot et Legacy activé)

Ce problème est connu wink

Il y a quelques solutions que l'on peut trouver afin de fixer le problème : http://www.reddit.com/r/elementaryos/co … i_support/.

Je suis actuellement en train d'essayer. Je t'en redirais des nouvelles et détaillerais mes manipulations

 

Merci ! Je vais jetter un oeil, tu as avancé dans la résolution du problème ?

 

Ahhh l'uEFI ..

Share this post


Link to post
Share on other sites
  • 0

Dernière photos Boot Override -> Windows Boot manager..

 

Déjà t'es toujours en boot by microsoft

 

 

Image 4 Secure boot mets Enable et regarde ce que tu as dans "plateforme mode"

 

sinon image 3 dans Boot option #1 regarde ce que tu as la dedans aussi.

Share this post


Link to post
Share on other sites
  • 0
Dernière photos Boot Override -> Windows Boot manager..

 

Déjà t'es toujours en boot by microsoft

 

 

Oui j'avais du modifier l'ordre de boot pour repasser sur Win.

 

Image 4 Secure boot mets Enable et regarde ce que tu as dans "plateforme mode"

 

sinon image 3 dans Boot option #1 regarde ce que tu as la dedans aussi.

 

Je peux pas modifier le plateforme mode, ce n'est pas un menu, j'ai juste accés à un nouveau menu ou j'ai des variables qui sont utilisées par le secure boot.

 

Pour les boot options j'ai rien en rapport avec Linux ..

 

à chaque fois que je loupe une install ce disque me sauve la vie : http://doc.ubuntu-fr.org/boot-repair

 

Malheureusement j'ai déjà tenté pendant un moment ! Boot-repair me renvoit un message d'erreur comme quoi eOS n'est pas une distrib EFI compatible..

Share this post


Link to post
Share on other sites
  • 0

Coucou !

 

Donc j'ai enfin réussi mon dualboot Windows 8.1 / Elementary OS Freya (grace à de nombreux membres que je remercie : Pierre, Devil, Gwagwa, Francisco, Breizh'... !)

Je vais te dire exactement ce que j'ai fait !

Le plus dur pour toi sera de switcher entre UEFI et Boot Legacy (BIOS normal - vieux)

 

  1. Installation de Windows 8 avec le mode UEFI activé dans le BIOS
    Création d'une clé USB live avec Elementary OS Freya via le logiciel RUFUS. Le mode est bien MBR (pour BIOS et UEFI)
    Tu partitionne ton disque dur comme tu le souhaite
    Tu éteint le PC
    Tu rentre dans le bios et tu passe en Boot Legacy et tu enlève le mode "Secure Boot"
    Tu démarre sur ta clé USB live (sans le mode UEFI)
    Tu installe Elementary OS sans les MaJ (même si ça ne change pas vraiment) avec les partitions que tu souhaite pour "/", pour ma part : / (200Go), Partition d'amorçage BIOS (100 Mo) et enfin Swap (8Go)
    Tu fini l'install
    Tu éteint et retire ta clé
    Lorsque tu va démarrer ton PC tu lance la touche pour choisir sur quel périphérique tu va démarrer
    Personnellement mon Elementary OS est sur "Disque Dur Portable" alors qu'il est dans mon PC, tu bootera sous eOS.

 

Donc voilà la méthode qui à pour ma part marché.

Si jamais tu ne peux pas boot sous Windows, il faudra que tu active le mode "Secure Boot" dans le bios, et lors du démarrage il bootera sous Windows. Et si dans ce cas, Elementary OS n'est pas dispo' alors il faut switcher en "Boot Legacy".

Share this post


Link to post
Share on other sites
  • 0

Je l'avais réussi sur mon UX32A , et si mes souvenirs sont bons , c'est dans "Boot Option Priorities" que j'avais réglé le pb, en allant auparavant dans "Add New Boot Option" puis en modifiant "Boot Option #1" avec la nouvelle entrée.

 

Mais c'est tellement vieux que je n'en suis plus tout à fait sur , toujours est qu'il est possible d'y arriver ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...