Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
icedragon

Crash cerbere

Question

Bonsoir à tous,

J'utilise Elemantary os depuis 2015 sans souci sauf depuis  quelques temps j'ai  une erreur qui s'affiche au démarrage d'Elemantary, pour connaitre d'ou provient cette erreur j'ai executer  la commande : sudo rm -v /var/crash/*,  j'ai obtenu en retour ceci "

/var/crash/_usr_lib_x86_64-linux-gnu_io.elementary.cerbere.1000.crash'  supprimé."

J'ai  chercher sur le net mais rien trouvé, j'avais posté sur pc astuces pour obtenir des infos, un intervenant que je remercie m'a indiqué qu'il s'agissait d'un logiciel de verrouillage de poste  utilisé en réseau, le sujet est peu documenté.

Si quelqu'un à une idée, un lien, un remède, je suis preneur, merc et bonne nuit i😴

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Salut et bienvenue, 

quand on a une erreur au démarrage, le système te crée un fichier dans le répertoire /var/crash qui rend compte de l'erreur

Tu as pris acte et supprimé le fichier, OK. Et maintenant ? As tu encore l'erreur au reboot suivant ?

Share this post


Link to post
Share on other sites
  • 0

Salut,  merci pour les réponses,

lafy, je pas touché au repertoire ne sachant pas trop comment faire pour  le supprimer et quel est le fichier exact, si tu connait la manip je suis preneur.

Aris j'essayerai de posté sur le lien que tu as indiqué, mais mon anglais est assez rudimentaire.

Share this post


Link to post
Share on other sites
  • 0

Hello @icedragon,

Il manque des informations pour pouvoir t'apporter un début de piste : tu nous indiques

Citation

depuis  quelques temps j'ai  une erreur qui s'affiche au démarrage d'Elemantary

Quel est le message en question ?

La commande que tu fais supprime les fichiers

sudo rm -v /var/crash/*

Il nous faut plus d'infos pour pouvoir t'aider.

Nikos

Share this post


Link to post
Share on other sites
  • 0
il y a 1 minute, Aris a dit :

Résultat d'une recherche rapide sur Stakexchange: https://elementaryos.stackexchange.com/questions/239/how-can-i-manage-which-applications-are-handled-by-cerbere

Peut-être y trouveras tu des éléments de compréhension.

Cerbere est un module d'elementary qui gère le redémarrage de certaines applications critiques : https://github.com/elementary/cerbere

Là, il nous faut plus d'infos.

Nikos

Share this post


Link to post
Share on other sites
  • 0

Voici les retours des commandes, je joins les captures d'écran :

116094566_Capturedcrandu2019-09-0422_36_19.png.366259a02cbb8e8e6068d662ed560508.png

ceci est le retour de la commande : sudo rm -v /var/crash/*

j'ai installé dconf j'ai ceci :

1295477081_Capturedcrandu2019-09-0423_15_11.png.9de7e4c2c04079c60a021ce9c2b45d6a.png

334957059_Capturedcrandu2019-09-0423_15_35.png.f4100a1311f38a85be2958181fef3dd3.png

2128412438_Capturedcrandu2019-09-0423_16_39.png.3344913ded75c842910f2e7bcd1750ee.png

J'ai changer mis le curseur sur utiliser la valeur par défaut, pour voir mais ça ne change rien, j'ai fait un reboot et toujours pareil.

Share this post


Link to post
Share on other sites
  • 0

Ce que tu as trouvé dans dconf n'a rien d’anormal pour moi, il y a un délai avant de réessayer le lancement du panel et de plank en cas de crash, c'est standard.

Il nous faudrait le détail de l'erreur. Essaie d'ouvrir les fichiers (tu en as 2 apparemment)  pour voir quelles infos il te donne, avant de les supprimer

Déplace toi dans  /var/crash et double-click simplement sur un des fichiers pour l'ouvrir en lecture seule.

Share this post


Link to post
Share on other sites
  • 0

Bonjour, lafy

J'ai ouvert les fichiers voici les captures, le texte est long je n'est pu capturer que le début, car ça risqué de tenir trop de place en image sur le forum,

1080267078_Capturedcrandu2019-09-0511_09_13.thumb.png.791bd1310661439ec1102c2659ed4872.png

 

625388672_Capturedcrandu2019-09-0511_08_58.png.056e558afab8410fb9831325d64d5b24.png

 

Share this post


Link to post
Share on other sites
  • 0

En fait ce qui est intéressant c'est ce qu'il y a à la fin du fichier.

Exemple chez moi :

moi@chezmoi:~$ ls /var/crash/
_usr_bin_onionshare-gui.1000.crash  _usr_bin_youtube-dl.1000.crash
moi@chezmoi:~$ vi /var/crash/_usr_bin_onionshare-gui.1000.crash

Et tout en bas du fichier _usr_bin_onionshare-gui.1000.crash je trouve :

ModuleNotFoundError: No module named 'distutils.spawn'

Ce qui m'indique la cause probable du crash. Dans cet exemple un module distutils. spawn qui serait absent de mon installation et qui est nécessaire à l'application Onionshare.

Share this post


Link to post
Share on other sites
  • 0

@Aris y'a encore des  utilisateurs de vi ! carrément rébarbatif mais pratique quand on n'a pas trop de modifs à faire

@icedragonPour prendre le problème dans l'autre sens, essaie de te souvenir de quelque-chose que tu aurais installé depuis le terminal en recopiant des instructions sur internet, autrement que par apt-get, par exemple une application de musique ?  Un module python installé par pip ?

 

Share this post


Link to post
Share on other sites
  • 0

Salut à tous,

En résumé, j'ai allumer l'ordinateur , hier écran noir pendant 1 mm, puis arrivé sur le bureau l'écran reste figé, donc je décide de tous réinstaller, pour l'instant tout à l'air de fonctionner, je me souvient avoir installer ajustement gnome et la meteo c'est peut-etre ça.

Merci de votre aide, je consulte souvent le forum si mes connaissance (maigre) peuvent aidé, j'interviendrais.

 

 

 

Share this post


Link to post
Share on other sites
  • 0

C'est un des problèmes avec les distribution GNU/Linux, il faut un peu faire gaffe à ce qu'on installe et qui n'est pas directement développé pour pour celle-ci. Le problème avec elementary c'est que c'est proche de GNOME... mais ce n'est pas GNOME... Même si normalement ce qui fonctionne avec GNOME devrait... Tu as compris. Moi lorsque je veux installé quelue chose et que j'ai un doute je regarde sur ce forum, et je fais une recherche sur le Web. Histoire de ne pas avoir à passer des heures à réparer.

Share this post


Link to post
Share on other sites
  • 0
Il y a 13 heures, icedragon a dit :

J'avais installé ces 2 applications  quand j'avais loki sans souci de fonctionnent.

Ajustement gnome fonctionne bien sur Juno, il n'est pas en cause.  La météo tout dépend laquelle, il y en a qui déconnent. De toute façon tu n'as rien fait de mal ça nous arrive à tous (c'est parce que je fais beaucoup de conneries que je passe beaucoup de temps à les réparer, à chaque fois j’apprends un truc)

Il y a 23 heures, icedragon a dit :

je consulte souvent le forum si mes connaissance (maigre) peuvent aidé, j'interviendrais

Avec plaisir. Dommage qu'on n'ait pas pu t'aider avant que tu doives tout réinstaller.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...