Jump to content
ElementaryOS France
  • 0
Sign in to follow this  
lenonlinuxien

problèmes avec epiphany et doc viewer

Question

Bonjour,

J'aime bien eOS, donc autant qu'il marche.

J'ai du mal à lancer epiphany. Comprenez que si je le lance, dans le dock il s'affiche comme s'il était lancé, mais j'essaie d'aller vers ce navigateur (alt tab ou sélectionner dans le dock), epiphany ne s'affiche pas. L'écran revient à ce que je faisais avant - par exemple Firefox.

J'ai eu aussi un cas similaire avec le pdf viewer fourni avec eOS cet après-midi. Des fois je tentais d'afficher une facture et si je tentais de passer au doc viewer (pareil alt tab ou dans le dock) ça ne fonctionnait pas.

Je me demande s'il y a une solution. Notez que dans les deux cas utiliser Firefox a résolu mon problème mais je voudrais bien ne pas trop dépendre de Firefox.

Peut-être que, tout simplement, la solution sera apportée par une prochaine mise à jour.

Je précise à ce sujet que j'ai fait mes mises à jour.

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 1

Ca fonctionne finalement...

En fait, epiphany semblait aller vers la droite quand je le lançais. J'ai donc fait Fenêtre + 2 pour aller dans le 2ème bureau (je crois qu'on dit comme ça) et là, miracle, je suis sur epiphany.

J'ai donc pu écouter, sur epiphany, 2 musiques sur Youtube histoire de tester.

Et ensuite je l'ai fermé, puis relancé, et plus besoin d'aller dans le deuxième bureau pour être sur epiphany.

J'appelle ça les mystères de l'informatique. J'espère que le problème ne réapparaîtra plus.

Merci pour ton aide.

Share this post


Link to post
Share on other sites
  • 0

Un détail intéressant. Si je lance epiphany dans le Terminal cela donne :

shinobi@shinobi-Satellite-P300:~$ epiphany-browser

** (epiphany:3174): WARNING **: 19:43:12.217: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of web processes is no longer possible for security reasons

 

Share this post


Link to post
Share on other sites
  • 0

Hello, 

ce message te dit que 2 navigateurs ne peuvent plus travailler en parallèle pour des raisons de sécurité, en gros tu dois en fermer un pour lancer l'autre.

Epiphany vise un public qui souhaite un navigateur tout léger, puisque tu as installé Firefox et qu'il te convient, tu peux désinstaller Epiphany qui aura toujours moins de fonctionnalités.

Share this post


Link to post
Share on other sites
  • 0

Bon, tu me dis que les 2 navigateurs ne peuvent pas être lancés en même temps, mais j'ai le message d'erreur même quand Firefox n'est pas lancé.

Share this post


Link to post
Share on other sites
  • 0

OK, le warning est toujours présent, un message pour les développeurs, la fonction appelée est obsolète.

Mais quand tu lances epiphany sans Firefox, directement ou en ligne de commande, comme tu veux , est-ce qu'il fonctionne ?

Share this post


Link to post
Share on other sites
  • 0

Que je tente de le lancer en ligne de commande ou depuis l'interface graphique, il ne fonctionne pas (que Firefox soit lancé ou non).

Il ne se lance pas, mais dans le dock il apparaît comme s'il était lancé.

 

En faisant clic droit sur epiphany dans le dock, j'ai :

Epingler au dock

Fermer

Nouvelle fenêtre

Nouvelle fenêtre privée

 

Mais si je clique-gauche sur epiphany dans le Dock, il ne se lance pas.

 

Share this post


Link to post
Share on other sites
  • 0

J'ai oublié de dire. Tout à l'heure, epiphany était affiché dans le dock comme s'il était lancé et j'ai fait une mise à jour. Elle s'est fait très lentement, ce qui à mon avis veut dire qu'epiphany était vraiment lancé.

Pour moi donc epiphany est lancé mais il refuse de s'afficher.

Comprenne qui pourra...

Share this post


Link to post
Share on other sites
  • 0

hum c'est très bizarre tout ça. tu peux me donner la version d'épiphany stp

epiphany --version

et puis, voilà que je deviens soupçonneuse :

snap list
flatpak list

 

Share this post


Link to post
Share on other sites
  • 0

shinobi@shinobi-Satellite-P300:~$ epiphany --version
Web 3.28.6

J'ai dû installer snap avec "sudo apt install snapd" et "snap install hello-world"

shinobi@shinobi-Satellite-P300:~$ snap list
Nom          Version    Révision  Suivi   Éditeur     Notes
core         16-2.42.5  8268      stable  canonical✓  core
hello-world  6.4        29        stable  canonical✓  -

"flatpak list" ne renvoit rien

 

Share this post


Link to post
Share on other sites
  • 0

Désolée mauvaise pioche, j'ai pensé à ça parce que tu disais que ta mise à jour avait pris du temps mais tu peux virer hello-world et core, c'était pas la bonne piste.

Share this post


Link to post
Share on other sites
  • 0

Le problème pourrait venir de tes paramétrages, epiphany fonctionne très bien dans cette version, rassure-toi.

essaie de supprimer epiphany, puis de supprimer son répertoire  de config :

Attention tu risques de perdre tes marques pages, si c'est important pour toi ne tape pas la commande, dis le moi , je te dirai comment les sauvegarder, sinon :

rm -r ~/.config/epiphany

puis  réinstaller epiphany

 

Share this post


Link to post
Share on other sites
  • 0

J'ai supprimé epiphany, lancé ta commande

rm -r ~/.config/epiphany

 

et réinstallé epiphany sous le nom de Gnome Web, mais je n'arrive toujours pas à le lancer.

Share this post


Link to post
Share on other sites
  • 0

Il est vraiment coriace ce problème. Il va falloir aller chercher dans les log.

Est-ce que tu aurais quelque chose qui concerne epiphany dans var/crash ?

Share this post


Link to post
Share on other sites
  • 0

essaie aussi de regarder avec

journalctl /usr/bin/epiphany --since "2020-01-10 07:00:00"

si tu vois autre chose que le message  dont tu as déjà parlé. 

Share this post


Link to post
Share on other sites
  • 0

rien dans file:///var/crash (depuis Files)

Ensuite j'ai lancé ta commande dans Pantheon Terminal :

shinobi@shinobi-Satellite-P300:~$ journalctl /usr/bin/epiphany --since "2020-01-01 07:00:00"
-- Logs begin at Wed 2020-01-01 20:43:36 CET, end at Thu 2020-01-16 18:25:06 CET. --
janv. 03 12:58:14 shinobi-Satellite-P300 epiphany[2952]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 03 16:58:15 shinobi-Satellite-P300 epiphany[3452]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 03 20:06:53 shinobi-Satellite-P300 epiphany[3483]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 03 22:15:56 shinobi-Satellite-P300 epiphany[1626]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 04 10:37:41 shinobi-Satellite-P300 epiphany[4900]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 04 12:01:46 shinobi-Satellite-P300 epiphany[3134]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 04 21:24:18 shinobi-Satellite-P300 epiphany[5326]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
janv. 04 21:34:21 shinobi-Satellite-P300 epiphany[5326]: epiphany: Fatal IO error 11 (Ressource temporairement non disponible) on X server :0.
-- Reboot --
janv. 07 07:49:21 shinobi-Satellite-P300 epiphany[1709]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
janv. 07 09:10:07 shinobi-Satellite-P300 epiphany[1709]: Failed to execute insert hash prefix statement: UNIQUE constraint failed: hash_prefix.value, hash_pref
janv. 07 09:10:07 shinobi-Satellite-P300 epiphany[1709]: Failed to execute insert hash prefix statement: UNIQUE constraint failed: hash_prefix.value, hash_pref
-- Reboot --
janv. 11 20:24:06 shinobi-Satellite-P300 epiphany[1935]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 12 23:11:14 shinobi-Satellite-P300 epiphany[4294]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 14 18:39:17 shinobi-Satellite-P300 epiphany[3533]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
janv. 14 18:40:15 shinobi-Satellite-P300 epiphany[3644]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
janv. 14 18:40:16 shinobi-Satellite-P300 epiphany[3644]: Failed to disable synchronous pragma: database is locked
janv. 14 18:40:16 shinobi-Satellite-P300 epiphany[3644]: Failed to create select metadata statement: database is locked
janv. 14 18:40:24 shinobi-Satellite-P300 epiphany[3694]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
janv. 14 18:40:42 shinobi-Satellite-P300 epiphany[3743]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
-- Reboot --
janv. 15 20:34:34 shinobi-Satellite-P300 epiphany[5392]: webkit_web_context_set_web_process_count_limit is deprecated and does nothing. Limiting the number of
lines 1-32/32 (END)


J'ai mis une date différence de la tienne, en espérant que je pourrais attraper plus de messages d'erreurs et que ça pourrait servir (mais c'est pas sûr).

 

 

Share this post


Link to post
Share on other sites
  • 0

Hello,

tu as posté ton problème le 7 janvier ce qui semble correspondre dans les logs au problème d'écriture d'un doublon dans la base de données.

Il y a 14 heures, lenonlinuxien a dit :

Failed to execute insert hash prefix statement: UNIQUE constraint failed:

Mais ce problème a dû disparaître avec la suppression de la base de données ( commande rm) , qui semble correspondre au 14 janvier.

Je me demande si la base a bien été supprimée, ou  si elle est restée parce que bloquée en écriture ?

Il y a 14 heures, lenonlinuxien a dit :

database is locked

essaie de la resupprimer, cette fois juste la base, avec epiphany non lancé, cette fois pas la peine de tout désinstaller. La base se recréera toute seule mais tu risques encore de perdre tes marques pages...

sudo rm -r ~/.config/epiphany/gsb-threats.db

et vérifie dans le répertoire

 cd   ~/.config/epiphany

si le fichier gsb-threats a bien disparu avant de relancer epiphany pour le recréer.

Share this post


Link to post
Share on other sites
  • 0

J'ai lancé dans le Terminal :

shinobi@shinobi-Satellite-P300:~$ sudo rm -r ~/.config/epiphany/gsb-threats.db
rm: impossible de supprimer '/home/shinobi/.config/epiphany/gsb-threats.db': Aucun fichier ou dossier de ce type

Je copie ici la commande que j'ai copiée collée dans le Terminal, aussi pour que tu puisses détecter si je fais une erreur.

 

Ensuite, si dans Files je vais dans file:///home/shinobi/.config/epiphany

je ne vois effectivement pas de fichier gsb-threats.db, mais il y a un dossier adblock(vide), des fichiers :

bookmarks.gvdb , cookies.sqlite , ephy-history.db , session_state.xml , session_state.xml~ , .migrated

 

En essayant de lancer epiphany, il ne marche toujours pas (j'ai tenté de lancer epiphany alors que j'écris ce message sous Firefox, qui est donc aussi lancé).

 

Par contre, après avoir tenté de lancer epiphany, un fichier gsb-threats.db et un ephy-history.db sont appurus dans file:///home/shinobi/.config/epiphany.

 

Je n'ai aucun marque-page dans epiphany. Je peux tout supprimer si nécessaire.

Share this post


Link to post
Share on other sites
  • 0

En lançant epiphany, maintenant il fonctionne. J'ai dû une fois lancer Fenêtre + 2 parce qu'il semblait s'être lancé dans le deuxième espace de travail, pourquoi je ne sais pas.

Maintenant il se lance normalement, plus besoin de Fenêtre 2 pour y accéder.

Merci pour ton aide.

Les mystères de l'informatique sont parfois hors de ma portée.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...