Jump to content
ElementaryOS France
  • 0
bjornzd

Installer un VPN : Cyberghost

Question

Bonjour,

J'essaye en vain d'installer le VPN payant Cyberghost sous Elementary OS mais n'y parviens pas,

si quelqu'un en sait plus sur comment l'adapter à cet OS merci de le partager ici :)

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hello @bjornzd,

Qu'est ce qui ne fonctionne pas ?

Peux-tu nous en dire plus ?

Nikos

Share this post


Link to post
Share on other sites
  • 0

Cyberghost est compatible avec les OS suivants

  • Ubuntu 16.04, 18.04, 19.04
  • Fedora 29, 30 & 31
  • Mint 19
  • CentOS 7
  • PopOS
  • Kali

Je suis étonné de la non compatibilité avec Elementary OS, du moins je n'y parviens pas.

Share this post


Link to post
Share on other sites
  • 0

Bonjour @bjornzd,

tu nous donnes là les compatibilités annoncées par le fabricant, cette liste n'est peut-être pas exhaustive. Elementary peut y être considéré comme un parent d' Ubuntu, qu'est-ce qui ne fonctionne pas ? Il te faudra peut-être un patch mais on ne peut pas t'aider sans un message d'erreur ou une description précise du problème rencontré. 

Tu peux sans doute aussi demander de l'aide au fabricant,  c'est dans leur intérêt puisqu'ils pourront citer une distribution de plus dans leur liste et attirer de nouveaux clients.

Share this post


Link to post
Share on other sites
  • 0

J'ai essayé pratiquement tous les programmes de chacun des OS cités ci-dessus pour une setup sur Elementary OS.

Pour Ubuntu j'obtiens le message suivant après essai d'installation du script sh :

Citation

Couldn't detect a valid version of your distribution. Make sure you are using Ubuntu 16, 18 or 19

Et ainsi de suite pour chaque distribution.

Je vais essayer de contacter les développeurs de Cyberghost, sait-on jamais s'ils peuvent concevoir une setup pour Elementary OS.

Share this post


Link to post
Share on other sites
  • 0

Peux tu nous donner le script ?

Il doit y avoir une commande du genre " lsb_release" et ça renvoie la version elementary OS et non Ubuntu

wolffy@InfinityOS:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	elementary
Description:	elementary OS 5.1.2 Hera
Release:	5.1.2
Codename:	hera

Du coup il faut l'adapter en conséquence.

Share this post


Link to post
Share on other sites
  • 0

@Wolf117Warrior a raison.

A la ligne 23, on recherche la version de elementary 5.1.2 mais il est attendu la version de ubuntu soit 18-04

essaie de modifier la ligne 23 de install.sh avec un éditeur (Code ou nano) : distroVersion=$(lsb_release -sr) par

distroVersion="18.04" 

 

Share this post


Link to post
Share on other sites
  • 0

Voici ce que j'obtiens après changement de la ligne 23 et exécution du script sh :

olivier@olivier-marais:~/Downloads/cyberghostvpn-ubuntu-19.04-1.3.1$ sudo sh ./install*
[sudo] Mot de passe de olivier :              
./install.sh: 4: [: Illegal number: 
-e 
CyberGhost Installer ...

Checking if glibc version is compatible
./install.sh: 29: [: 18.04: unexpected operator
./install.sh: 42: [: 18.04: unexpected operator
./install.sh: 55: [: 18.04: unexpected operator
./install.sh: 55: [: 18.04: unexpected operator
Couldn't detect a valid version of your distribution. Make sure you are using Ubuntu 16, 18 or 19

 

Share this post


Link to post
Share on other sites
  • 0

C'est l'instruction qu'on t'as donnée pour lancer l'installation ?

Essaie de le lancer avec sudo bash install.sh

Share this post


Link to post
Share on other sites
  • 0

Comme l'a dit Lafy, ce script n'est pas prévu nativement pour Elementary OS. Bien que développé sur une base Ubuntu 18.04, en modifiant ce script cela devrait fonctionner.

Je viens de faire le test avec le code de Lafy : j'ai bien pu installer ce vpn

Par contre, j'ai ce message d'erreur :

[4113] Error loading Python lib '/tmp/_MEIIge1hG/libpython3.7m.so.1.0': dlopen: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/_MEIIge1hG/libpython3.7m.so.1.0)

Je ne vois pas trop d'où vient le problème...

Share this post


Link to post
Share on other sites
  • 0

Petit problème de connexion sur ma box depuis quelques jours, je ne peux pas faire les manipulations ci-dessus, pour le moment.

Share this post


Link to post
Share on other sites
  • 0
Il y a 9 heures, burbigo1 a dit :

Cyberghost n'est pas compatibles avec MAC ou WIN ?

Si.

Share this post


Link to post
Share on other sites
  • 0

Essai depuis mon MacbookAir sur lequel j'ai installé ElementaryOS aussi :

olivier@olivier-MacBookAir:~/Programs/cyberghostvpn-ubuntu-19.04-1.3.2$ sudo bash install.sh

CyberGhost Installer ...

No LSB modules are available.
Checking if glibc version is compatible
The glibc version is incompatible, exiting setup...

 

Share this post


Link to post
Share on other sites
  • 0

Salut @bjornzd ,

il lance la commande suivante (essaie la) :

ldd --version | grep -i ldd | awk -F' ' {'print $5'}

qui renvoie la version de du compilateur c, il attend la version 2.27 : deux cas soit tu as une version plus récente donc c'est mieux et tu modifies la ligne 45 en conséquence, soit ta version est inférieure et une mise à jour devrait arranger le problème, tiens nous au courant...

Share this post


Link to post
Share on other sites
  • 0

J'ai bien la version 2.27 qui est renvoyée à cette commande.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Excuse moi, mais tu as bien modifié la ligne 23? parce que chez moi ce test passe nickel (j'ai empêché l'install en renommant le répertoire, c'est vrai, mais j'ai le bash passe)

Edit: Hum en bonus pour ceux qui comme moi auraient voulu tester l'install sans vouloir en garder des traces : supprimer le répertoire wireguard* dans /etc/apt/sources.list.d  (sudo rm - r wireguard*) fera l'affaire et supprimer le fichier wireguard* dans trusted.gpd.d

Edited by lafy

Share this post


Link to post
Share on other sites
  • 0

J'ai bien modifié la ligne 23 pour 19.04 (c'est la version employée), mais j'ai le message du dessus...

Share this post


Link to post
Share on other sites
  • 0
Le 08/03/2020 à 20:01, Nikos a dit :

Comme l'a dit Lafy, ce script n'est pas prévu nativement pour Elementary OS. Bien que développé sur une base Ubuntu 18.04, en modifiant ce script cela devrait fonctionner.

Je viens de faire le test avec le code de Lafy : j'ai bien pu installer ce vpn

Par contre, j'ai ce message d'erreur :


[4113] Error loading Python lib '/tmp/_MEIIge1hG/libpython3.7m.so.1.0': dlopen: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /tmp/_MEIIge1hG/libpython3.7m.so.1.0)

Je ne vois pas trop d'où vient le problème...

J'ai la même erreur que toi.

Share this post


Link to post
Share on other sites
  • 0

Tu as le même message que @Nikos ? Et tu as une version Ubuntu 19.04 ? alors il te demande la version libc6  2.30, vérifie quelle version tu as ?

Share this post


Link to post
Share on other sites
  • 0
olivier@olivier-MacBookAir:~$ sudo apt-get install libc6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6 is already the newest version (2.27-3ubuntu1).

 

Share this post


Link to post
Share on other sites
  • 0

En prenant la setup d'ubuntu 18.04 j'ai réussi à finir l'installation, le reste coule de source, merci à vous.

 

Si vous avez besoin de plus de précisions je reste disponible.

Share this post


Link to post
Share on other sites
  • 0

Problème, l'installation se passe bien sur mon macbookair mais pas sur mon pc (tous deux sous elementaryOS)

olivier@olivier:~/Downloads/cyberghostvpn-ubuntu-18.04-1.3.2/cyberghost$ cyberghostvpn --country-code FR
Perform authentication ...
Traceback (most recent call last):
  File "cyberghostvpn.py", line 761, in <module>
  File "cyberghostvpn.py", line 509, in main
  File "servers/traffic.py", line 13, in __init__
  File "libs/services.py", line 21, in __init__
  File "libs/locales.py", line 24, in __init__
  File "libs/user.py", line 37, in __init__
  File "libs/auth.py", line 55, in __init__
  File "libs/config.py", line 90, in getConfig
Exception: The section "account" is missing configuration file!
[6285] Failed to execute script cyberghostvpn

 

Share this post


Link to post
Share on other sites
  • 0

Salut @bjornzd,

le problème c'est qu'un logiciel propriétaire n'ouvre pas son source et n'est pas prévu pour être débuggé par l'utilisateur.

A mon avis cela sort maintenant du cadre de ce forum, il faut t'adresser au fournisseur.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...