Jump to content
ElementaryOS France
  • 0

eid-viewer installation on Elementary 0.4


raoul
 Share

Question

je ne sais pas installer eid-viewer sur votre dernière version , je reçois le message suivant "Dépend: libproxy1 (>=0.4.7) but it is not installable"

Merci d'avance

Raoul

PENDING.........EN ATTENTE

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Bonjour,

Merci beaucoup, Nikos et lafy, pour regarder tout ça! A tous les cas, c'est le logiciel eid qui est pas mis à jour régulièrement, non?

J'ai la version : elementary OS 5.1.7 Hera

J'ai fait

sudo apt-get install libcurl3

et toutes les autres commandes après (je pense que

sudo apt install ./eid-archive_2020.4_all.deb

n'était pas nécessaire mais je l'ai refait quand-même) et le lecteur de carte est installé! Merci beaucoup!

Je vais redémarrer et tester si ça marche...

Link to comment
Share on other sites

  • 0

Bonjour,

Je viens d'installer elementary, en suis très contente mais ai le même problème.

Par contre, je n'ai pas de compétences informatiques et copier/coller du texte dans le terminal est ma limite.

Voici la page d'aide du logiciel pour info:

https://eid.belgium.be/fr/installation-du-logiciel-eid-sous-linux

Est-il possible de l'installer sur elementary?

Ensuite, serait-il possible de recevoir de l'aide pour installer le dit logiciel?

Merci dans tous les cas!

Bonne journée,

Link to comment
Share on other sites

  • 0

Bonjour @Fanny et bienvenue sur elementary

je ne connais pas ce logiciel, mais suivant les indications qu'ils donnent, le .deb prévu pour ubuntu est compatible et il t'installe un ppa.

Ensuite :

sudo apt-get update

pour mettre à jour tes paquets disponibles puis on te propose d'installer le logiciel soit depuis l'app center, soit :

sudo apt-get install eid-viewer

il est question ensuite de tester une carte, et là tu sais sans doute mieux que moi de quoi il s'agit, tiens nous au courant ...

Link to comment
Share on other sites

  • 0

Bonjour lafy,

E: Impossible de trouver le paquet eid-viewer
Merci beauoup pour ta réponse!

C'est un logiciel pour lire les cartes d'identité et se connecter sur les plateformes du gouvernement, surtout pour payer ses taxes. D'où tester une carte.

J'ai:

1. télécharger le .deb sur le site

2. copier coller les 2 commandes dans le terminal

et la 2ème commande me rend "E: Impossible de trouver le paquet eid-viewer".

J'imagine qu'il ne faut pas juste télécharger le .deb mais en faire quelque chose après?

Link to comment
Share on other sites

  • 0

Hello @Fanny,

Comme tu as déjà téléchargé le package deb, il ne reste plus grand chose à faire. Dans mon exemple, je pars du principe que tu as téléchargé le package deb dans ton dossier Téléchargements, si ce n'est pas le cas, à toi d'adapter en conséquence. Dans l'ordre, on va faire :

  1. Installer le package deb avec la ligne de commande (je te donnerai la commande qui va bien).
  2. On mettra ensuite la liste des logiciels à jour.
  3. On terminera par l'installation des packages nécessaires.

Pour installer le package deb qui se trouve dans le dossier Téléchargements, tu peux faire :

cd Téléchargements
sudo apt install ./eid-archive_2020.4_all.deb

Si tout se passe bien tu devrais avoir un bout de texte équivalent à ça:

WARNING: Unsupported distribution found. Please see the website at
https://eid.belgium.be/en/faq/which-linux-distributions-are-supported#7406
for a list of supported distributions.
Unknown distribution found. Using xenial as fallback.

Creating config file /etc/apt/sources.list.d/eid.list with new version
Repository enabled, keys installed. Please run "apt-get update" followed by
"apt-get install eid-mw eid-viewer" to install the middleware and the viewer, respectively.

Si c'est le cas, pas de crainte, la première installation est bien terminée. On passe à la deuxième, pour cela, j'utilise les commandes indiquées + une petite commande avant celle indiquée :

sudo apt-get update

Puis

sudo apt install eid-mw eid-viewer

A la fin de cette étape, si tout se passe bien, tu pourras trouver l'icone "Lecteur de Carte eID" dans le menu Applications.

Nikos

Link to comment
Share on other sites

  • 0

Et c'est presque exactement ce qu'il s'est passé. Merci beaucoup, Nikos!

A la fin, j'ai juste eu :

 

Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 eid-viewer : Dépend: libcurl3 (>= 7.16.2) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


J'imagine que ça veut dire qu'il faudrait d'abord installer ce "libcurl3"?

Link to comment
Share on other sites

  • 0

L'erreur ne vient pas de vous, c'est une dépendance nécessaire qu'ils auraient dû l'intégrer à leur code d'installation

Rien n’empêche d'installer libcurl3, on en est à libcurl4 mais on peut installer la version3  :

sudo apt-get install libcurl3

Puis recommencer les étapes de @Nikos

PAr contre, quand ça commence comme ça, il y aura peut-être d'autres dépendances surprises à rajouter.

  • Thanks 1
Link to comment
Share on other sites

  • 0

@lafy,

Je suis un peu surpris que @Fanny ne puisse pas installer libcurl3, normalement avec la commande fourni, apt va automatiquement résoudre les dépendances (et au passage ça remplace gdebi de ce fait, mais c'est un autre sujet) via le fichier deb donné.

Tu as une idée ce qui pourrait poser soucis ?

Nikos

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...