Jump to content
ElementaryOS France
  • 0

Le micro ne marche pas, du tout.


Fanny
 Share

Question

Bonjour,

 

Comme le titre l'indique, le micro de mon pc ne marche pas du tout sous Linux.

 

Le contexte

 

Je suis en DualBoot avec Windows et, sous Windows, il marche très bien.

J'avais Deepin avant (aussi Debian) et le micro ne marchait pas non plus.

J'avais un casque et le micro du casque marchait très bien alors j'ai ignoré ce problème. Mais mon casque s'est cassé et doit être remplacé alors je me suis dit qu'il était peut-être temps de résoudre ce problème.

Entre-temps, je peux redémarrer en Windows pour utiliser mon micro donc ce n'est pas urgent, juste long...

 

Solutions essayées

 

Je ne m'y connais pas beaucoup en informatique et ai suivis des solutions proposées dans des postes précédents ici et sur le stack en anglais. Excusez-moi si j'explique mal ce que j'ai fait, je fais de mon mieux.

Mon micro n'est pas détecté dans les paramètres ou sur pavucontrol (voir capture d'écran).

J'ai aussi essayé la commande alsamixer (voir capture d'écran.) Mon micro était en mute, je l'ai 'unmuté' et ai augmenté la sensibilité du micro et de son boost (on sait jamais). J'ai fait tab et suis allée dans 'capture'. Je pense que c'était désactivé et l'ai activité (j'ai tapé espace).

J'avais alors un petit icône micro en haut de mon écran mais elle a disparu maintenant. Rien d'autre n'a changé.

 

Y aurait-il une solution?

 

Merci dans tous les cas,

 

 

* J'ai essayé de réduire la taille de ces images mais n'y arrive pas... Désolée.

 

pavucontrol

pavucontrol.thumb.png.631e89e0dfbb09db03e39284e40cfd55.png

 

alsamixer

alsamixer.png

 

alsamixer capture

alsamixer capture.png

Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Salut @Fanny

ta question s'était perdue... rien que de te répondre ça va la remonter.

Quand tu vas dans alsamixer, tu ne peux plus remonter speaker à fond  ?

Link to comment
Share on other sites

  • 0

Merci pour ta réponse!

Pas de problème, c'est vraiment pas urgent :)

Je peux. Ce sont les speakers externes, donc quand j'écoute de la musique sans écouteurs. Là, j'avais mes écouteurs. D'où que 'headphone' était à 100 et 'speaker' à 0.

J'ai essayé de les changer mais ça n'a pas d'effet sur le micro...

Link to comment
Share on other sites

  • 0

oui je suis désolée @Fanny j'ai juste dit une bêtise pour remonter ton post mais je n'ai pas les compétences, il faut attendre @Nikos

Peut-être explorer ton matériel avec lshw et chercher un driver mais je ne peux pas t'aider.

Link to comment
Share on other sites

  • 0

Quelques pistes en attendant,

- apparemment c'est dans la carte son qu'est aussi géré le micro donc si tu fais F6 dans alsamixer regarde si tu n'as pas une autre carte son à essayer

Sinon est-ce que ta machine est très récente ou très ancienne ? Si elle est récente essaie d'upgrader le noyau (en restant sur Hera)

Link to comment
Share on other sites

  • 0

Où est-ce que tu en es Fanny? Si tu as toujours ce problème de micro, peux tu me donner le résultat de

pacmd list-cards

pour vérifier si tu as plusieurs profils input

Link to comment
Share on other sites

  • 0

Salut lafy,

Merci de revenir vers moi!

Depuis, j'ai récupéré mon casque avec micro et ne sais toujours pas quoi faire avec le micro de l'ordi... Donc je dirais que j'ai abandonné?

Il y a un profile input:

        input:analog-stereo: Entrée Stéréo analogique (priority 60, available: no)

Link to comment
Share on other sites

  • 0

Merci!

Et, désolée, je ne comprends pas ceci:

Then add the following to /etc/modprobe.d/snd-hda-intel.conf: 

Est-ce que je dois le copier tel quel dans le terminal?

De plus, le micro apparaît avec capture... Donc je ne comprends pas bien ce que je dois faire et obtenir comme résultat.

... Ou c'est ce que je pensais. En fait, c'est pas 'mic' mais 'mic boost'. Est-ce que ça change quelque chose?

Link to comment
Share on other sites

  • 0

Honnêtement Fanny, je suis hors de ma zone de compétence mais il se trouve que j'en ai 3 sur le deuxième panneau (micoboost ,capture et internal micro boost)

Du coup s'il t'en manque un, ça vaut ptêtre le coup d'essayer d'obtenir le dernier

ils disent que tu dois copier la ligne dans le fichier donc depuis le terminal :

sudo nano /etc/modprobe.d/snd-hda-intel.conf

tu insère la ligne :  options snd-hda-intel enable_msi=1

puis ctrl X pour sortir Y (pour yes) et entrée pour confirmer

ensuite lancer la commande qu'ils te donnent # rmmode pour relancer et voir si tu as une entrée de plus.

Link to comment
Share on other sites

  • 0

Pareil pour moi. Je suis bien au-delà de mes compétences, mais j'essaie. Et c'est ce qui compte, non? :)

 

Alors, au début, je comprenais rien. Mais j'ai relu plusieurs fois et pense avoir compris.

Il y a juste la commande:

# rmmod snd-hda-intel && modprobe snd-hda-intel

qui ne donne rien. Mais peut-être c'est normal?

 

A la fin, le contenu de alsamixer ne change pas. J'ai toujours 'Mic' et 'Mic Boost', aucun 'internal micro' mentionné.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...